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Introduction
Draw is a vector graphics drawing tool, although it can also perform 
some operations on raster graphics (pixels). Using Draw, you can 
quickly create a wide variety of graphical images.

Vector graphics store and display a picture as simple geometric 
elements such as lines, circles, and polygons rather than as a 
collection of pixels (points on the screen). This permits simpler storage 
and supports precise scaling of the picture elements.

Draw is fully integrated into the OpenOfce.org (OOo) suite, and this 
simplifes exchanging graphics with all components of the suite. For 
example, if you create an image in Draw, reusing it in a Writer 
document is as simple as copying and pasting the image. You can also 
work with drawings directly from within Writer or Impress, using a 
subset of the functions and tools from Draw.

Draw’s functionality is extensive, and even though it was not designed 
to rival high-end graphics applications, it possesses signifcantly more 
functionality than the drawing tools that are generally integrated with 
most ofce productivity suites.

A few examples of the drawing functions are: layer management, 
magnetic grid-point system, dimensions and measurement display, 
connectors for making organization charts, 3D functions that enable 
small three-dimensional drawings to be created (with texture and 
lighting efects), drawing and page-style integration, and Bézier 
curves.

The Draw Guide is not a course book to be worked through from 
beginning to end. Rather, it is a reference work in which you can 
browse for guidance on particular topics.

This document describes only the functions associated with Draw. 
Some concepts, such as fle management or the way the 
OpenOfce.org environment works, are mentioned only briefy; they 
are covered in more detail in the Getting Started guide.
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The Draw workplace
The main components of the Draw interface are shown in Figure 1.

The large area in the center of the window is where you make the 
drawings. You can surround the drawing area with toolbars and 
information areas. The number and position of the visible tools vary 
with the task in hand and user preferences. Therefore, your setup may 
look diferent. For example, many users put the main Drawing toolbar 
on the left-hand side of the workspace—not at the bottom, as shown 
here. The setup procedure is described in detail in Chapter 4 (Menus 
and Toolbars) in the Getting Started guide.

You can split drawings in Draw over several pages. Multipage drawings 
are used mainly for presentations. The Pages pane, on the left side of 
the Draw window in Figure 1 gives an overview of the pages that you 
create. If the Pages pane is not visible on your setup, you can enable it 
from the View menu (View > Page Pane). To make changes to the 
page order, just drag and drop one or more pages.

In Draw 3, the maximum size of a drawing page is 300 cm by 300 cm.

Figure 1: Initial Draw window
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Rulers
You should see rulers (bars with numbers) on the upper and left-hand 
sides of the workspace. If they are not visible, you can enable them by 
selecting them from the View menu (View > Ruler).

The rulers show the size of a selected object on the page (see the gray 
double lines, highlighted in Figure 2). When no object is selected, they 
show the location of the mouse pointer, which helps to position 
drawing objects more accurately.

You can also use the rulers to manage object handles and guide lines, 
making it easier to position objects.

The page margins in the drawing area are also represented on the 
rulers. You can change the margins directly on the rulers by dragging 
them with the mouse.

Figure 2: Rulers show the size of 
the selected object

To modify the units of measurement of the rulers (which you can defne 
independently), right-click on the desired ruler, as illustrated for the 
horizontal ruler in Figure 3.

Figure 3: Rulers in a drawing
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Status bar
The Status bar is located at the bottom of the screen (in all OOo 
components) and includes several Draw-specifc felds, as identifed in 
Figure 4.

Figure 4: Items on the Draw status bar

The Information feld shows which action is being carried out, or which 
object type is selected.

The Position feld shows diferent information, depending on whether 
objects are currently selected or not:

• When no object is selected, the left number pair shows the 
current position (in X,Y Cartesian coordinates) of the mouse 
cursor.

• While an object is being resized with the mouse, the right number 
pair shows the size of the object (width and height).

Note

The sizes are given in the current measurement unit (not to be 
confused with the ruler units). This unit is defned in Tools > 
Options > OpenOfce.org Draw > General, where you can 
also change the scale of the page. Another way to change the 
scale is to double-click on the number shown in the status bar.

• If an object is selected, the left number pair shows the X,Y 
coordinates of the upper-left corner, and the right number pair 
displays the size of the object, as seen in Figure 4. These numbers 
do not relate to the object itself, but to the selection outline, 
which is the smallest possible rectangle that can contain the 
visible part or parts of the object; see also Chapter 3 (Working 
with Objects and Object Points).

• When an object is selected, a double-click on this feld opens the 
Position and Size dialog, which is described in detail in Chapter 4 
(Changing Object Attributes).
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In the Indicator feld, an asterisk (*) is shown whenever any change is 
made to the document but not yet saved to disk.

If you wish to digitally sign the document, a double-click or right-click 
in the Signature feld brings up the signature box. Note that a 
document must be saved at least once before it can be signed. After it 
is signed, an indicator is present in this feld.

The Slide feld shows the sequence number for the current drawing 
page, in addition to the total number of pages that you created so far. 
This is useful when your drawing has a number of pages. If you select 
an object, the feld enclosed by parentheses shows the layer in which 
the object resides within the drawing. In the example of Figure 4, the 
object is on the Layout layer of Slide 1, and there is a total number of 
one slide, so far.

The Template feld shows which page template is being used for the 
current page. If you saved several slide designs, you can select one for 
the current page by double-clicking in this feld (see Figure 5) and 
selecting Load after choosing a slide design.

Figure 5: Selecting a slide (page) design

The vertical bar in the middle of the Zoom slider represents a zoom 
factor of 100%. To change the view magnifcation, drag the Zoom 
slider, or click on the + and – signs, or right-click on the zoom level 
percent to pop up a list of magnifcation values from which to choose. 
Double-clicking on the zoom level percent to open the Zoom & View 
Layout dialog.
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Toolbars
You  can display or hide the various Draw toolbars, according to your 
needs. To display or hide a toolbar, click View > Toolbars. On the 
menu that appears, choose which toolbars you want to display.

You can also select the icons that you wish to appear on the toolbars. 
Toolbars display a default selection of icons but you can choose to hide 
some of these and display others. To change the visible icons on any 
toolbar, click the arrow at the right-hand end of the toolbar and select 
Visible Buttons. On the list of the available icons that appears, select 
or deselect the icons you want to be visible. A checkmark next to an 
icon indicates that it is visible.

The tools available in the various toolbars are explained in the 
following sections.

Standard toolbar
The Standard toolbar is the same for all OOo components and is not 
described in detail here.

Figure 6: Standard toolbar

Line and Filling toolbar
The Line and Filling toolbar lets you modify the main properties of a 
drawing object: the icons and pull-down lists vary, according to the 
type of object selected. For example, to change the thickness of a line 
with the spinner, hover the mouse over the spinner and click the up or 
down arrow to achieve the desired thickness.

Figure 7: Line and Filling toolbar

In the example above, the available functions enable you to change the 
color, style, and width of the line drawn or the fll color, style, and 
other properties of an object. The object must frst be selected with a 
mouse click. If the selected object is a text frame, the buttons for line 
style and fll color are changed to Invisible.

When text is selected, the Line and Filling toolbar changes to the Text 
Formatting toolbar, which is very similar to the Formatting toolbar in 
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Writer. A more detailed explanation of the buttons on this toolbar can 
be found in Chapter 4 (Changing Object Attributes).

Figure 8: Text Formatting toolbar

Drawing toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains 
all the necessary functions for drawing various geometric and freehand 
shapes and for organizing them on the page. It is described in detail in 
Chapter 2 (Drawing Basic Shapes).

Figure 9: Drawing toolbar

Color bar
To display the Color bar, use View > Toolbars > Color Bar. The 
toolbar then appears at the bottom of the workspace and displays the 
current color palette.

Figure 10: Color bar

This toolbar lets you rapidly choose the color of the various objects 
(lines, areas, and 3D efects) in your drawing. The frst box in the panel 
corresponds to transparency (no color).

Choosing a color palette
You can access several specialized color palettes in Draw, as well as 
change individual colors to your own taste. This is done using the Area 
dialog, reached by choosing Format > Area, as shown in Figure 11, or 
the pouring can icon on the Line and Filling toolbar (Figure 7).

On the Area dialog, choose the Colors tab (Figure 12).

To load another palette, click on the Load Color List button (circled). 
The fle selector dialog asks you to choose one of the standard OOo 
palettes (fles bearing the fle extension *.soc). For example, web.soc 
is a color palette that is particularly adapted to creating drawings that 
are going to appear in Web pages. The colors will correctly display on 
workstations with screens displaying at least 256 colors.
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Figure 11: Displaying the Area 
dialog from the menu bar

A more detailed description of color palettes and their options can be 
found in Chapter 8 (Tips and Tricks).

.
Figure 12. Changing the color palette
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Options toolbar
The Options toolbar lets you activate or deactivate various drawing 
aids. The Options Bar is not one of the toolbars displayed by default. To 
display it, select View > Toolbars > Options.

Figure 13: Options toolbar

Table 1: Functions on the Options toolbar

Icon Function

Rotation Mode after Clicking Object

Display (or hide the) Grid

Display (or hide the) Guides

Display (or hide Guides) When Moving

Snap to Grid

Snap to Guides

Snap to Page Margins

Snap to Object Borders

Snap to Object Points

Allow Quick Editing

Select Text Area Only

Double-click to edit Text

Simple Handles

Large Handles

Modify Object with Attributes

Exit All Groups
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The options are described in the table above and in greater detail in 
other chapters of the Draw Guide.

Drawing grid and guides
Draw ofers a grid as a drawing aid. The grid can be turned on or of by 
clicking on the Grid icon on the Options toolbar. The points of the grid 
displayed on the screen are not shown on the printed drawing. The 
color, spacing, and resolution of the grid points can be individually 
chosen for each axis. This is described in more detail in Chapter 8 (in 
the section titled “Confguring the grid”).

Guides are special “helper lines” that can be turned on or of by 
clicking on the Guides icon on the Options toolbar. Draw ofers a 
“Snap” function, with which you can place drawings exactly on these 
guides or on a grid point, a page margin, or a border or point of 
another object. All snap functions are described in detail in Chapter 8 
(Tips and Tricks).

Showing the position of the object while moving it makes positioning 
the object much easier. If the Guides function is activated, pairs of 
vertical and horizontal lines enclosing the object are shown while 
moving the object. These lines extend to the edges of the drawing area. 
This function is also described in detail in Chapter 8.

Floating and moving toolbars
Many toolbar icons are marked with a small arrow. The arrow indicates 
that this icon has additional functions. Click the arrow, and a submenu 
appears, showing its additional functions (see Figure 14). Such an icon, 
and its associated submenu, can become a foating toolbar. Click the 
area at the top of the submenu, drag it across the screen to a location 
you want, and then release the mouse button. Floating toolbars can be 
redocked on an edge of the screen or within one of the existing toolbar 
areas at the top of the screen, as described in Chapter 4 (Changing 
Object Attributes). The foating-toolbar capability is common to all 
components of OOo.

Note

When a submenu is made into a foating toolbar, the icon on the 
existing toolbar remains in the toolbar and always shows the last 
command you used. This means that the icon you see on your 
screen may difer from any icon shown in this Guide.
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Figure 14: An arrow next to an icon 
indicates additional functions.

Tip

When you double-click on an icon on a foating toolbar, the 
command corresponding to that icon will run. You can then 
repeat this action as often as you like. To exit from this mode, 
press the Esc key or click on another icon (for example ). This 
may not work for every icon on every toolbar.

Similarly, click on the arrow on the title bar of a foating toolbar to 
display additional functions (see Figure 15).

Figure 15: An arrow on a foating toolbar indicates 
that there are additional functions available.

To show or hide icons defned for the selected toolbar, choose Visible 
Buttons from the drop-down menu. Visible icons have a checkmark 
next to them. Click on icons to select or deselect them.

In Draw, as in all OOo components, you can move a toolbar to a new 
position by using the mouse. Hover the mouse pointer over the vertical 
column of dots  at the left end of the toolbar until the pointer changes 
shape, and then drag-and-drop as desired.
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Customizing toolbars
You can customize toolbars in several ways, in addition to those 
described in the previous section. For example, you can add functions 
to a toolbar, move tools between toolbars, and create new toolbars. To 
do this, choose View > Toolbars > Customize, select the Toolbars 
tab (Figure 16) and the toolbar you want to change, and then select the 
desired buttons for that toolbar. Each toolbar has a diferent list of 
buttons. For details, see Chapter 14 (Customizing OpenOfce.org) in 
the Getting Started guide. That chapter also describes how to 
customize menus.

Figure 16: Customizing a toolbar
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Creating simple drawings
You can create 2D and 3D objects in Draw. This chapter shows how to 
draw simple 2D objects. The following chapters describe how to work 
with and edit such objects.

All shapes, whether they are lines, rectangles, or more complicated 
shapes, are called objects. This is common notation in vector drawing 
software.

The drawing tools are found on the Drawing toolbar. Figures 17 and 30 
show parts of the standard form of the toolbar, as installed with Draw.

As described in Chapter 1 (Introducing Draw), the Drawing toolbar is 
normally located at the bottom of the window. If you do not see it, you 
can activate it from the View > Toolbars menu. As in all components 
of OpenOfce.org, you can place the toolbar on the Draw window 
wherever you wish, and you can confgure toolbars as you wish by 
adding, moving, hiding, or deleting toolbar icons.

Custom shapes
Draw 3 ofers the ability to create custom shapes. These correspond to 
autoshapes in Microsoft Ofce. The shape elements used in version 1 
of Draw are still available, but their use is now deprecated and support 
for them may be dropped in some future version of OOo.

The two types of shapes difer in their properties and are dealt with 
separately in the relevant chapter of this guide. The main diferences 
relate to the behavior of 3D objects and text handling. Beginners can 
safely ignore both for the present.

Text frames in Draw 3 have their own geometric format.

Drawing basic shapes
Basic shapes include:

• Lines
• Arrows
• Rectangles and squares
• Ellipses and circles
• Curves and polygons
• Connectors
• Lines and arrows
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Note

When you draw a basic shape or select one for editing, the 
Information feld in the status bar changes to refect the action 
taken or in progress: Line created, Text frame xxyy selected, 
TextEdit: Paragraph 1, Row 1, Column 8 and so on.

Figure 17 shows part of the Drawing toolbar with the icons needed in 
the following sections. The Text icon is also included.

Figure 17: Part of the Drawing toolbar

Drawing a straight line
We begin with the drawing of the simplest element—a straight line.

Click on the Line icon  on the Drawing toolbar and place the mouse 
pointer at the point where you want to start the line (see Figure 18). 
Drag the mouse while keeping the mouse button pressed. Release the 
mouse button at the point where you want to end the line. A blue 
selection handle appears at each end of the line, showing that this is 
the currently selected object.

Holding down the Shift key while you draw a line restricts the angle of 
the line to a multiple of 45 degrees (0, 45, 90, 135, and so on).

Caution
This is the default behaviour of the Shift key. However, if you 
have used Tools > Options > OpenOfce.org Draw > Grid 
to set Snap position to When creating or moving objects, the 
action of the Shift key is the opposite: lines will always be at a 
multiple of 45 degrees unless the Shift key is pressed.

Figure 18: Drawing a straight line
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Keeping the Ctrl key pressed while drawing a line enables the end of 
the line to snap to the nearest grid point.

Caution
The efect of the Ctrl key depends on the settings of the Snap to 
Grid option on the View->Grid menu:
Snap to Grid on: Ctrl deactivates the snap option for this 
activity.
Snap to Grid of: Ctrl activates the snap option for this activity.

The spacing (resolution) of the grid points can be adjusted under Tools 
> Options > OpenOfce.org-Draw > Grid. See also Chapter 8 (Tips 
and Tricks).

Holding down the Alt key while drawing a line results in the line 
extending outwards symmetrically in both directions from the start 
point. This lets you draw lines by starting from the middle of the line.

The line just drawn has all the standard line attributes, such as color 
and line style. To change any of these properties, select the line by 
clicking on it, then right-click and select Line.

Figure 19: The information area in the status bar

While you are working with a line (or any other element), you can use 
the information feld on the status bar to monitor the activity. A 
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description of the current activity or selection is shown when you are 
working with elements. Figure 19 shows two examples.

Drawing an arrow
Arrows are drawn like lines. Draw classifes arrows as a subgroup of 
lines: lines with arrowheads. The information feld on the status bar 
shows them only as lines. Click on the Line Ends with Arrow icon  
to draw an arrow.

Drawing lines and arrows

Click on the small black triangle on the Lines and Arrows  icon on 
the Drawing toolbar to open a toolbar with ten tools for drawing lines 
and arrows (Figure 20). (View > Toolbars > Arrows opens the toolbar 
as a foating toolbar.) In both cases, the last-used command will be 
stored on the toolbar to make it quicker to call it up again: click 
directly on the symbol to repeat the last used command chosen from 
this toolbar.

After drawing the line, you can change the arrow style by clicking on 
the Arrow button in the Line and Filling toolbar and choose from 13 
arrow start and end options.

Figure 20: Lines and Arrows toolbar

Drawing a rectangle or square
Drawing a rectangle is similar to drawing a straight line, except that 
you click on the Rectangle icon  on the Drawing toolbar, and the 
(imaginary) line drawn by the mouse corresponds to a diagonal of the 
rectangle. In addition, the outline of the future rectangle changes 
shape as you drag the mouse around. The outline may be shown as a 
dashed line until you release the mouse button.
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Figure 21: Drawing a rectangle

Draw considers squares to be rectangles with sides of equal length. 
Hold down the Shift key to draw a square. Hold down the Alt key while 
dragging with the mouse to create a rectangle with its center (rather 
than a corner) at the start point (where you frst clicked the mouse).

Note

Blue or green selection handles appear around an object made 
up of more than 2 points, showing that this is the currently 
selected object. The colors depend on the standard selection 
mode—green with a normal selection or blue if you are in the 
point edit mode. This efect is easily seen if both Simple 
Handles and Large Handles are switched on in the Options 
toolbar. See Chapter 3 for more details on points.

Drawing ellipses (ovals) and circles
To draw an ellipse (also called an oval) or a circle, click on the Ellipse 
icon  on the main Drawing toolbar. (A circle is simply an ellipse with 
both axes the same length.) The ellipse drawn is the largest ellipse that 
fts within the (imaginary) rectangle drawn by the mouse (Figure 22).

Figure 22: Drawing an ellipse

There are three ways to draw an ellipse or a circle:

• Holding down the Shift key while dragging with the mouse draws 
a circle.

• Holding down the Alt key (together with the Shift key) draws a 
symmetrical ellipse (a circle) with the starting point at the center.
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• Holding down the Ctrl key while dragging with the mouse draws 
an ellipse or circle that snaps to the nearest grid points.

Note

If you frst press and hold the Ctrl key down and then click on 
one of the icons for Line, Rectangle, Ellipse or Text, a standard 
sized object is drawn automatically in the work area: the size, 
shape, and color are all standard values. These attributes can 
be changed later, if desired. This only works if the icon has no 
associated toolbar—no arrow on right side of icon—for example, 

.

Adding ellipse and arc tools to the Drawing toolbar
In previous versions of Draw, a long-click on the ellipse button opened 
a new toolbar that contained tools for drawing elliptical and circular 
arcs. This function is not directly available in Version 3.

If you really need this tool, you can add an Ellipse toolbar to the 
Drawing toolbar:

1) Click on the arrow on the right-hand end of the Drawing toolbar 
and select Customize Toolbar.

2) On the Toolbars page of the Customize dialog, select Drawing in 
the Toolbar feld and click Add.

3) In the Add Commands dialog (Figure 23), select Drawing in the 
Category list, select the frst Ellipse command in the Commands 
list, click Add, and then click Close.

Figure 23: Adding the extended Ellipse toolbar
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4) On the Customize dialog, ensure that the checkbox by the new 
Ellipse command is selected, and then use the up and down 
arrow buttons to move it to the desired position on the toolbar.

5) To remove the simple Ellipse icon from the Drawing toolbar, click 
to highlight it in the Customize dialog, and press the Delete key 
(or click the Modify button and choose Delete from the drop-
down menu).

6) Click OK to complete the process.

You should now see this Ellipse icon  on the Drawing toolbar. If 
you use this icon instead of the standard Ellipse icon, all the extended 
ellipse functions are available. Clicking on the black arrow by the icon 
opens the foating Circles and Ovals toolbar (Figure 24).

Figure 24: Circles and Ovals toolbar

Drawing elliptical and circular arcs
To draw an arc, choose the appropriate Arc 
symbol in the Circles and Ovals toolbar. 
Drag with the mouse to create a guide circle 
or ellipse.

Release the mouse button and move the 
cursor to the position where you want the arc 
to start. In the status bar, you can measure 
the actual angle in degrees. Single-click this 
point; the circle (or ellipse) disappears and 
moving the mouse creates the arc. Again, the 
status bar shows the current angle.

When you have drawn the arc to the length 
you want, click once more. The drawing of the 
arc is complete.

Curves
The tools for drawing curves or polygons are on the toolbar that 
appears when you click the Curve icon  on the Drawing toolbar. 
This toolbar contains eight tools (Figure 25).
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Note
Hovering the mouse pointer over this icon gives a tooltip of 
Curve. If you convert the icon to a foating toolbar, however, the 
title is Lines, as shown in Figure 25. 

Figure 25: Floating Curves toolbar (incorrectly titled “Lines”)

If you move the mouse cursor over one of the icons, a tooltip pops up 
with a description of the function. For a more detailed description of 
the handling of Bézier curves (curves and flled curves), see Chapter 
10 (Advanced Draw Techniques).

• Polygons: Draw the frst line from the start point with the left 
mouse button held down. As soon as you release the mouse 
button, a frst corner point is drawn; move the mouse to see how 
subsequent lines will look. Every mouse click sets another corner 
point. A double-click ends the drawing. A flled polygon 
automatically joins the last point to the frst point to close of the 
fgure and flls it with the current standard fll color. A polygon 
without flling will not be closed at the end of the drawing.

• Polygon 450: Like ordinary polygons, these are formed from lines 
but with angles of only 45 or 90 degrees between them.

• Freeform Line: With this tool you can draw just like with a pencil. 
Press and hold the left mouse button and drag the mouse. It is not 
necessary to end the drawing with a double-click. Just  release the 
mouse button and the drawing is completed. If you have selected 
Freeform Line, Filled, the end point is joined automatically to the 
start point and the object is flled with the appropriate color.

Gluepoints and connectors (basics)

Gluepoints
All Draw objects have associated invisible gluepoints, which become 
visible when you choose any of the connectors under the Connectors 
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icon  on the Drawing toolbar and then move the mouse pointer 
over the object.

Most objects have four gluepoints, as shown in Figure 26. You can add 
more gluepoints, and customize gluepoints, using the toolbar of the 
same name (Figure 27).

Figure 26: Four gluepoints

Figure 27: Gluepoints toolbar

Gluepoints are not the same as the little blue or green “handles” of an 
object. The handles are for moving or changing the shape of an object, 
as described in Chapter 3 (Working with Objects and Object Points), 
but the gluepoints are used to “glue” a connector to an object.

For a more detailed description of the use of gluepoints, see Chapter 9 
(Organization Charts, Flow Diagrams, and More).

Connectors
Connectors are lines or arrows whose ends automatically dock to a 
gluepoint of an object. Connectors are especially useful in drawing 
organization charts, fow diagrams, and mind-maps. Even when objects 
are moved or reordered, the connectors remain attached. 

Figure 28 shows two Draw objects and a connector.
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Figure 28: A connector between two objects

Draw ofers a range of diferent connectors and connector functions. 
Open the foating Connectors toolbar by clicking on the arrow next to 

the Connector icon  (Figure 29).

Figure 29: The Connectors toolbar

For a more detailed description of the use of connectors, see Chapter 9 
(Organization Charts, Flow Diagrams, and More).

Drawing geometric shapes
Geometric shapes include:

• Basic shapes
• Symbol shapes
• Block arrows
• Flowcharts
• Callouts
• Stars
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Note
If you select shapes for editing, the information feld in the 
toolbar shows the type of shape selected and, if more than one 
object is selected, the total number.

Figure 30 shows part of the Drawing toolbar with the icons referred to 
in the following sections. Clicking on the arrow next to the icon opens 
a foating toolbar with the relevant work tools.

Figure 30: Part of the main Drawing toolbar

Tip
The use of all these tools is similar to that of the Rectangle tool, 
even though they produce diferent geometric shapes.

Basic shapes

The Basic Shapes icon  makes  available a 
range of tools for drawing basic shapes, 
including a rectangle tool identical to the one 
on the main toolbar.

The only diferences you will see are in the 
information feld in the status bar (in this case 
“Shape selected” rather than “Rectangle 
selected”).

Symbol shapes

The Symbol Shapes icon   gives you an 
array of tools for drawing various symbols.
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Block arrows

The Block Arrows icon  opens the Block 
Arrows toolbar.

Flowcharts
The tools for drawing fowcharts are accessed 
by clicking on the Flowcharts icon .

The creation of fowcharts, organization charts, 
and similar planning tools are described in 
Chapter 9 (Organization Charts, Flow 
Diagrams, and More).

Callouts

Use the Callouts icon , to open the 
Callouts toolbar.

Stars and banners
These tools are associated with the Stars icon 

.

You can add text to all these shapes. See “Using text elements in Draw
objects” on page 33.
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Adding text to objects
Draw ofers two ways to add text to a drawing: in a dynamic text frame 
as an independent Draw object or as text in a previously drawn object. 
In the latter case, the text is integrated with the object.

Using dynamic text frames

The text tool is activated by clicking on the Text icon  for horizontal 
text or the Vertical Text icon  for vertical script (to be able see the 
icon and use this latter option, you must check Enabled for Asian 
languages under Tools > Options > Language Settings > 
Languages). If you still do not see the Vertical Text icon, enable it on 
the Drawing toolbar by clicking the arrow on the right hand side of the 
toolbar, select Visible Buttons, and click on Vertical Text to make this 
icon show on the toolbar.

Text frames can be moved and rotated like all draw objects. For more 
details on text input, see Chapter 10 (Advanced Draw Techniques).

After activating Text command mode, click at the location where you 
want to position the text. A small text frame appears. It contains only 
the cursor. You can move the frame, if desired. The Text Formatting 
toolbar appears (Figure 31), and you can choose the font type, font 
size, and other text properties and begin to type in your text.

Figure 31: Text Formatting toolbar

The text frame grows with the text. You can insert a line break with the 
Shift+Enter key combination. The Enter key begins a new paragraph. 
Neither line breaks nor new paragraphs terminate the text frame.
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Figure 32: Text input in a dynamic text frame

Observe the information feld in the status bar: it shows that you are 
editing text and also provides details about the current cursor location
—paragraph, line, and column numbers.

Text properties can also be changed during text input. Any changes 
will be refected from the cursor position onwards (Figure 33).

Figure 33: Changing text properties

After choosing the Text icon, you can also draw a frame with the 
mouse to contain future text. You can move the frame only after typing 
some text in it. Line breaks are inserted automatically at the right edge 
of the frame when the text flls the frame width (Figure 34). You can, 
however,—just like when editing other text—insert your own line 
breaks, begin new paragraphs, or change any of the text properties.

Figure 34: Text frame

Using text elements in Draw objects
A text element is associated with most Draw objects. By means of these 
elements, text can be added to an object (see Figure 35).
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The exceptions to this are control elements like buttons or list boxes, 
as well as 3D scenes and their associated elements and groups.

If the Double-click to edit Text icon  on the Options toolbar is 
active, you can start editing an object by double-clicking on it (or by 
pressing F2). In the middle of the Draw object, a black bar indicates 
the text cursor; start typing to input text. The status bar shows at the 
lower left “Text Edit” and the position of the cursor within the text.

Text can contain paragraphs, and these can be in the form of bulleted 
or numbered lists. For a new line without beginning a new paragraph, 
use (as in text documents) the key combination Shift+Enter. To end the 
text input, click next to the object or press the Esc key.

Figure 35: Adding text to objects

34 OpenOfce.org 3.x Draw Guide



Chapter 3
  Working with Objects and 

Object Points



Introduction
This chapter looks at the tools and functions that let you modify 
existing drawings. All of the functions apply to a selected object or 
group of objects, which can be distinguished by small colored squares 
or circles located around it. These points are called handles.

The handles form a rectangular frame that is just big enough to 
contain the object. Where several objects are selected, the frame 
around them corresponds to the smallest rectangle that can contain all 
of the objects. This frame is called the selection rectangle.

If the Options bar is displayed (select View > Toolbars > Options to 
turn it on, if it is not displayed), you can change the size of the handles 
using two buttons: Simple Handles shows the handles as fat squares; 
otherwise they are shown in 3D. Large Handles increases the size of 
the handles. You can combine the two efects. Figure 36 shows the 
location of the handles and other buttons.

Figure 36: Location of handles on the Options toolbar

Selection modes
There are three selection modes:

1) Moving and changing size
2) Editing
3) Rotating points

To set the default mode (1 or 2) for selecting objects, click on the 
Points button  on the Drawing toolbar.

In standard mode (when you begin a new drawing), 
the Points button is not active, and the default mode 
is for selections to be moved or changed in size; 
these selections are indicated by small green 
squares.
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When the Points button is active, the default mode is 
for selections to be edited; these selections are 
indicated by blue squares. Some objects will have one 
or more extra handles, which are larger or colored 
diferently. This is explained in more detail in 
“Editing object points” on page 46.

Selections for rotating objects are indicated by small 
red circles and a symbol representing the center of 
rotation. To choose these selections, click on the 

Efects drop-down button  from the Drawing 
toolbar and after that on the object.

Changing the selection mode
To go from one mode to another, you can do one of the following:

• Choose the Points button  from the Drawing toolbar to switch 
from simple selection mode to Points mode. You can also use the 
keyboard shortcut F8 (Points). See “Editing object points” on 
page 46 for details on using Points mode.

• Choose the Efects drop-down button from the Drawing Toolbar 

 to activate the Rotation mode for a selected object. To exit 

Rotation mode, click on the Selection icon .
• If you often work in Rotation mode, you can choose the Rotation 

Mode after Clicking Object button  from the Options bar 
and cycle through normal and rotation modes just by clicking on 
the object. This can be more convenient than repeatedly clicking 
the selected object, then clicking the Rotate button from the 
Drawing toolbar.

Selecting objects

Direct selection
The easiest way to select an object is to click directly on it. For objects 
that are not flled, click on the object’s outline to select it. One click 
selects; a second click deselects. To select or deselect more than one 
object, hold the shift button down while clicking.
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Selection by framing
You can also select several objects at once by using the 
mouse to drag a large rectangle around the objects 
with the Select button, as shown. For this to work, the 

 icon on the Drawing toolbar must be active.

Only objects that lie entirely within the rectangle will 
be selected.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still 
be selected. Hold down the Alt key and click where the object is 
located. If there are several overlapping objects, hold down the Alt key 
and click until you reach the object you want. To cycle through the 
objects in reverse order, hold down the Alt+Shift keys and click. The 
number and type of the selected objects is shown at the left of the 
status bar to help you to select the correct object.

Note

This method generally works in Windows, but on a Linux system 
it usually does not. If the Alt key on your system does not 
operate as described above, use the Tab key method described 
below.

To select an object that is covered by another object using the 
keyboard, use the Tab key to cycle through the objects, stopping at the 
object you wish to select. To cycle through the objects in reverse order, 
press Shift+Tab. This is a very quick way to reach the object you want, 
but it may not be practical if you have a large number of objects in 
your drawing.

When you click on the selected object, its outline will appear briefy 
through the objects covering it.

In the illustration to the right, the square located 
beneath the circle was selected in this way (the 
circle has been made semi-transparent in order to 
show the square).
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Arranging objects
In a complex drawing, several objects may be stacked on top of one 
another. To rearrange the stacking order (move an object to the front 
or to the back of the stack), select the object, click Modify > Arrange 
and choose Bring Forward or Send Backward. Or right-click the 
object, choose Arrange from the context menu, then choose Bring 
Forward or Send Backward.

These options are also available from the Arrange tear-of toolbar 

accessible from the  icon on the Drawing toolbar. A keyboard 
shortcut is Shift+Ctrl+plus sign to bring an object to the top, and 
Shift+Ctrl+minus sign to send an object to the bottom.

Note, however, that an object located on the Controls layer always lies 
above all other objects.

Moving and dynamically adjusting an 
object’s size
There are several ways of moving or changing the size of an object. 
The dynamic method described here uses the mouse.

When you dynamically change an object, remember to check the left-
hand area of the status bar at the bottom of the Draw window. This 
area shows detailed information about the ongoing manipulation

Figure 37: Left end of status bar during dynamic adjustment

For example, when you are resizing an object, the object information 
felds show which object is selected, the current position in X/Y 
coordinates, and object dimensions (width x height). The information 
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changes as the mouse is moved. The units of measurement are those 
selected under Tools > Options > OpenOfce.org Draw > General.

Dynamic movement of objects
To move an object, select it and then click within the 
object’s border and hold down the left mouse button 
while dragging the mouse. During movement, the 
shape of the object appears as dotted lines to help 
with repositioning.

To drop the object at its new location, release the mouse button. The 
new position appears immediately in the Status Bar.

Dynamic size modifcation of objects
To change the size of a selected object (or a group of 
selected objects) with the mouse, move one of the 
handles located around the selection. As shown in the 
illustration, the outline of the resulting new object 
appears as a dotted line while the mouse button is 
pressed.

The results depend on which handle you use. To resize an object along 
one axis, use the appropriate side handle. To resize along both axes, 
use a corner handle. The new size appears immediately in the status 
bar.

Note
If you press the Shift key while resizing an object, the change in 
size will be carried out symmetrically with respect to the two 
axes, so that the aspect ratio of the object  remains the same.

Dynamic size modifcation of objects with the help 
of the status bar
If you select an object and modify it using the mouse, the changes are 
immediately refected in the information feld of the status bar. With 
geometric shapes (such as basic shapes, symbol shapes, block arrows), 
the only information shown in the status bar is that the shape is being 
resized, as shown in the top-left image in Figure 38. With geometric 
elements (rectangles, circles, and so on), the changes to the attributes 
of the element (either relative or absolute) are also shown, as in the 
top-right image in Figure 38.
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Figure 38: The Information feld during dynamic size 
modifcation of objects

In the case of a rectangle, the new size is shown as percentages of the 
original x and y dimensions. For a line, much more information is 
given: the absolute change in x and y coordinates of the end point 
being moved, together with the current length and bearing of the 
modifed line. These are updated dynamically as the end point is moved 
(see Figure 38).

This is the only place where the exact start and end angles of an arc or 
the length and bearing of a sloping line are shown. This information 
enables you to size the object with considerable accuracy.

Modifying an arc
The beginning and end points of an arc can be modifed. Select the arc 

and click on the Points icon  on the Drawing toolbar to enter the 
Edit points mode (described later in this chapter). In this mode, the 
handles on the selection frame change—two larger blue handles 
appear at the beginning and end points of the arc. When the mouse 
hovers over one of these points the cursor will change to a hand.

Figure 39: Editing an arc
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If you click and hold the mouse button when the hand cursor appears, 
moving the mouse will change the location of the start or end point of 
the arc. The actual coordinates are shown in the Status Bar (see lower 
left graphic in Figure 38.

Rotating and shearing an object using the 
mouse
Use the red rotation handles to either rotate an object around an axis 
or slant or shear the object.

Rotating
To rotate an object (or a group of objects), drag a red corner handle 
point of the selection with the mouse. The mouse cursor takes the 
shape of an arc of a circle with an arrow at each end. A dotted outline 
of the object being rotated appears and the current angle of rotation is 
dynamically shown in the status bar.

Note

Rotation works in a slightly diferent way for 3D objects because 
the rotation occurs in 3D space and not in one plane. See 
Chapter 7 (Working with 3D Objects) regarding rotation when 
the Edit Points mode is active.

Rotations are made about an axis which is displayed as a small symbol. 
This is normally located at the midpoint of the object, but you can 
move the axis of rotation with the mouse to any location you like, even 
outside the object.

If you hold down the Shift key during the rotation, the operation will be 
carried out in increments of 15°.

Figure 40: Rotating an object
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Changing inclination or perspective
To slant or shear objects, use the red handles located at the midpoint 
of an edge of the selected objects. The mouse pointer changes to a  
when the pointer hovers over one of these midpoint handles. Not every 
object can be slanted—basic shapes can be rotated but not slanted.

The slant axis is the point directly opposite the midpoint handle to be 
used for shearing the object. This point stays fxed in location; the 
other sides and edges move in relation to it as the mouse is dragged 
(make sure that the  icon is showing before dragging).

Figure 41 shows how the vertices move in relation to each other 
during the shearing process. The circles represent the path of the 
vertices. The inclination axis is the bottom vertex of the triangle (the 
slanting handle used is the midpoint of the upper enclosing frame). All 
points on the fgure will move through the same angle irrespective of 
the fnal shape. The actual angle is shown in the status bar.

  
Figure 41: Shearing an object

Note
The triangle in Figure 41 was produced with the (unflled) 
polygon tool and then Close Object was selected from the 
context menu.

This tool can be used to produce perspective drawings. The series of 
pictures in Figure 42 shows the method of constructing a cuboid or 
rectangular prism. To shorten the edges leading from front to back, 
reduce the length before you distort the height or width of the surface.

Figure 42: Perspective production of a cuboid
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As with rotation, you can make the slanting occur in steps of 15° by 
pressing the Shift key while moving the handle.

Setting size and position exactly
You can position and resize objects with the mouse, but this method is 
not very exact. If you need accurate positioning of objects, use Format 
> Position and Size from the menu bar, or right-click the object and 
select Position and Size from the context menu, or press F4. 

Position and Size
Open the Position and Size dialog (see Figure 43) and click on the 
frst tab to set the appropriate values.

Figure 43: Position and size of an object

Position is defned as an X,Y coordinate relative to a fxed point (the 
base point), typically located at the upper left of the drawing area. If 
desired, you can temporarily change this base point to make 
positioning or dimensioning simpler (click on the radio button 
corresponding to the location of the base point in either of the two 
selection windows on the right side of the dialog—upper for positioning 
or lower for dimensioning). The possible base point positions 
correspond to the handles on the selection frame plus a central point. 
The change in position lasts only as long as you have the dialog open; 
when you close this dialog, Draw resets the base point to the standard 
position.
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Tip
The Keep ratio checkbox is very useful. Click it to keep the ratio 
of width to height fxed while you change the size of an object.

Either or both the size and position can be protected so that they 
cannot be inadvertently changed. Check the appropriate boxes to 
achieve this.

Tip
You cannot move an object? Check to see if the position is 
protected!

Rotating objects
Click on the Rotation tab of the Position and Size dialog (see Figure 
43). Here you can defne the rotation angle, as well as the location of 
the pivot point.

Figure 44: Rotating an object

Slant and corner radius
With some Draw objects the slant angle (inclination or shearing) and 
corner radius can be set in this dialog (Figure 45).
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Figure 45: Setting rounded corners and slant angle

Corner radius

Figure 46: Example of setting rounded corners

You can use this dialog to round the corners of the usual Draw objects
—text boxes, legends, rectangles, and squares, as shown in Figure 46. 
The same efect can be achieved when you are in the points mode (by 
clicking the Points icon on the Drawing toolbar), by dragging the large 
handle with the mouse. The larger the value for the corner radius, the 
more round will be the object.

Slant
You can shear the older, classic Draw objects, but not the newer Shape 
objects. Enter the slant angle in the box marked Slant Angle.

Figure 47: Example of setting the slant angle in a classic Draw object

Editing object points
For polygons and Bézier curves, Draw ofers a complete set of tools 
that let you accurately edit the contour of an object. To edit other 
objects in the same way, you must frst convert them into curves. To do 
this, select the object, then right-click and choose Convert > To 
Curve or choose Modify > Convert > To Curve from the menu bar.
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You can also convert the shapes to a polygon (Convert > To Polygon). 
With polygons, the edge points are always connected with straight 
lines and not with curves. Some of the techniques described work 
equally with polygons as with curves.

An alternative way to change the form of 
basic shapes
In current versions of Draw, many of the new shapes can be directly 
edited without having to convert them to curves frst. You can 
recognize these objects by the presence of one (or more) circular 
yellow handles as shown in Figure 48. The mouse pointer changes 
shape when hovered over a yellow handle.

If you drag one of these handles, you can modify the shape of the 
object; the type of change is dependent on the shape itself. For 
example, you can round the corners of a rectangle or square, change 
the angles of an arc or ellipse, or alter the control points of a circular 
or elliptical segment.

Figure 48: Some basic shapes with yellow “handles”
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How curves work
The editing of curves depends on the mathematics of Bézier curves1. 
The complete study of such curves goes beyond this scope of this 
guide, and only the basics are covered here. Chapter 10 (Advanced 
Draw Techniques) provides more information on drawing and 
manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or 
tangents passing through these points. Each tangent has two control 
points—one at each end—and a junction point where it meets the 
curve. The relative angle and distance between the control points 
determine the shape of the curve. Figure 49 shows several variations 
starting from a basic circle and changing only one point on the circle.

You can create many diferent shapes by moving either the junction 
point itself, or one or both of the round handle points at either end of 
the tangent.

Figure 49: Creating diferent shapes by 
changing the tangent

Draw ofers even more possibilities when you use the functions on the 
Bézier curve toolbar.

The Edit Points toolbar
When you work in Edit Points mode, use the Edit Points toolbar, shown 
in Figure 50. To activate this toolbar, choose View > Toolbars > Edit 
Points. It will then appear whenever you select a curve and the Edit 
Points icon on the Drawing toolbar is active.

1 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car 
manufacturer, who developed the technique in the 1960s. The technology was intended to make 
modeling the surface of vehicles easier.
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Figure 51: 
Symmetric 
tangent

1  Points 5  Split Curve   9  Symmetric Transition
2  Move Points 6  Convert to Curve 10  Close Bézier
3  Insert Points 7  Corner Point 11  Eliminate Points
4  Delete Points 8  Smooth Transition

Figure 50: Edit Points toolbar

On this toolbar, icons may be active or inactive depending on the 
selected object and object point. With the Convert to Curve icon, you 
can determine for individual points whether their connection will be 
made with straight lines or with curves.

Only with curves are the icons for tangents activated. An object that 
contains no curves is treated as a polygon.

The three kinds of tangent
Three buttons in the Edit Points Toolbar let you select the type of 
tangent and convert from one type to another. Only one of these 
buttons can be active at any given time. Their use is described in the 
following chapter.

Choose the Symmetric Transition button  
to work with a symmetrical tangent (Figure 51). 
Any movement of one or the other of the 
handles is carried over symmetrically to the 
other handle.

Figure 52: 
Asymmetric 
tangent

Choose the Smooth Transition button  to 
separately adjust the lengths of the two parts of 
a tangent and so make the curve fatter or 
steeper. In Figure 52, you can clearly see that 
the curve is fatter on the longest side of the 
tangent. The tangent remains as a single 
straight line. This kind of tangent is known as a 
smooth junction. 
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Figure 53: 
Infexion 
point

Figure 54: Moving 
a junction point

It is also possible to completely detach both 
sides of the tangent. In this case, the central 
point is known as the infexion point. Using this 
technique, you can draw spikes and troughs in 

objects. Choose the Corner Point button  
to create an infexion point around the selected 
point.

Examples
The other buttons in the Edit Points Toolbar are described here in 
relation to working examples. The following examples start from a 
flled circle. As mentioned earlier, in order to use Edit Points mode, you 
frst need to convert the object to a curve.

You will notice that after the conversion, the handles located in the 
corners of the rectangle have disappeared. This behavior is normal in 
that the handles which are used in the Edit Points mode are located 
along the outline or trace of the drawn object.

The Move Points button  is the default 
mode when editing points. If it has not been 
activated, click on its button. When this mode is 
active, the mouse pointer has the following 
shape when it is hovered over an edit point:

Movement of a point is one of the easiest 
manipulations to do. Figure 54 illustrates how 
you can draw an egg very easily by starting 
from a circle and dragging the the top point 
upwards.
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Figure 56: Adding 
an edit point to a 
curve

 

Figure 57: Deleting 
points from a curve

Figure 55: 
Rotating a tangent

To change the direction or location of the 
tangents, move the circular handles at each 
end. The mouse pointer then looks like this:

Use the Add Points button  to add an extra 
edit point to an existing curve. Click on the 
curve at the spot where you want to insert a 
point and then move the mouse slightly in any 
direction while holding down the button. Watch 
out! If you just click, the new point will not be 
added.

The tangent attributes associated with the new 
point depend on the buttons that are selected on 
the toolbar.

The Delete Points button  has the opposite 
efect: it subtracts one or more points from the 
curve. The resulting curve stretches itself 
automatically around the remaining points after 
subtraction.

Select one or more points to delete. You can 
select several points by holding down the Shift 
key (➊).

When you have selected the points you want to 

delete, click the Delete Points  button. The 
selected points disappear from the curve, which 
then reforms around the remaining points (➋).

You can also delete the selected points by 
pressing the Del key on the keyboard.
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Figure 59: Moving 
a segment

Figure 60: 
Closing an open 
curve

 

Figure 58: Cutting a 
curve

Use the Split Curve button  to split or cut a 
curve at the location of the selected handle. If 
the object is flled, it will be emptied because 
the curve that represented the edge is no longer 
closed.

Check that you have selected the correct handle 
(➊), click the Split Curve button  (➋) and 
notice that the object is no longer flled. You can 
then check, by moving the point, that the curve 
has indeed been separated (➌).

If you have an open curve, the start point of the 
curve is larger than the others.

You can also separate a curve at several points 
simultaneously. Keep the Shift key pressed down 
and select all of the points at which the cut 
should occur.

Drag and drop segments with the mouse to 
move them from the original curve.

To close an existing curve, select an open curve 

and click on the Close Bézier button .

The opening point is identifed by a slightly 
larger handle (Figure 60).
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Figure 61: Using 
the “select points” 
switch

The Select button  on the Drawing toolbar 
functions as a switch. It works as follows.

If you have two points linked together by a 
straight line (you do not need to have a curve 
between the points) and you insert a new point 
between them that is set at an angle to the 
initial straight line (and hence the two 
endpoints), then:

• If the Select button is active, you will have a 
drawing similar to that illustrated in ➊.

• If the Select button is not active, and you 
move the point you have just inserted to bring it 
back close to its initial position in the straight 
line, you will have a drawing similar to that 
illustrated in ➋.

3.
Release mouse 
button

Figure 62: Reducing 
a line by one point

The Eliminate Points button  button only 
functions with lines with multiple points.

If the button is active, click on a point, hold the 
mouse button down and move the mouse to 
draw virtual straight lines between the 
neighboring left and right points.

When the two lines are more or less straight 
and you release the mouse button, the point is 
deleted and a line between the above mentioned 
two neighboring points replaces the previous 
two lines, thus eliminating one point.

Note that this only works when the angle 
between the two lines shown dashed in the 
fgure at left is less than a certain amount.

In the Tools > Options > OpenOfce.org 
Draw > Grid window there are options for snap 
settings relating to editing points when rotating 
and in point reduction mode.
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Figure 63: Moving 
a point on a curve

The Rotate function from the Efects drop-

down button  on the Drawing toolbar and 
the Rotation Mode after Clicking Object 

button  on the Options toolbar can be used 
in Edit Point mode. In this case, it can be used 
to move single points around the contour of an 
object.

Switch into rotation mode by clicking on either 
of the rotation buttons. Notice that in rotation 
mode, all of the tangent points become red dots.

Select the point to be moved and then drag it 
around the contour while keeping the left mouse 
button pressed down (➊). When you release the 
mouse button, the point will be moved to the 
new position (➋).

If you move one of the handles located at the 
end of the tangents during rotation, you will 
make the object rotate in exactly the same way 
as with the usual rotation operations.

Important: To exit the efects mode, do not just 
click on the Efects button; click the Select 
button  on the Drawing toolbar.
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Toolbars and menus
To change an object’s attributes (such as color, border width, among 
others) you can use the Line and Filling toolbar or the context menu.

Line and Filling toolbar
If the Line and Filling toolbar is not visible, you can display it using 
View > Toolbars > Line and Filling. From here you can edit the 
most common object attributes. You can also open the Line dialog by 
clicking on the Line  icon and the Area dialog by clicking on the Area 

 icon to see more options.

1  Styles and Formatting
2  Line
3  Arrow Style

4  Line Style
5  Line Width
6  Line Color

7     Area
8–9  Area Style / Filling
10    Shadow

Figure 64: Line and Filling toolbar

Text Formatting toolbar
When you select text, the Line and Filling toolbar changes to show text 
formatting options. You can also display the Text Formatting toolbar by 
choosing View > Toolbars > Text Formatting.

Figure 65: Text Formatting toolbar (when text is selected)

The context menu
When an object is selected, you can right-click on the object to bring 
up a context menu (Figure 66). The context menu provides additional 
access to the options shown above and another way to change an 
object’s attributes. The entries with a small arrow on the right-hand 
side contain a submenu.
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Figure 66: Right-click on an object to see 
the context menu

Editing lines and borders
Lines, arrows, and the borders of an object are managed through the 
same dialog (Figure 67).

Figure 67: Lines and 
borders

You can change some properties from the Line and Filling toolbar. To 
see more options, select the object and  right-click on the object and 
choose Line from the context menu. This opens the Line dialog.
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Figure 68: Line dialog (right-click on an object and choose Line).

Common line properties
In most cases the property you want to change is the line’s style (solid, 
dashed, invisible, and so on), its color, or its width. These options are 
all available from the Line and Filling toolbar.

Figure 69: Common line options (style, width, color)

You can also edit these properties from the Line dialog. They are on the 
frst tab, left column (see Figure 68). From the Line dialog you can also 
change the line’s transparency. Figure 70 illustrates diferent degrees 
of transparency.

Figure 70: The vertical lines have diferent levels 
of transparency (0%, 25%, and 50%).
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Drawing arrows
Arrowheads (and other line endings—usually referred to in this guide 
collectively as arrows) are a line property. Select a line and click on the 

Arrow Style  icon. This opens the Arrowheads menu.

Figure 71: Arrowheads menu

There are several types of arrowheads available. Each end of the line 
can have a diferent arrowhead (or no arrowhead).

Note
Arrowheads are only applicable to lines. They have no efect on 
an object’s border.

In the Line dialog (Figure 68), Arrow styles on the right-hand side 
contains a number of options to fne tune the arrow properties. If 
Synchronize ends is selected, both line endings will have the same 
appearance. The Center option brings the middle of the arrow over 
the end point of the line. If this option is not selected, the line ends on 
the outermost edge of the arrow. It is much easier to understand if you 
look at the following sketch.

Figure 72: Default arrowheads (left) 
vs centered arrowheads (right)
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Customizing line and arrow styles
You are not constrained to using only the line and arrow styles 
provided by default in Draw. You can modify the styles and create your 
own.

Customizing line styles
In the Line dialog, click on the Line Styles tab (see Figure 73). From 
here you can customize the line styles or create your own (click on the 
Add button to create your own). You can change the length of the 
dashes, the space between them, and other attributes.

Figure 73: Editing line styles

Use the Load Line Style and Save Line Style  icons to save a 
new defnition or read one from disk (fle extension .sod).

Customizing arrow styles
You can also create your own arrowheads to create some interesting 
efects, such as:

The frst step is to draw a curve with the shape you want for the 
arrowhead (see Figure 74).
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Figure 74: To create your own arrowhead, 
you must frst draw a curve.

Note

The arrowhead must be a curve. A curve is something you could 
draw without lifting a pencil. For example,  is a curve but  
is not a curve. You can however draw forms which are not 
curves and then at the end convert them to a curve.

Select the curve, open the Line dialog, and go to the Arrow Styles 
page. Click on Add, enter a name for the arrow style and click OK (see 
Figure 75).

Tip
The part of the shape which should point in the direction of the 
line must be drawn facing upwards. In Figure 74 the top of the 
shape will point towards the “outside” of the line.

Figure 75: Adding an arrow style

Now you can access the new style from the Arrow style list (Figure 76) 
or the Arrowheads dialog (Figure 71).
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Figure 76: Arrow style list

Editing the inside (fll) of an object
The OpenOfce.org term for the inside of an object is Area fll. The 
area fll of an object can be a uniform color, a gradient, a hatching 
pattern, or an image. It can be made partly or wholly transparent and 
can throw a shadow.

Figure 77: Diferent types of area fll

Common fll properties
In most cases, you will choose one of the standard fll options, whether 
it is a color, a gradient or an image. These options are all available 
from the Line and Filling toolbar (see Figure 78). 

If you want no fll at all, select the object you wish to edit and on the 
Line and Filling toolbar select the option Invisible on the pull down 
list at the right of the paint can.
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Figure 78: Common fll options

Fill with a uniform color
Select the object you wish to edit. On the Line and Filling toolbar, 
select Color on the pull down list at the right of the paint can, and 
then choose a color from the right-hand menu.

Figure 79: Filling with a color

Fill with a gradient
Select the object you wish to edit. On the Line and Filling toolbar, 
select Gradient and then choose a gradient from the right-hand menu.

Figure 80: Filling with a gradient

Chapter 4   Changing Object Attributes 63



Fill with a line pattern
The OOo term for line patterns is Hatching. Select the object you wish 
to edit. On the Line and Filling toolbar, select Hatching and then 
choose an option from the menu.

Figure 81: Filling with a line pattern

Fill with an image
You can fll an object with a bitmap image (as opposed to a vector 
graphic image). Select the object you wish to edit. On the Line and 
Filling toolbar, select Bitmap and then choose an option from the 
menu.

Figure 82: Filling with an image
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Adding a shadow
In Draw, shadows are considered an area property. Click on the Filling 

 icon on the Line and Filling toolbar—next to the area fll functions 
(Figure 83).

Figure 83: Adding a shadow

Advanced area fll options
Click on the Area icon  to bring up the Area dialog. From this 
dialog, you can fne tune the area fll of an object in greater detail.

Creating your own fll color
Click on the Colors tab of the Area dialog (Figure 84). From here you 
can modify existing colors or create your own.

Figure 84: Customizing the color palette

Depending on the color model (RGB or CMYK can be selected from the 
pull down menu) in use you can change the individual values of the 
constituent colors—Red, Green, and Blue or Cyan, Magenta, Yellow, 
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and Black. Click on Add to add this color to the color table. Clicking on 
the Modify button will change the values of the current color (here it 
is Blue 8, shown in the upper rectangle) to those on the screen in the 
lower rectangle. The Edit button allows you to fne tune the color 
using a palette with visual feedback.

Further explanation about color palettes can be found in Chapter 8 
(Tips and Tricks).

Creating your own gradient
On the Area dialog, click on the Gradients tab. From here you can 
modify existing gradients or create your own.

Figure 85: Customizing gradients

A gradient works by creating a smooth transition from one color to 
another. First, you need to choose two colors.

Figure 86: Choosing colors for a gradient
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Then choose a type of gradient. There are several available (Linear, 
Axial, Radial, and so on) and each has up to four diferent options to 
specify it in detail. For example, a radial gradient has a center you can 
specify (Figure 87).

Figure 87: Center option in a radial gradient

Figure 88 shows how an ellipsoid gradient is rotated, moved vertically 
and horizontally, and the color of the border area varied.

Figure 88: Center, Angle, and Border options for a gradient

Creating your own hatching (line pattern)
On the Area dialog, click on the Hatching tab (Figure 89). From here 
you can modify existing hatchings (line patterns) or create your own.

You can customize options like the spacing between lines, the angle 
and the color of the lines. There is no way to edit the line thickness.
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Figure 89: Modifying hatchings

Creating your own bitmap fll
You can add your own bitmap images to fll an area. First, you need to 
create the bitmap image. This could be a photo or another sketch you 
have created in another program. For example, you can draw 
something with Draw and export it as a PNG format image fle.

To export a PNG image fle: Create the image, select it, then choose 
File > Export, choose PNG from the pulldown list of fle formats, give 
the fle a name, and save it.

To use an image as a bitmap fll, open the Area dialog and click on the 
Bitmaps tab (Figure 90).

Figure 90: Adding your own bitmap images

68 OpenOfce.org 3.x Draw Guide



From there you can add new bitmap images to serve as area flls. Click 
on Import and choose a fle you previously saved. Give it a name that 
will make it easy to remember. The last imported image will appear at 
the bottom of the pulldown list of bitmap flls. Now you can use that 
image as an area fll.

Figure 91: Adding your own bitmap images

Tip

If the imported image seems to be very small in the preview in 
Figure 91 probably you forgot to select the image before you 
exported it. The exported image was then the whole page with a 
(small) drawing on it.

Customizing shadows
First, select the object you want to apply a custom shadow to. Open the 
Area dialog and go to the Shadow tab (Figure 92). There you can 
customize the shadow’s position, distance and color.

Figure 92: Customizing shadows
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Shadows can also have transparency, so the shadow does not hide 
objects behind it.

Figure 93: Shadow with 50% transparency

Adding transparency
You can make objects partly or fully transparent, or even a with a 
varying degree of transparency (as a gradient). On the Transparency 
page (Figure 94), choose Transparency (for a uniform transparency) 
or Gradient for a gradient transparency.

Figure 94: Transparency page of Area dialog

An example of gradient transparency is shown in Figure 95. See also 
“Dynamic gradients” on page 76.

Figure 95: Example of gradient transparency
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Using styles
Suppose that you want to apply the same area fll, line thickness, and 
border to a set of objects. This repetitive process can be greatly 
simplifed by the use of styles. Styles allow you to defne a formatting 
template (a style) and then to apply that style to multiple objects. For 
more about styles, see Chapter 6 (Introduction to Styles) in the Writer 
Guide.

Click on the Styles and Formatting  icon on the Line and Filling 
toolbar or press the F11 key to open the Styles and Formatting window 
(Figure 96). This window can be docked to the left or right side of the 
main Draw window, if you wish.

Figure 96: Styles and Formatting window

Creating a new style
Select an object and customize the area fll and border. When you are 
satisfed, click on the New Style from Selection  icon on the Styles 
and Formatting window. This defnes a new style based on the selected 
object. Type a name for the new style and click OK.

Applying a style
Once the new style is defned, you can apply it to other objects. Select 
another object and double-click on the style name you defned. The 
new object will acquire the area fll and line properties of that style.
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Tip

Question: What happens if I modify a style after it has been 
applied?

Answer: Then every object with that style is updated 
automatically!

Modifying a style
Modifying a style is similar to creating a new style. Select an object 
with that style and change the area and line properties. When 

satisfed, click on the Update Style icon .

Special efects
First make sure that the Drawing toolbar is selected (View > Toolbars 

> Drawing). On the Drawing toolbar, locate the Efects icon . 
Click on the arrow next to that icon. This opens a submenu with all the 
special efect tools (see Figure 97).

1  Rotate
2  Flip
3  In 3D Rotation Object

4  Set in Circle (perspective)
5  Set to Circle (slant)
6  Distort

7  Transparency
8  Gradient

Figure 97: Mode tear-of submenu

The tools are described in the following sections with the exception of 
the 3D rotation tool, which is described in Chapter 7 (Working with 3D 
Objects).

Rotating an object

Click on the Efects  icon to select the Rotate tool. Then select an 
object. The selected object will have red handles instead of the usual 
green handles.
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Grab one of the handles and move it 
to rotate the object. The black circle 
in the middle of the object is the 
pivot (center of rotation). You can 
move the location of the pivot with 
the mouse.

Flip an object

Select an object and click on the Flip icon . You will 
see a dashed line through the middle of the object.

This dashed line is the axis of symmetry. The object 
will be refected about this line. Move one or both ends 
of the line with your mouse to set the orientation of the 
axis.

Then, grab any one of the eight green handles and move 
it across to the other side of the dashed line. The new 
position of the fgure is shown faintly until the mouse is 
released.

Note
If you press the Shift key while moving the line, the line will 
rotate in 45-degree increments.

Mirror copies
Ofcially, this useful command does not (yet) exist in Draw. It can, 
however, be easily emulated. 

Move the axis of symmetry to the desired location of the mirror axis. 
Copy the object to the clipboard. Flip the object, then click on an 
empty area of the Draw screen in order to deselect the object. Paste 
from the clipboard to put a copy of the object in its original location 
and now you have a mirror copy.
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Figure 98: Making a mirror copy of an object

Distorting an image
There are three tools on the Efects menu that let you drag the 
corners and edges of an object to distort the image.

The Distort tool distorts an object in perspective, the Set to Circle 
(slant) and Set in Circle (perspective) tools both create a pseudo 
three-dimensional efect.

The results of using these tools are shown in the following fgures.

Distort an object
Select an object and click on the Distort icon . Draw will ask if you 
want to transform the object to a curve. This is a necessary step before 
distortion, so click Yes. Then you can move the object handles to 
stretch it.

The corner handles distort, as shown in Figure 99. The midpoint 
handles distort the fgure either horizontally (handle on vertical side of 
fgure) or vertically (handle on horizontal side of fgure).

Figure 99: Distort an image
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Set in circle (perspective)

Select an object and click on the Set in Circle (perspective)  icon. 
Draw will ask if you want to transform the object to a curve. This is a 
necessary step before distortion, so click Yes. Then you can move the 
object handles to give a pseudo three-dimensional perspective).

Figure 100: Set an image in a circle with perspective

Set to circle (slant)

Select an object and click on the Set to Circle (slant)  icon. Draw 
will ask if you want to transform the object to a curve. This is a 
necessary step before distortion, so click Yes. Then you can move the 
object handles to give a pseudo three-dimensional slant perspective.

Figure 101: Set an image to a circle with slant perspective
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Note
Transforming an object into a curve is a safe operation, but it 
cannot be reversed other than by clicking the Undo button.

Dynamic gradients
You can control transparency gradients in the same manner as color 
gradients. Both types of gradient can be used together. With a 
transparency gradient, the direction and degree of an object’s fll color 
changes from opaque to transparent (in a regular gradient, the fll 
changes from one color to another, but the degree of transparency 
remains the same).

If you have assigned transparency to an object with a color fll, you can 

control the transparency by clicking on the Transparency icon . To 
defne a transparent gradient, select an object and choose a 
transparency fll from the Line and Filling toolbar. The transparency 
icon is now active. When you click on this icon, a dashed line 
connecting two squares appears on the object. Move the two squares 
to modify the gradient. You can defne the direction of the gradient 
(vertical, horizontal, or at any angle) and the spot at which the 
transparency begins.

In the same manner, to defne a regular gradient, select an object, 
choose a gradient fll from the Line and Filling toolbar, The Gradient 

icon  is now active. When you click on the gradient icon, a dashed 
line connecting two squares appears on the object, just as it does for a 
transparency gradient.

In both cases a dashed line connecting two small squares appears on 
top of the object. Click outside the object to set the gradient.

Note

If the transparency and gradient icons are not visible, you can 
display them using View > Toolbars > Mode.

Moving the squares will have diferent efects, depending on the 
type of gradient. For example, for a linear gradient, the start and 
end squares of the gradient will always be situated to either side 
of the center point of the object.

The three examples in Figure 102 demonstrate how the type and 
degree of transparency can be controlled.

76 OpenOfce.org 3.x Draw Guide



A single color object and a transparency 
gradient, covering part of the underlying 
object.

The gradient can be dynamically adjusted, 
made more transparent by moving the 
white square or more opaque by moving 
the black square.

An object with a color gradient, completely 
covering another object.

The gradient is adjusted dynamically by 
moving the squares – the color of the 
square relating to the increase or decrease 
in that color.

An object with both color and transparency 
gradients, partly covering the underlying 
object.

Figure 102: Dynamic gradients
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Introduction: grouping and combining 
objects
Using Draw, you can combine drawing objects together in two distinct 
ways: grouping and combining. These two methods allow you to treat 
multiple objects as one unit, or to merge objects to form a new shape.

Grouping is like putting objects in a container. You can move them as a 
group and apply global changes to them. A group can always be 
undone and the objects that make up the group can always be 
manipulated separately.

A combination is a permanent fusion of objects leading to a new object. 
The original objects are no longer available as individual entities and 
the operation is not reversible.

Tip
To select multiple objects, click on each object while holding 
down the Shift key or click the Select icon (on the Drawing 
toolbar) and draw a rectangle around the objects.

Grouping objects

Grouping by common selection
When several objects are selected, any operations you carry out are 
applied to all of the objects. For example, you can rotate a group of 
objects in its entirety. Groups obtained through common selection of 
several objects are undone as soon as you click outside the group. 
However, you can group objects and keep those selected objects 
grouped together.

Maintaining groups and undoing groups
To group objects, frst select the objects, then right-click and choose 
Group from the pop-up menu. You can also use the keyboard shortcut 
Control+Shift+G or choose Modify > Group from the menu bar.

When objects are grouped, any editing operations carried out on that 
group are applied to all members of the group. If you click on one 
member of the group, the whole group is selected.
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Figure 103: Grouping objects using the 
right-click menu

The objects of a group retain their own individual properties. To undo a 
group, right-click and choose Ungroup from the pop-up menu, use the 
keyboard shortcut Control+Alt+Shift+G or choose Modify > 
Ungroup from the menu bar.

Editing individual objects in a group
You can edit a member of a group individually without breaking the 
group. To do this, right-click and choose Enter group or double-click 
on the group.

Figure 104: When you enter a group, 
objects outside the group can not be 
selected and appear pale

Once inside the group, click on any object to edit it.

Figure 105: Editing an object inside a group

To leave this mode, right-click and choose Exit group or double-click 
outside the group.
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Nesting groups
You can create “nested” groups, or groups of groups. In this case, 
Draw keeps the initial group hierarchy. If you ungroup a group made of 
other groups, you are left with individual groups that you can then 
ungroup further, and so on until only single objects remain.

Combining objects
In contrast to grouping functions, combinations create a new object; 
subsequent “un-combining” in the same manner as ungrouping is not 
possible. Select a collection of objects, then right-click and choose 
Combine from the pop-up menu. The result of this operation is shown 
in Figure 106.

  

Figure 106: Combining objects

At frst glance, this can seem rather surprising. Once you understand 
the rules governing combination in Draw, however, it will become 
clearer.

• The attributes (for example, area fll) of the resulting object are 
those of the object furthest back. In this example, it is the circle.

• Where the objects overlap, the overlapping zone is either flled or 
empty depending on the number of overlaps. When the number of 
overlaps is even, you get an empty space; when the number is odd, 
you get a flled area.

Figure 107: Odd numbered overlaps are flled, 
even numbered overlaps are empty
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Tip

You can reorder objects so they are further back in the 
background or further forward in the foreground: right-click on 
the object and select Arrangement from the pop-up menu. See 
also “Aids for positioning objects” on page 84.

An object which is a combination can be broken up into its constituent 
parts by selecting Modify > Break. This is not the equivalent of 
ungrouping as the objects were converted to Bézier curves when they 
were combined. The resulting object is a set of base level objects (for 
example, a rectangle will be broken into 4 separate lines). The original 
formatting—line thickness, colors, and area properties—is not 
retained.

Merging, subtracting, or intersecting 
shapes
After you have selected more than one object, the Merge, Subtract, 
and Intersect functions can be reached in the Modify > Shapes menu 
or though the group’s right-click menu under the heading Shapes.

Merge
When you merge objects, the new object 
covers the entire surface of the original objects 
(it is the union of the objects). In the same way 
as combining, the fll of the merged object is 
determined by the fll of the object furthest in 
the background. Other properties are not 
taken over into the new object.

Subtract
When you subtract, the upper object is 
subtracted from the lower object.

Intersect
When you intersect two objects, you get the 
area covered by both objects.
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Tip
How do I move an object so it is further back or closer to the 
front? See page 84.

Practical example
The following example shows how you can use the merge functions to 
create a complex shape, namely a knife with a wooden handle.

1) Draw an ellipse and then a rectangle 
overlapping half of its width.

2) Select both shapes, right-click, and choose Shapes > Subtract 
from the pop-up menu. The result should resemble the shape at 
right:

    

3) Draw another rectangle and put it over the top half of the ellipse. 
Then subtract again.

    

4) Draw a small ellipse covering just the lower right corner and 
subtract again.

    

5) The knife blade is now complete. To make the handle, draw a 
rectangle and an ellipse as shown.

6) Merge the shapes together.

    

7) Group this image with the previous one.
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Aids for positioning objects
Draw has various tools to help you arrange the objects with respect to 
each other. Here we explore some of the more important ones.

Moving an object to the front or to the back
When you combine or merge objects, the end result varies drastically 
depending on which object is “in front” and which one is “in the back”. 
In Figure 108 you can see the diference.

  

Figure 108: Subtracting objects: the result varies depending on which 
object is in front.

If you imagine several objects stacked one on top of the other, the one 
referred to as “Front” is the one on top of the stack. The one referred 
to as “Back” is the one on the very bottom of the stack.

First select an object, then on the Drawing toolbar, long-click on the 

Arrange icon  to open the Position toolbar. This toolbar can be 
torn of and made to foat.

1  Bring to Front 5  In Front of Object
2  Bring Forward 6  Behind Object
3  Send Backward 7  Reverse
4  Send to Back

Figure 109: The foating Position toolbar
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 brings the selected object to the front of the group.

 brings the selected object one step upwards.

 sends the selected object one step backwards.

 sends the selected object to the back of the group.

 moves the selected object in front of another chosen object.

 moves the selected object behind another chosen object.

Click frst on the object you want to change in position. Next click 
on the icon and then move the mouse over the other object. The 
mouse cursor changes into a hand and the outline of the second 
object becomes a dashed line (see below). Clicking on this object 
completes the rearrangement of position.
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 reverses the order of the selected objects.

Aligning objects

Select two objects and long-click on  on the Drawing toolbar to 
open the Align toolbar. This toolbar can be torn of and made to foat. 
The tools help you position objects with respect to each other.

1  Align left 4  Align top
2  Center horizontally 5  Center vertically
3  Align right 6  Align bottom

Figure 110: The foating Align toolbar

 Align left.

 Center horizontally.

 Align right.
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 Align top.

 Center vertically.

 Align bottom.

If you have selected only one object, clicking the various buttons on 
the Align toolbar positions the object in relation to the drawing page.

Distributing the distance and space between objects
Select at least three objects. Now you are able to select the option 
Distribution on the Modify menu or from the right-click menu. The 
Distribution dialog contains a number of options, described below.

Figure 111: Distribution of spacing between objects

Horizontal distribution

None. Does not distribute the objects horizontally.

Left. The left edges of the objects are evenly spaced from one another.

Center. The horizontal centers of the objects are evenly spaced from 
one another.
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Spacing. The horizontal spacing between the objects is evenly 
distributed.

Right. The right edges of the objects are evenly spaced from one 
another.

Vertical distribution

None. Does not distribute the objects vertically.

Top. The top edges of the objects are evenly spaced from one another.

Center. The vertical centers of the objects are evenly spaced from one 
another.

Spacing. The vertical spacing between the objects is evenly 
distributed.

Bottom. The bottom edges of the objects are evenly spaced from one 
another.

Figure 112 shows four objects before distribution of horizontal 
spacing.

Figure 112: Before distribution

The result of the selections made in Figure 111 (change to equal 
horizontal spacing, no vertical change) is shown in Figure 113.

Figure 113: After distribution – change to equal horizontal spacing, no 
vertical change
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Chapter 6
  Editing Pictures 
(Raster Graphics)



Introduction
Earlier chapters of the Draw Guide have dealt only with vector 
graphics. However, Draw also contains a number of functions for 
handling raster graphics (bitmaps) such as photographs and scanned 
pictures, including import, export, and conversion from one format to 
another.

Draw can read all the usual graphics fle formats. It has a subset of the 
same capabilities as specialized raster graphics programs like Adobe 
Photoshop or The Gimp.

Importing raster and vector graphics
To import stored graphics fles, choose Insert > Picture > From File 

on the main menu bar or click on the  icon on the Draw toolbar. 
Draw possesses import flters for many diferent vector and raster 
graphics formats; a flter for *.svg (scaleable vector graphics) fles is 
available as an extension, 
http://extensions.services.openofce.org/en/project/svgimport. If your 
fle has a nonstandard extension, you must choose the format explicitly 
when importing it.

If you select the Preview option in the Insert picture dialog (Figure
114), Draw shows a preview of the picture in the box on the right-hand 
side. This makes it much easier to choose the picture you want and to 
see whether Draw can import a fle of this format.

Figure 114: Inserting a picture
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To link or to embed?
If you select the Link option in the Insert picture dialog, the graphic is 
linked rather than embedded. It is not actually inserted into the 
document; instead, a link to the graphic is created. This link is relative 
to the folder where the document is stored, even though it shows up in 
the Edit Links dialog (see Figure 115) as an absolute link. If you store 
the document and the graphic in the same folder, and transport the 
folder as a whole to another computer, the graphic will show up in the 
document as before.

Linked graphics are not changed as a result of any actions carried out 
within OpenOfce.org. Such changes afect only the view of the 
graphic in the document and not the graphic itself. In particular, the 
format of a linked graphic remains unchanged. In contrast, when a 
raster graphic is embedded in an OOo document, it is converted into 
PNG format.

Linking keeps the fle size of the Draw document small. The picture 
can be edited or even replaced by another and the link will still 
function. As long as the new picture is given the same name as the old 
one, links will be re-established and updated when the document 
containing the link is next opened. However, some actions do not last 
beyond the current session (for example, Filter) or are simply not 
possible on a linked graphic (for example using the Eyedropper to 
exchange colors).

Links can easily be removed. The linked picture will then be embedded 
in the document. To break a link, choose Edit > Links from the main 
menu bar. In the Edit Links dialog (see Figure 115), choose the link to 
be broken and then click on the Break Link button.

Figure 115: Editing links to documents
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Scanning
With most scanners you can directly insert a scanned picture into a 
document. Choose Insert > Picture > Scan and then either Select 
Source or Request.

The Select Source option opens a window which acts as an interface 
to a scanner device. Some scanner options can be directly set from 
within this window. See Figure 116.

Figure 116: Select source ..... Scanner

Click on Create Preview to carry out a preview scan. The results are 
shown in the preview box on the left. Modify the scan area as desired 
and review the result as before. When you are satisfed with the scan 
preview output, click OK and then insert the scan into the document 
with Insert > Picture > Scan > Request.

Scanned images are embedded in the document in PNG format.

Pasting from the clipboard
The clipboard ofers another way to insert graphics. Depending on the 
source and the operating system, fgures may be in diferent formats. 
You can obtain an overview by choosing Edit > Paste Special from 
the menu bar or by clicking on the Paste icon's drop-down menu on 
the main toolbar.
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Dragging and dropping
Drag and drop also functions in many situations. The exact way drag 
and drop works is determined not by whether the graphic is to be 
embedded or linked but by the operating system in use and the source 
of the graphic. The behavior can be controlled by the use of the 
Control or Control+Shift keys together.

Draw objects and images which are used frequently can be stored in 
the Gallery. Objects can be dragged from the Gallery to the Draw 
surface quite simply. Working with the Gallery is dealt with in Chapter 
10 (Advanced Draw Techniques).

Inserting from a fle
With this option, you can insert complete pages or single objects from 
existing Draw or Impress documents into your Draw document. In 
addition you can insert text in Rich Text Format (RTF), HTML format 
or plain text. The text will be contained within a text frame. The usual 
paragraph and character formatting options are available for this text.

Choosing Insert > File brings up the File selection dialog. If the fle is 
a Draw or Impress document, a special import dialog opens.

Figure 117: Inserting complete pages or objects on a page

To access single pages or slides of the document, click on the 
expansion symbol (usually a + or a small triangle, depending on your 
operating system) to the left of the fle name in the selection area. The 
same method is used to display single objects within slides. Raster 

graphics (for example, photos) and Metafles are marked with a  

symbol, drawing objects with a  symbol.
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Choose the object or objects (multiple selection using the Control or 
Shift key is possible). If the inserted object was named in the source 
document, it keeps its original name unless the name already exists in 
the current document. In that case you must give the object a new 
name before it is inserted. To rename an inserted object, right-click 
and choose Name from the pop-up menu. Renaming has the advantage 
that the object is then listed in the Navigator.

You can choose whether to embed or link the selected page or object.

Exporting graphics
Saving drawings in the native OpenOfce.org Draw format (*.odg) 
means that in general only OOo (or StarOfce) users, or users who 
have installed a suitable ODF plug in, can open the fles. To make it 
easier for other users and to use the drawings in other applications, 
you can export the graphics in other formats. Choose File > Export 
and then in the File format pull-down list select the desired format.

Figure 118: Section of the fle selection list

Exporting the entire fle
The fle format options in the upper area of the File format box (PDF, 
Flash, and HTML) always apply to the complete fle. Use of Flash or 
HTML format causes each page of the Draw document to be exported 
as a raster graphic. You will no longer be able to access individual 
objects on the page. If you wish, the Export Assistant can generate a 
Navigation aid to help in moving from page to page.

If you want to use the objects in other applications, select one of the 
Metafle formats (JPEG, PNG, TIFF, BMP and so on) in the lower part of 
the File format list (see Figure 119). With this type of export, only the 
currently active page is exported.
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Figure 119: Lower part of the Export dialog

Exporting single objects
In order to export individual drawing objects, you need to frst select 
them. A selection can include more than one object. Take care to 
choose the Selection option on the Export dialog.

Exporting as a vector graphic
The choice of vector formats is still limited. An export to a DXF format 
fle (Autocad) is not yet possible. Even the export of a graphic to a SVG 
format fle is not yet fully implemented: 2D graphic objects are 
exported as paths and 3D objects only as preview images. Best 
supported are the Metafle formats and exporting to one of these is 
usually successful.

Exporting as a raster graphic
The choice of formats for export as a raster graphic is large enough to 
support most other applications. If in doubt, test diferent formats to 
see which gives the best results; some programs behave diferently 
depending on the format of the image imported into them.

After typing in a name for the exported fle and selecting the fle 
format, you may be able to set options for the exported image—
compression, color format, version of Metafle—depending on the 
format chosen. Some examples of the various option dialogs are shown 
in Figure 120.

Where the export dialog allows you to specify the image resolution, 
this does not afect the number of raster points in the image. Rather it 
inserts information into the picture that tells other programs the 
dimensions to be used in displaying the image. This means that, among 
other things, missing raster points can be interpolated when the 
graphic is opened in the other program.
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Figure 120: Adjusting format specifc properties prior to export

The actual number of pixels used is determined by the screen 
resolution set up by the operating system and the Drawing scale factor 
set in Tools > Options > OpenOfce.org Draw > General. This is a 
limitation of the current user interface; it is possible to set other 
resolutions using macros.

Embedded raster graphics, or objects that have been converted to a 
bitmap or Metafle (from the context menu Convert > To Bitmap / To 
Metafle) may subsequently be saved as a picture; from the context 
menu choose Save as Picture. This saves the picture without Draw-
specifc additions such as text elements, borders, or shadows and 
without the possibility of setting any of the options available when 
exporting.

Draw objects can easily be imported into Writer, Calc, or Impress 
documents. For objects used often, this is most simply done by storing 
them in the Gallery or by using the clipboard. As Writer and Calc do 
not possess the same range of tools available within Draw, it makes 
sense to use Draw to produce a complex drawing and then to copy it 
into the other OOo application. A link to single drawing objects is not 
possible, but you can incorporate Draw documents in the other 
modules as linked OLE objects.
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Tip

To avoid problems when scaling Draw objects containing text 
after importing them into Writer, convert the object to a polygon 
before storing it in the Gallery or copying it to the clipboard. 
See “Convert to a polygon” on page 110.

Modifying raster object properties
As with other objects, the properties of a raster graphic can be 
modifed. You can format the graphic using the Format menu or the 
context menu. Use the Picture toolbar to add or change flters using 
the Graphic Filter Bar; adjust the Lines, Areas and Shadows 
properties. The Transparency property in the Format menu does not 
relate to the transparency of the raster graphic itself but to the 
background area. To set the transparency of the graphic, you must use 
the Picture toolbar.

Graphics can also have a text element. For more on text, see Chapter 
10 (Advanced Draw Techniques).

You can change the position and size of graphics, or rotate them, using 
the methods described in Chapter 3 (Working with Objects and Object 
Points). Raster graphics can be fipped (Modify > Flip), but note that 
some Metafle formats might have problems fipping text.

Graphics included as a member of a group behave like other drawing 
objects when the properties of the group are modifed.

It is a good idea to (re-)name the graphic using Name from the Modify 
menu or the context menu. Only named objects are visible in the 
Navigator and only named objects can be directly imported from 
another fle.

The picture (editing) toolbar
If you have enabled the Picture toolbar (in View > Toolbars), it will 
automatically appear on the screen whenever you select a (bitmap) 
picture. It appears either directly under the menu bar in place of the 
formatting toolbar or as a foating toolbar elsewhere on the screen.

Figure 121: The Picture toolbar
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The following table explains the individual functions on the Picture 
toolbar and illustrates their use with examples.

Filter Opens the Filter toolbar, which is described in “The
graphic flter toolbar” on page 101.

Graphics Mode Use the Graphics mode menu to change the display 
of the graphic from normal color to grayscale, black 
and white, or a watermark. This setting afects only 
the display and printing of the picture; the picture 
itself remains unchanged.

Default: The graphic is displayed unaltered in color.

Grayscale: The graphic is displayed in 256 shades of gray.

Black/White: The graphic is displayed in black and white.

Watermark: The brightness and contrast of the graphic are 
reduced to the extent that the graphic can be used 
as a watermark (background).

Color Use the Color tool to adjust the values of the three 
RGB colors, the brightness, contrast and the Gamma 
value. These adjustments do not afect the original 
picture but the values are stored in Draw as a 
separate formatting set.

You can select values from between –100% (no 
color) to +100% (full intensity); 0% irepresents the 
original value of the property.

The brightness can be adjusted between –100% 
(totally black) and +100% (totally white).

The contrast can be adjusted between –100% 
(minimum) and +100% (maximum).
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The Gamma value afects the brightness of the 
middle color tones. Values can range from 0.10 
(minimum) to 10 (maximum)

Hint: Try adjusting this value if changing 
brightness /contrast does not give you the result you 
want.

Transparency The degree of transparency of the picture can be 
adjusted between 0% (opaque) and 100% (fully 
transparent).

Line Opens the Line dialog. In this context, line refers to 
the outline of the border. See also Chapter 4 
(Changing Object Attributes).

Area Opens the Area dialog. Here you can edit color, 
gradient, hatching and flls of the background area 
that contains the graphic—not the graphic itself. To 
see the background, you must set the transparency 
of the graphic to a suitably high value.

Shadow Use this tool to set a shadow efect around the 
graphic.

Crop Use this function to crop (trim) an image. When you 
click on this icon, crop marks appear on the image 
(Figure 122). Drag one or more of these marks to 
crop the picture to your desired size. For more 
accurate cropping, see “Cropping” below.

Figure 122: Interactive crop marks on an image
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Cropping

Figure 123: The Crop dialog

More control and accuracy over cropping functions are available via 
the Format menu. Click Format > Crop Picture and the dialog box in 
Figure 123 will appear. The felds Left, Right, Top, and Bottom 
establish the amount to be trimmed of the appropriate edge. 

In addition to cropping, you can also enlarge or reduce the size of the 
graphic by changing the percentage scaling values. The new 
dimensions of the graphic are shown in the Image Size width and 
height boxes, which can also be directly adjusted.

In Figure 123 you can see that 2 cm from the left side and 1 cm from 
the top, bottom, and right side will be trimmed from the original 
object. The preview pane shows the location of the new edges of the 
graphic. In addition both height and width have been scaled down by 
28%.

• If you choose Keep Scale, the graphic will be cropped to the scales 
shown in the width and height boxes and the picture reduced in size 
accordingly.

• If you choose Keep image size, the graphic will be cropped and then 
enlarged to the original image size.

Take care with these operations: in the Crop dialog the width and 
height are treated as totally independent values. Changing one without 
the other can result in signifcant distortion of the image; this might 
not be what you want. (The Position and Size dialog on the context 
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menu has an option for keeping the width:height ratio fxed while 
changing one of the two dimensions.) Changing values in one area 
(Scale or Image Size) will show up correspondingly in the other area.

Caution
Any changes made in the Crop dialog change only the view of 
the picture. The original picture is not changed. If you want to 
export a cropped graphic, you must do it through File > 
Export. If you use the option Save as Picture from the 
context menu, the changes are not exported.

The graphic flter toolbar

Click the Filter icon (  icon) to open the Filter toolbar. Draw ofers 
eleven flter efects. Filters work on the current view of an object and 
they can be combined. Filters always apply to the entire graphic; it is 
not possible to use flters to edit only a part of the object.

Invert reverses (inverts) the colors of an image so that it 
appears as a color negative of the image.

  

Smooth reduces the contrast between neighboring pixels and 
produces a slight lack of sharpness. If you use the flter 
several times in a row, the efect will be strengthened.
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Sharpen increases the contrast between neighboring pixels, 
emphasizing the brightness diference. This will accentuate 
the outlines. The efect will be strengthened if you apply the 
flter several times in a row.

    

Remove noise compares every pixel with its neighbors and 
replaces the extreme values (those that deviate in color by a 
large amount from a mean value) by a pixel with a mean color 
value. The amount of picture information does not increase, 
but because there are fewer contrast changes our brains can 
better recognize the resulting graphic. This flter tends to 
make the picture also a little more smooth.

     

Solarization was originally a photochemical efect. If the 
location of a photograph is extremely highly lit, you can 
experience a reversal of color and brightness. Similarly, entry 
of light during the developing process reverses the brightness 
values. These phenomena were used for artistic production of 
pictures.

With this flter you input a threshold brightness value, above 
which the color values are reversed (middle picture, 
threshold value 70%). With the Invert option the whole of the 
resulting picture is inverted in color (right picture).
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Aging lends pictures a certain “look” resembling that of old 
photos. The process frst produces a grayscale picture from 
the original and then reduces the intensity of the blue and 
green color values, so that the fnal picture appears darker 
and redder. In the middle example, the aging degree was set 
to 0%, at right it was 15%.

     

Posterize reduces the number of colors in the picture. The 
fewer colors, the more fat the picture appears. In the right 
picture below the number of colors was reduced to 8. The 
results of this flter are not always good.

   

The Pop-Art flter is supposed to change the colors of the 
picture to a pop-art format, but unfortunately it does not seem 
to function correctly at present.
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Charcoal sketch makes the picture appear as if it had been 
drawn with charcoal. The outlines are in black and the 
original colors are suppressed.

  

The Relief flter calculates the edges in relief of the picture 
and produces a picture as if illuminated by a light source, the 
position of the illuminating light being variable and producing 
shadows in diferent directions and magnitude.

  

Mosaic takes groups of pixels and converts them into a single 
color rectangular tile. The whole picture appears to be a 
mosaic. The center and right pictures below had an element 
resolution of 5 pixels. The picture on the right also had the 
Enhance edges option selected; with the greater contrast at 
the edges, it appears to be a little sharper.
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Caution

If your picture is linked, flters are applied only to the current 
view. The stored picture is not changed. When you close the 
document, all fltering is lost. You should ensure that you 
export the picture to create a copy with all the flters applied 
(File > Export).

If you have embedded the graphic in the document, all flters 
are applied directly on the embedded graphic and cannot be 
undone in a subsequent session. If you do not want to retain a 
flter, you must use Edit > Undo to return to an earlier state 
of editing. After you save and close the document, the flter 
efects are permanent.

Eyedropper
Use the eyedropper to change one color in a picture for another or set 
the color as transparent. The tool always works on the entire picture; 
you cannot select only a region for editing.

The changes are carried out on the graphic itself and therefore require 
it to be embedded. Attempts to use the eyedropper tool on a linked 
graphic result in the following message: This graphic is linked to a 
document. Do you want to unlink the graphic is order to edit it?

The tool can be used on all raster graphic formats and with many 
Metafle formats.

Note The eyedropper might not work on some Metafle formats.

Practical example: Changing wrong colors to 
transparency
Some applications, which cannot correctly handle transparency, show 
transparent areas with the color Magenta and then store the graphic 
with this color and without the correct transparency information.

   
Bitmap graphic with area in magenta, which actually 
should be shown transparent. On the left is the 
original picture, right is the picture after saving it with 
MS Paint.

If you receive such a picture, you can recreate the transparency with 
the eyedropper tool.
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Open the Eyedropper dialog with 
Tools > Eyedropper and click on 
the picture to be edited.

Now click on the icon , to change 
to the color selection mode. Outside 
the dialog the cursor changes to a 
hand. The feld next to the icon 
shows the color immediately under 
the hand cursor.

Click on the color to be changed. 
The frst Source Color box is now 
marked and the color selected 
appears in the left box. In the 
Replace with selection list, the 
option Transparent is already 
selected. Click on the Replace 
button at the top right of the box to 
carry out the changes to the picture. 
There is no preview of the efect. If 
the result is not what you wanted, 
choose Edit > Undo.

The dialog does not close automatically, so you can carry out further 
color replacements. Mark frst the feld for the Source color and 
choose again the color with the eyedropper. Close the dialog with 
Ctrl+F4 or the Close icon on the window border. Draw uses an Alpha 
channel for transparency so that pixels of diferent colors can be made 
transparent.

It is also possible to carry out the operation in reverse to change a 
transparent area to a color. Select nothing in the graphic but choose 
the Transparency option at the lower left of the dialog and the 
replacement color at the lower right.
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The selection list for replacement colors shows all the available colors 
in the current color palette of the document. You cannot defne any 
new colors here but you can add colors to the available palette before 
using the eyedropper tool. For more on this topic, see Chapter 8 (Tips 
and Tricks).

Efect of the tolerance parameter
The tolerance parameter describes how closely a color value in the 
picture must agree with the source color in order to be replaced. In the 
fgure below, the red color tone at the left edge of the rectangular color 
palette is used as the source color and a pure blue as the replacement 
color with several diferent tolerances. The original is a rectangle with 
color palette from red to green. Because the eyedropper is not usable 
on drawings, the rectangle on the left side was converted into a raster 
graphic (Convert > Bitmap). The picture was then exported in a 
Enhanced Metafle format and inserted on the right.

Note
The application of transparency and color replacement efects on 
raster graphics and Metafles leads to quite diferent results. This 
is a known problem, which will be corrected in a future version.

Color depth
It is possible to reduce the color depth in OOo. The tools are available 
but you must create a separate menu and add the tools to the menu if 
you wish to have them available (refer to OOo help if you are not sure 
how to do this). To fnd the tools, click on Tools > Customize, 
Toolbars, and Add (Command). The commands are in the category 
Modify, at the top of the list.
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Reducing color depth

Original with a 24 bit pixel depth (=8 bits 
per channel)

1 bit dithered

The impression of grayscale is produced 
by a raster. In reality there are only two 
colors.

1 bit threshold

The threshold determines which pixels 
are black and which are white. You 
cannot set it directly but you can 
infuence which part of the image is set 
to black by varying color settings on the 
picture toolbar—red, green, blue level, 
brightness, contrast, and/or gamma value
—to see what works best for your image. 
You must export and save the modifed 
image with File > Export and then 
reopen it, before you fnally change the 
color depth.

4 bit color palette

With 4 bits a total of 16 colors can be 
produced. The color steps are quite fne, 
because the process does not use the 16 
RGB basic colors, but selects from the 
palette those that best match the colors 
in the image.
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4 bit grayscale palette

8 bit color palette

With 8 bits a total of 256 colors can be 
produced. The image at left is at frst 
glance very difcult to distinguish from 
the original. A big diference is that the 
picture fle is only one third of the size of 
the 24 bit version.

8 bit grayscale palette

Conversion

Convert to a contoured image
Select the picture so you see the green handles. From the context 
menu or from the Modify menu choose Convert > to Contour. This 
command creates from the original image a polygon or group of 
polygons, with four corner points and the image set as a background 
graphic. In this state you are not able to further edit the graphic. All 
your modifcations must be completed before this point.

The polygon is in fact a vector graphic but the picture remains as a 
bitmap image. Using a polygon ofers possibilities for further change; 
for example, you can modify the shape or defne a transparency 
gradient.
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Convert to a polygon
Select the picture so you see the green handles. From the context 
menu or from the Modify menu, choose Convert > to Polygon. This 
command converts areas of the same color into small flled polygons. 
The total image becomes a vector graphic and can be resized with no 
loss of image quality or distortion of text. The resulting format will be a 
Metafle.

The Convert to Polygon dialog has a number of settings which can be 
tested using the Preview button. Because graphics conversion can take 
some time, depending on the picture and the computer, a progress bar 
is included at the bottom of the dialog (see Figure 124).

Figure 124: Conversion of a picture to polygons

Number of colors
Draw considers between 8 and 32 colors in the conversion. The picture 
can, however, contain fewer colors than 8. For every color occurring in 
the picture, Draw creates a polygon, which may consist of several 
disconnected parts. These polygons are then flled with the relevant 
color.

The algorithm used to reduce the number of colors in the picture to the 
number specifed is not yet optimal. For this reason you may prefer to 
try reducing the number of colors by changing the color depth or with 
the Posterize flter from the Graphic Filter toolbar (page 101).
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Point reduction
Polygons will only be created if they have a size greater than the value 
given in this setting. The section of the picture below, highly magnifed, 
shows that with a larger point count small fecks of color—typical of 
irregular color patterns—simply disappear.

2 Pixel 3 Pixel 

Fill holes
Point reduction can result in small areas or “holes” which are not 
covered by a polygon. If the Fill holes option is marked, additional 
square, tiled areas are created with a background color the same as 
the hole. The Tile size option allows the width in pixels of the width of 
these square areas to be preset.

Original picture Original picture with 16 colors 
and 0 Pixel point reduction 
vectorized

Original picture transformed with 
the Poster flter and 64 colors …

… and then with 16 colors and 
0 pixel point reduction vectorized.
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Here the picture is transformed 
with the Poster flter, but this time 
with a point reduction of 4 pixels 
and a tile size of 16 pixels.

The efect below was generated 
from the picture to the left 
(posterized and vectorized); the 
polygons were split with Modify 
> Break, and a number (in this 
case 6) of the (foreground) 
polygons were deleted until the 
resulting background was 
achieved.

Note: To select polygons for 
deletion, click on a curved colored 
area (the text in the status bar 
shows “Polygon nnn corners 
selected”, where nnn is the 
number of corners of the polygon) 
and a frame with green handles 
encloses the area of the polygons 
selected. Press Delete to delete 
the polygons. Repeat until you 
have achieved the desired efect, 
(which here is to have only the 
background showing).

If you next 'split' the existing Metafle (Modify > Split), access is 
gained to individual polygons. To be able to operate on these together 
you should immediately group them after splitting.

With this vectorized form of the image, you can carry out operations 
familiar from classic drawing programs, for example a curved warping 
operation. For such transformations, it is much less efort to use a 
conversion with background tiles so that the edges of the picture are 
straight.
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Using the graphic generated in the posterize and vectorize process 
above, Break and Split it, and then try out some operations using the 
tools on the Efects toolbar.

To use this tool to vectorize the frst letter of a chapter in a special 
font,  convert the graphic to a polygon, using no point reduction or 
background tiling. Use Modify > Break to generate two polyons. An 
example is shown below.

 

Original polygon, converted from a 
Metafle. Break the graphic into two 
polygons.

After the conversion there are two 
polygons, one with the visible letter and 
another polygon, not visible because the 
lines and area flling are all in white. You 
can select this “invisible” polygon by 
pressing the Tab button (click on the visible 
letter frst, then press Tab; this moves the 
current selection to the next object). In the 
example at left, the invisible polygon has 
been moved to the side. If you have Display 
Grid active and the grid points set to 
display behind objects, you can see where 
this invisible polygon is since it obscures 
the grid points behind it. 

This invisible polygon encloses the letter. 
After changing lines and/or area to a 
diferent color, the polygon becomes 
visible.
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Convert to bitmap
All drawing objects are vector graphics. Use the command Convert > 
To Bitmap from the context menu to convert a vector graphic to a 
raster graphic. Draw creates the raster graphic in PNG format with a 
color depth of 24 bits. Unfortunately any transparency efects which 
were created in the vector graphic are lost in this conversion, although 
the PNG format used in Draw does support transparency. Only if you 
use the eyedropper tool to set transparency will an Alpha channel also 
be produced.

To determine the height and width of the converted graphic (number of 
pixels), Draw considers the dpi setting of the operating system for the 
screen and the percentage scaling factor set under Tools > Options > 
OpenOfce.org > View in the section User Interface.

Example:

Width of vector graphic: 1.5 inch
Monitor setting of operating system: 96 dpi ( = 96 dots per inch)
Scaling 130 %

Calculation: 1.5 inch x 96 dpi *130% = 187 pixels

The actual number of pixels will vary somewhat from this value due to 
rounding. When the format permits, Draw uses a dpi value (in this case 
125 dpi) which permits the calculation to be reversed and the picture 
with this pixel value reproduced with the correct width of 1.5 inch.

Print options with raster graphics
If you have a black and white printer or are experiencing problems 
with printing, you should have a look at the following settings.

You can set up printing so that all text and all graphics are printed in 
grayscale or black and white. The general settings are in Tools > 
Options > OpenOfce.org Draw > Print in the section Quality (see 
Figure 125). To set these for the current document only, use Options in 
the Print dialog (File > Print). With both Black/white printing and 
Grayscale printing, no background is printed.
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Figure 125: Options - OpenOfce.org Draw - Print

Other options are in Tools > Options > OpenOfce.org > Print (see 
Figure 126). They relate to page options (scaling) and other printing 
variables. They afect the size of the print fle and the time taken to 
print the document. With most modern systems you can simply accept 
the defaults. As diferent operating systems and printers have their 
own requirements, you need to tailor the settings to your particular 
site conditions. Refer to the Help fle for more information.

Figure 126: Options - OpenOfce.org - Print dialog
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Creating 3D objects
Although Draw does not match the functionality of leading drawing or 
picture editing programs, it is capable of producing and editing very 
good 3D drawings and pictures.

Draw ofers two diferent types of 3D objects: 3D bodies and 3D 
shapes. Depending on which type you choose, there are diferent 
possibilities for further editing of the object (rotation, illumination, 
perspective). 3D shapes  are simpler to set up and edit than 3D bodies, 
but 3D bodies currently allow for more customization.

Creating 3D bodies
You can produce 3D bodies in three ways: extrusion, body rotation, and 
using ready made objects. In this chapter, these methods are called 
Variation 1, 2, and 3.

Variation 1: Extrusion
First, draw one of the common Draw objects, for example a 
square/rectangle, circle/ellipse or a text box using the  or  
icons on the Drawing toolbar. Next, choose Modify > Convert > To 
3D (or right-click on the object and choose Convert > To 3D, or click 

the  icon) to produce a 3D object from the 2D surface.

The  icon is not usually visible on the Drawing toolbar. To make it 
visible, select Visible Buttons from the toolbar menu at the right-
hand end of the toolbar and click on the icon to make it visible.

Figure 127: Extruding 3D objects from 2D 
surfaces

The procedure by which parallel surfaces are moved to create a 3D 
object is known as extrusion. In this case the 2D surface is moved 
forwards “out of” the drawing level. At the same time the object is 
slightly tilted and central projection turned on so that one can better 
recognize the object. Draw uses a default value for the extrusion (the 
body depth) based on the size of the 2D object. The value can be 
changed after the extrusion; see “Editing 3D objects” on page 121).
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Variation 2: Body rotation
Choose a common drawing object, for example a (non-black) line. Then 
change this into a rotation body. Draw provides two methods to do this.

Method 1. Click the icon  in the Drawing toolbar (this icon is also 
usually not visible) or choose Modify > Convert > To 3D Rotation 
object. With this rotation method, the axis of rotation coincides with 
the left edge of the enclosing selection rectangle, through the green 
rectangle handles.

Figure 128: Rotation body created using variation 2.1

Method 2. Click the icon  on the Efects pulldown menu on the 
Drawing toolbar. This icon can also be accessed from the Mode menu, 
accessible from View > Toolbars > Mode. Notice that this icon lacks 
the curved red arrow of the fxed-axis rotation icon.

With this method, you can change the location of the rotation axis, 
which appears as a dotted line with two white circular endpoints.

Figure 129: Rotation body created using variation 2.2

Click one of the white endpoints and drag it so that the axis moves to 
the desired position. You may need to move both ends to achieve this. 
The outline shows how the fgure will be rotated. When you click on 
the fgure again, the rotation is carried out and the new 3D body is 
produced.
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Variation 3: Using ready-made objects
Use the 3D Objects toolbar/pulldown menu (Figure 130). To activate 
this toolbar, click View > Toolbars > 3D Objects).

Figure 130: The 3D Objects toolbar

If you add the icon  to the Drawing toolbar, the 3D Object bar will 
be available as a pulldown menu or as a foating toolbar.

After choosing the type of object, left-click on the starting point and 
drag the mouse diagonally until the outline of the object is the size you 
want.

After releasing the mouse button, the 3D object appears. To change the 
height:width ratio of the object, keep the Shift key pressed while 
dragging the mouse. Most of these objects are constructed by rotation. 
Cubes and spheres are special types of 3D objects that are directly 
defned in the OOo program code.

3D scenes
Variations 1–3 all produce a result known as a 3D scene. If you click on 
a 3D scene, the status bar text shows 3D scene selected. Such a scene 
is actually a group of objects.

If you constructed the scene using one of the above methods, it 
consists of the 3D body as a single element. 3D scenes can, however, 
be extended to include other 3D objects, as described in “Combining
objects in 3D scenes” on page 144.

As mentioned in Chapter 6 (Editing Pictures), you can access individual 
elements of the group using Modify > Enter group or the context 
menu. The status bar text then changes and shows the type of each 
individual element selected, for example Sphere selected or Extrusion 
object selected.

Producing 3D shapes
Since the release of Version 2.0 of OpenOfce.org, Draw contains a 
type of drawing object known as a Shape. A special method of 
extrusion exists for these shapes.
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Variation 4: Extrusion of shapes

Figure 131: The Basic Shapes toolbar

You use the Basic Shapes toolbar (or another shape toolbar) to produce 
2D surfaces. Shapes such as cylinders or cubes are technically possible 
but not very useful, because they produce curiously curved images. If 

you have drawn a shape, the last icon  on the Drawing toolbar is 
active. A click on this icon can transform a 2D surface into a 3D object 
(see Figure 132).

Extrusion of a shape does not create a new object type but just 
changes the shape’s appearance. All the object’s properties and 
settings are retained. You can use this button to toggle between a 2D 
and a 3D view. The actual object properties and settings are not lost in 
the switching operation from one view to another.

Figure 132: 3D objects from basic shapes

If you click on such an object, the 3D-Settings toolbar is available. If 
this is not automatically opened, switch it on with View > Toolbars > 
3D-Settings.

Figure 133: 3D-Settings toolbar

The frst icon  corresponds to the icon on the Drawing toolbar. This 
icon also works as a toggle switch. After changing to 2D, the 3D-
Settings toolbar is again hidden. To change the object back to 3D, you 

must use the icon  on the Drawing toolbar.

Variation 5: Fontwork
For text you can also use the shapes from the Fontwork Gallery. These 
produce a similar type of extrusion objects to those from Variation 4. 
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To open the Fontwork Gallery, use the icon  on the Drawing toolbar.

Figure 134: Extrusion Shapes from the Fontwork Gallery

Note

Draw objects of the type “Shape” cannot be viewed with 
OpenOfce.org Version 1.x. They are simply missing from the 
drawing. If you save a document with extruded shapes in the 
older *.sxw format, the shapes will be converted to 3D scenes.

Editing 3D objects

Rotating 3D objects

Procedure for 3D bodies
The Rotation command used for 2D objects also works with 3D objects, 
but due to the additional axis, there are a few diferences with the 
editing of 3D objects (see Figure 135). The procedure for selecting the 
object is identical to that used for a 2D object.
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Figure 135: 3D object rotation

You can rotate the object about each axis (X,Y,Z). The X and Y axes are 
those parallel to the edges of the drawing layer, while the Z axis comes 
out of the page. It is not possible to change the axis orientation. 

The three axes are not shown directly, but the  symbol indicates 
their intersection point.

You want to … You must ...

... rotate the object 
about the X or Y axis.

... put the mouse cursor over the object. 
With the left mouse key pressed you can 
now rotate the object as you wish. Moving 
one of the red points at the middle of an 
edge allows you to rotate the object about 
only one axis. Note that the cursor initially 
has the shape for a (2D) shearing 
movement but pressing the mouse button 
changes it to a rotation cursor.

... rotate the object 
about the Z axis.

... move the handle on one of the corner 
points with the left mouse button pressed. 
Rotation about the Z axis is independent of 
the setting of the rotation angle in the 
dialog Position and Size.

... move the axis 
intersection point.

... simply drag the Symbol  to the desired 
location. The point is located by default in 
the middle of the object.

These rotations can be carried out on a 3D scene as a whole or on 
individual objects within a 3D scene.
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Procedure for 3D shapes
Objects produced using variations 4 and 5 (see above) can only be 
rotated about the Z axis when using the three methods described in 
the previous section. This rotation is carried out on the underlying 2D 
object. It is also possible to rotate the 3D object in the same way as 
with a 2D object using Format > Position and Size > Rotation 
(shortcut key for Position and Size is F4) and specifying the pivot point 
location and the number of degrees of rotation desired.

Shape objects have their own procedure for rotation about the X and Y 
axes. If you have activated the 3D-Settings toolbar (under View > 
Toolbars), this becomes active when you select the 3D object; icons 2 
to 5 on this toolbar (see Figure 136) rotate the object in 5 degree 
increments about the X and Y axes.

Figure 136: 3D-Settings toolbar with 
rotation icons indicated

3D settings for 3D bodies

3D Efects dialog – general buttons
The 3D Efects dialog ofers a wide range of possible settings for 3D 
objects produced with variations 1 to 3 (see previous sections). To open 
the dialog, right-click on the object and choose 3D Efects from the 

pop-up menu. You can also activate a 3D Efects icon  on the 
Standard toolbar or add it to another toolbar using Customize 
Toolbar > Add > Category Options > 3D Efects.

The dialog can be docked in a similar manner to the Navigator or 
Template windows.

The possible settings are arranged in various thematic categories on 
separate pages, accessible through the buttons at the top of the 
window, which act in a similar way to tabs. To apply the settings you 
have altered, click the Assign button . This applies all the changes 
you have made to the object on the other pages of the dialog as well as 
the current one.
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Figure 137: Upper part of the 3D Efects dialog

Note

Only the selected efects are assigned to the object. There is no 
object conversion; thus a cylinder cannot be transformed into a 
ring through the application of a 3D efect. However, it is 
possible to change the appearance to a wooden or metal body. 
By the assignment of a 3D efect, 2D objects are transformed 
into 3D objects.

In order for the Efects dialog to take over all the current properties of 

the object, you must click the  button. If you deactivate this button 
before you leave an object and click on it again when you open the 
Efects dialog for another object, the settings are carried over from the 
frst object to the second object. You can use this to transfer favorite 
settings from one object to another, as all the settings are brought over 
to the new object. In normal use, however, the icon should be left 
activated.

At the bottom left of the dialog is another row of buttons (see Figure
138), which are available on each page.

Figure 138: Buttons for geometric transformations

The frst two buttons correspond to the menu commands Modify > 
Convert > To 3D / To 3D Rotation Object. When the Efects dialog 
for a 3D object is called up, these buttons are inactive. The third icon 
switches on or of a perspective view of the object.

Converts the selected 2D object to an extrusion body.

Converts the selected 2D object to a rotation body.

Switches between a central projection and a perspective 
projection.

With a central projection parallel edges are shown as meeting at some 
common point in the distance, as shown on the button symbol. Parallel 
projection retains all parallel edges as parallel, as is often used to 
produce oblique fgures in school. The switching process is carried out 
on the entire 3D scene.
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With central projection (see Figure 139), Draw creates the object with 
three vanishing points. The parameters for central projection are set 
(indirectly) through the camera settings on the Shading dialog page.

Figure 139: Figure shown using 
central projection. For clarity the 
projection lines have been added.

3D Efects - Geometry
On the Geometry page, you can make changes to the geometry of a 3D 

object. This page is opened with the Geometry button  in the upper 
part of the 3D Efects dialog.
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Figure 140: Geometry page

In the frst example, the depth (length) of a body is to be changed. This 
is possible only if you created it through extrusion. To illustrate: draw a 
circle and convert it according to Variation 1 into a 3D object (a fat 
cylinder); see Figure 141a and b.

If necessary, select the cylinder, open the 3D Efects dialog, make sure 
the Geometry page is active, change the parameter Depth to 3.5cm 
and click on the Assign icon . The cylinder should now resemble the 
fgure in Figure 141c.

Figure 141: Conversion by extrusion 
of a 2D object (a) into a 3D object (b) 
and then changing its depth (c)

This parameter has no efect on a rotation body or on ready-made 3D 
objects, although the input feld remains active.

With the Rounding parameter you can specify how strongly the edges 
of the 3D object are rounded. Select (if necessary) the lengthened 
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cylinder again and use the 3D Efects dialog to change the rounding to 
30%. The cylinder should now resemble that in Figure 142.

Figure 142: Edge rounding 
of 10% (a) and 30% (b)

This parameter also has interesting efects when you convert text into 
a 3D object.

The Scaled Depth parameter sets the size ratio of the front to the back 
for a 3D object produced by extrusion. The front side of such an object 
always protrudes out from the original surface; the rear side is the 
original surface of the 2D object (that is, the 2D exit surface) even if 
the object has been rotated in the meantime.

By default the scaling is set to 100%, which results in both surfaces 
being scaled by the same amount. If you set this scaling to 50% the 
cylinder becomes a truncated cone (see Figure 143).

Figure 143: Cylinder with 50% scaling

The diameter of the front side is 50% that of the rear side. It is also 
possible to create the reverse efect, with the rear side smaller than 
the front, by using a scaling depth greater than 100%.

With rotation bodies this parameter infuences the width of the surface 
parallel to the axis of rotation. At the end of the rotation the surface 
width of the fgure is given by the scaling depth. The distance to the 
rotation axis remains unchanged. In Figure 144 a line is rotated to 
create a 3D object with a scaling depth fgure of 0%.
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Figure 144: Scaling depth of a 
rotation body

The Rotation Angle parameter is only available for rotation bodies. 
With this parameter you can create a segment of a complete rotation 
body by choosing an angle less than 360 degrees. Figure 145 shows a 
hemisphere with a rotation angle of 270°.

Figure 145: Hemisphere with 
a rotation angle of 270°

The Horizontal and Vertical Segments parameters defne the number 
of segments out of which Draw builds spheres and rotation objects2. 
For rotation objects, the horizontal segments are more important. The 
vertical segments infuence the degree of edge rounding.

In Figure 146 the left sphere is made up of 10 horizontal and vertical 
segments while the right sphere has 25 segments. More segments give 
a smoother surface, but it will take longer to generate the fgure on the 
screen. By default, spheres and hemispheres are constructed with 24 
segments. For a square pyramid you need four horizontal segments.

2 To reduce both calculation time and data storage, circles are often constructed as regular 
polygons. If you cut a sphere or cylinder of 10 segments through the middle you end up with a 
20-cornered cut section (10-cornered for a hemisphere).
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Figure 146: Sphere from 10 segments (left) 
and 25 segments (right)

These are properties belonging to individual objects. If you use the 
setting for segments on a 3D scene, all the objects contained in the 
scene are modifed accordingly.

If you extrude an unflled circle or intersecting lines with a flling the 

result may not be what you expect. In this case the Double-Sided  
tool, on the lower part of the dialog page, may be able to help. It 
changes the line properties of an object from invisible to continuous 
and so enables all edges to be seen. Otherwise it may happen that 
some surfaces receive no flling (see Figure 147). For lines without 
flling the efect is switched on by default and cannot be switched of. 
This is also a property of single objects.

Figure 147: Left: without “Double-Sided”
Middle: with continuous lines but without 
“Double-Sided”
Right: with “Double-Sided”

Use the buttons in the section Normals to modify the normals of a 3D 
object.

A Normal is a straight line which is perpendicular to the surface of an 
object (in the same way that a vector, starting from an inner point and 
extending outwards, is at right angles to the surface of the object at 
the point where it exits). Figure 148 shows some normals extending 
outwards from a sphere made up of 10 segments.
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Figure 148: Normals (vectors) of 
a 3D sphere with 10 segments

Using normals, the display of the object surface and the variation in 
colors, textures and lighting can be controlled, infuencing directly how 
the surface of the object is rendered.

The frst three icons in Figure 140 work as “either-or” switches. Only 
one of the efects can be active at a given time; an efect can be 
switched of by clicking on one of the other icons.

The settings belong to individual objects, not scenes; every object can 
have its own setting. The rest of the icons are normal toggle “on-of” 
switches. The following efects are available:

Object specifc: The object is rendered to produce the best 
result independent of its shape. Single segments are changed 
but their “edges” will hardly be visible.

Flat: The surface of the 3D object will be divided into single 
polygons, whose edges are clearly recognizable. Every polygon 
is generated with a uniform color.

Spherical: The enclosing sphere is calculated for the object and 
then projected onto the object. This form of calculation 
produces an object with a smoother surface; the edges of 
individual segments are more smoothly rounded than with the 
Object-specifc efect (see Figure 149). However surfaces that 
meet at a point do not show a realistic lighting efect.

Invert Normals: This results in a reversal of the lighting 
direction. The inside of the body then becomes the outside. This 
property is particular to each individual object.

Double sided illumination: The lighting is also computed for the 
inside of the object. In other cases the lighting value for the 
outside is simply transferred to the inner side. This property is 
of interest for open objects. It is a property of the 3D scene and 
afects all objects in the scene.
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Figure 149: Cylinder with 10 segments 
a= Object-specifc b=Flat, c=Spherical

The following table shows the linkage between double-sided 
illumination and inverted normals.

The light source is on the 
right.

Normals
not inverted

Normals inverted

No double sided 
illumination

With double sided 
illumination

3D Efects - Shading
The Shading page ofers functions for shading the object surface, 
adding shadows and choosing camera settings.

Shading is a rendering method involving a consideration of  lighting 
ratios, which is used to produce curved 3D surfaces. The surfaces are 
broken down into small triangular segments. Draw ofers three 
methods to produce this efect: Flat, Phong and Gouraud. The setting 
selected applies to all objects in the 3D scene.

• Flat is the fastest and simplest method. For every individual 
segment a special color tone is determined, based on the lighting ratio 
and the direction of the segment area. This tone is used for the whole 
area of the segment. The segmentation is clearly visible.

• Phong is the most time-consuming method. With this method, for 
each pixel the associated normal is determined by interpolation, based 
on the normals of the segment edges. This causes the segment area to 
appear curved and the segment intersections are no longer visible.
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Figure 150: Shading page

• Gouraud is a relatively quick method. It determines the color value 
for the segment corners and calculates the color value for every pixel 
through linear interpolation. The segment edges are still recognizable, 
but importantly are less so than with the fat method. The Gouraud 
method considers only light refection on difuse, refecting surfaces 
(dispersal).

Figure 151: Flat, Phong and Gouraud shading

In Figure 151 the left sphere was rendered with fat shading, the 
middle with Phong and the right with Gouraud. The quality of the fat 
method is clearly inferior to the other two. The diference between 
Phong and Gouraud is small. With the Gouraud method the segments 
can be very faintly seen and rendered objects have a slightly less 
“shine” than with the Phong method.

All three methods function at the pixel level and as such, shadowing 
and mirroring inside the 3D scene is not possible in the way that ray 
tracing methods permit.
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With the the Shadow button  you can provide a 3D object with a 
shadow. By changing the Surface angle you can infuence the form of 
the shadow (see Figure 152). The left sphere has a surface angle of 0° 
(the paper represents a perpendicular surface behind the object) while 
the right sphere has a surface angle of 45°. With 90° the paper would 
be directly under the object.

Figure 152: Shadows using 
diferent surface angles

The shape and size of the the shadow are also infuenced by the 
lighting properties. These can be adjusted on the Illumination page of 
the dialog. Multiple light sources for shadows are not yet supported. 
The shadow properties can be set for individual objects in a drawing 
but where objects form part of a 3D scene, the shadow produced is 
that of the entire scene.

It is possible to set the shadow property for single objects using the 
Area property. The shadow is then shown with the color selected in the 
shadow dialog, but again the representation of the lighting of the 
scene determines the end result of the entire scene. In this way, 
colored shadows, with diferent distances to the object, and diferent 
color and transparency efects can be created.

In the Camera feld of the shading dialog the settings of the virtual 
camera can be changed. These settings relate only to the view in 
central projection and apply to the entire 3D scene. The Distance 
parameter is used to adjust the spacing between the camera and 
scene. The default value for an extruded body is equal to the depth or 
length of the body. With equal length edges front and rear, the efect at 
large distances is quite small. The standard value of Focal length is 
10cm. It has the same signifcance as with a real camera. Larger focal 
lengths simulate a telephoto lens, smaller ones a wide-angle lens. The 
efect that changes in the camera settings have on an object are shown 
in Figure 153.
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Figure 153: Efect of camera settings

Picture a shows a 3D object with the standard settings. The individual 
changes are listed in the following table.

a b c d

Distance: 0.81 cm 3.81 cm 0.81 cm 0.81 cm

Focal length: 10 cm 10 cm 5 cm 15 cm

3D Efects - Illumination
On the Illumination page (see Figure 154) you defne how a 3D object 
is lit. The settings apply to all objects in a scene.

Figure 154: Illumination (lighting) page
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You can light a scene with a maximum of eight individual Light sources 
at the same time. For each of these sources the light color and position 
relative to the scene can be set. The light sources are represented by 
eight small light bulbs. When you select this page, the frst bulb “lights 

up” . At least one light source must be active; otherwise, the 
rendering and shading functions cannot function correctly.

Each symbol functions like a multi-function press switch. With the frst 
mouse click the bulb is selected and with the second click the settings 
mode for this light source is activated (see Figure 155). A third click 
deactivates the light source.

Figure 155: Adjustment of light source

In the selection list next to the symbols you can choose the color of the 

active light source. If desired, click the  button to open a color 
palette dialog, where you can defne your own color and also adjust the 
brightness. For the frst light source, it is best to retain the neutral 
color value (default is white); with several light sources it is advisable 
to reduce the brightness.

In the lower right corner of the menu the light source location and 
orientation is depicted. With the vertical slider bar you can adjust the 
lighting angle; with the horizontal bar the light is rotated about the 
object. Alternatively you can click on the light point and drag the point 
as you please (see Figure 156). Click on the small square in the bottom 
right (circled) to change the preview image from a sphere to a cube.
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Figure 156: Moving the light source

To apply the changed settings to the selected object, click on the the 
Assign button .

The use of additional light sources can result in some interesting 
efects.

Figure 157: Lighting with three independent light sources

In Figure 157 the ring has the lighting settings from Figure 154 with 
the standard color white. In addition it was lit with magenta, and also 
from the left underside with yellow. The number and position of the 
light sources is shown in the window at the lower right. The three light 

sources in use can be recognized by the “lit” symbols .

To see the efect of a particular lighting efect you can also temporarily 
turn it of. With an object selected, clicking on a “lit” symbol turns it of 

. This new setting must then be applied (assigned) to the scene. With 
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a further mouse click on the light source the efect can be switched 
back on and then re-assigned.

You can also change the settings for the Ambient lighting. The 
selection of properties (lighting color, brightness, and so on) is carried 
out in same way as for light sources.

3D Efects - Textures
Textures are raster graphics (bitmaps) which can be used as an object 
property for the surface of an object. Every object in a 3D scene can 
have its own texture.

You can set a raster graphic as a texture for a 3D object in the same 
way as for a 2D object (Format > Area > Bitmaps or right-click on 
the object > Area > Bitmaps) – as is the case for Gradient and 
Hatching. More details are found in Chapter 4 (Changing Object 
Attributes).

If the Fill setting on the Area dialog is Color, then the Texture page is 
inactive. Change it to Bitmap to activate the Texture page for 3D 
objects. If the texture is not tiled or stretched and is smaller than the 
object, then the remainder of the area will have the color of the Object 
color property on the Material page.

Figure 158: Textures page
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In the frst row of the page (Figure 158) are two switches (Type) with 
which you can choose between black and white or color for the texture 
(see Figure 159).

Figure 159: a - standard color setting, b - texture 
(color), c - texture (black and white)

With the two switches in the row Mode you can control whether the 
texture of the selected objects is rendered with light and shadows 
(Switch 2) or not (Switch 1); see Figure 160. By means of appropriate 
lighting and shading adjustments, the graphic object is more 
realistically rendered.

Figure 160: Texture without (a) and with 
(b) lighting and shadow efects

Projection X / Y

With one of the three buttons you can determine how the texture for 
this coordinate axis should be projected onto the object. The default 
setting, Object specifc, in general gives the best result. Examples of 
the use of each button are shown below.

Object specifc The texture is automatically adjusted to best ft 
with the form and size of the object.

Parallel The texture is projected parallel to the axis of the 
object. It is mirrored on the rear side of the object.

  Circular The axis of the texture pattern is wrapped around 
the object.
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For a rotation body, the turning axis is the Z axis and the wrapping is 
the X direction; for an extrusion body, the extrusion direction is the Z 
axis and the extruded surface is the X direction. Depending on how the 
object was produced, diferent positions of the texture result.

OpenOfce.org

Area fll without 
tiling, with 
adjustments

Projection X Projection X Projection X

Projection Y

Projection Y

(Diference is 
small)  Front and rear side

Figure 161: Cylinder as a rotation body

OpenOfce.org

Area fll without 
tiling, with 
adjustments

Projection X Projection X Projection X

Projection Y

Projection Y

(Diference is 
small)  

Upper and under 
sides

Figure 162: Cylinder as an extrusion object

The Filter button  switches on and of a soft-focus flter. It can often 
remove slight faults and errors in the texture.
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3D Efects - Material
On this page you can assign the appearance of diferent materials to 
the 3D object.

Figure 163: Material menu

In the selection list under Favorites are the most commonly used 
materials (see Figure 164).

Figure 164: The favorites (from left to right): 
Metal, Gold, Chrome, Plastic and Wood

With the individual color parameters, additional efects can be 
produced. The meaning of these parameters corresponds to those on 
the Illumination dialog page.

Materials and textures can be combined with one another. Settings 
only simulate materials and it is sometimes a matter of trial and error 
to achieve the desired result.

Tip
Do not use too high a brightness value for individual colors. 
These are all additive and it is easy to end up with a totally 
white “colored” area.

140 OpenOfce.org 3.x Draw Guide



The Illumination color brightens 
those parts of the object which lie 
in shadow making the body seem 
more illuminated.

When textures are used as well, the 
Illumination color is combined with 
the white color part of the texture. 
On the left the object has a black 
Illumination color, on the right 
bright green.

The Specular color simulates the 
refecting capacity of the surface. 
The position of the illuminated point 
is determined by the setting of the 
frst light source.

Left: Set the Specular color the 
same as the object color and the 
illumination point intensity to a low 
value, in order to give the 
impression of a matt body.

Right: Set the Illumination point 
color the same as the light source 
color, in order to give a shiny 
appearance to the object surface.

 

Metallic surfaces and glass are not so well simulated, because the 
impression of these materials is produced through refection. Such 
simulation cannot (at the moment) be calculated by OpenOfce.org.

3D settings for 3D shapes
3D shapes are handled quite diferently from objects in 3D scenes. The 
appearance of a shape object is changed using the 3D-Settings toolbar 
(see Figure 165). The 3D Efects dialog described above should not be 
used for shape objects as it will not give the correct formatting results.
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Figure 165: 3D-Settings toolbar, indicating 
icons for formatting 3D shapes

If you have used it in error, you can remove the incorrect formatting 
with Format > Default Formatting.

With the buttons on this toolbar you can adjust the extrusion depth and 
perspective, lighting and material properties as well as the extrusion 
color. There are tear-of bars, which  you open by clicking on the small 
black triangle. The purpose of each individual button is described by 
its tool tip. You do not need to assign the result of any of the functions 
to the object as you do with the 3D Efects dialog used with 3D scenes; 
every action is immediately applied and you can see its efect on the 
object in the main Draw window.

Note

The program may sometimes seem to generate the wrong 
formatting with shape objects. The exact cause is not known, 
but you can undo the action with Format > Default 
Formatting. One reason for bad formatting can be that you 
have used a function from the 3D Efect dialog on a 3D shape.

Here are some examples of formatting of 3D shapes:

Depth 

left: 0.3cm (user defned)

right: 1cm (selection)

 

Direction 

The examples show “columns” at  right 
angles to the drawing surface.

left: 5 cm depth, Parallel projection

middle: 10 cm depth, Perspective

right: Infnity, Perspective
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Illumination 

The light color cannot be changed, the 
brightness can be changed only in three 
levels, and some efects may not be 
totally correctly rendered.

left: from left under, dim

middle: from left under, bright

right: from right under, normal

Surface 

Only four built-in variations are 
possible. At present only Wireframe and 
Matt are correctly rendered.

left: Wireframe
right: Matt

You can also choose a gradient, 
hatching, or bitmap for the surface; 
these are only applied to the extruded 
surface—the sides remain in the color of 
the object.

 

3D Color 

Here you can choose the color of the 
sides of the extruded surface.

The symbol shows the color of the most 
recently chosen shape object.
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Combining objects in 3D scenes
3D objects produced by extrusion or rotation are shown in the status 
bar as a 3D scene. You can group together several of these objects. 
Other object types cannot be so grouped. Management of the group is 
carried out in the same way as described in other parts of this guide 
(Modify > Enter Group, or Modify > Exit Group), see also 
“Grouping Objects” in Chapter 5 (Combining Multiple Objects).

As an example, we will produce a game piece.

First produce both objects independently 
of each other. The subsequent combination 
is made easier if you use parallel 
projection and rotate the objects into an 
upright, straight position.

Click on the sphere and use Edit > Copy 
to take over the scene and put the sphere 
on the clipboard. If you are sure that you 
do not need the original anymore you can 
use Edit > Cut. In any case move the 
sphere a little to the side.

Click now on the cone. The status bar will 
show 3D Scene selected. Right-click and 
enter the group. You will see that, as usual, 
elements that do not belong to the group 
are less bright.

Use Edit > Paste. Now the objects (not 
the whole scene) from the clipboard are 
pasted into this scene.

The original position of the sphere now 
contains a new sphere that belongs to the 
scene. This new sphere can be dragged 
over to the cone. Exit the group after 
moving the sphere.
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Notice that combining 3D objects results 
in them being more or less “fused” 
together – there is no stacking or layering 
as with 2D objects.

Adjust the position of the objects as you 
wish. You cannot arrange objects in front 
or behind others, as with 2D objects, but 
can only move them parallel to the 
drawing plane. 

Enter the group again and adjust the 
objects. The status bar indicates which 
object is marked. Use the Tab key to 
change from one object to the next in the 
group, if it is not possible to do so with the 
mouse. Exit the group.

 

Now you can rotate the entire 3D scene 
and view your game piece from all sides.

Examples for your own experiments
All examples use objects in 3D scenes.

Extruding a 2D object with text 
generates letters as separate objects 
and they have a larger extrusion 
depth than the background.
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3D objects of the Shape type can be 
rendered as wireframe models. This 
efect can be produced in other 3D 
objects by setting the Area fll to 
None and the line style to Continuous.

 

If you select several 2D objects—
without grouping them—and extrude 
the selection, they are transformed, 
according to their stacking order, with 
diferent extrusion depths. The object 
previously on top will be uppermost 
on the extruded object.

 

For 2D objects use Modify > Shapes 
> Merge/Subtract/Intersect to 
produce complex objects. The 
resulting fgures can be also 
extruded, rotated and so on.

 

Rotation of lines produces concave 
bodies. Use a bright line color. With a 
high number of vertical segments, the 
transition to the ground is relatively 
sharp-edged. Remember to switch on 
two-sided illumination.

The transparency of the platter is 
adjusted in the surface properties of 
the body. The best efect is obtained 
only when the transparent body is 
combined with other objects.

The color shadow of the fruit is 
produced by the use of multiple light 
sources – they are not “real” and do 
not rotate and change as the scene is 
rotated.
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Positioning objects with zoom
With zoom you can place objects with higher precision.

Figure 166: Using zoom to place 
objects with greater precision

Zoom adjustments using the status bar
The current zoom value is shown at the right-hand end of the status 
bar next to the zoom slider.

Figure 167: Zoom level on Status 
Bar

You can adjust the zoom value by using the slider, right-click on the 
zoom percent to select from a menu of preset values, or double-click to 
open the Zoom & View Layout dialog.

Figure 168: Zoom & View Layout

You can enter a zoom factor in the Variable feld, select 100%, or use 
one of the three other choices. (The three options on the right hand 
side of the dialog are not available in Draw; they are active only for 
text documents.)

• Optimal: The drawing or selected object(not the page) is enlarged 
to just ft in the Draw page area.
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• Fit width and height: The drawing page edges are set to the 
edges of the Draw page area.

• Fit width: The right and left page edges are set to the vertical 
edges of the Draw page area.

The exact efect of choosing one of these options depends on whether 
you have the Page pane switched on or of. 

Figure 169: Zoom values – Fit width and height, Fit width, and 
Optimal

The Zoom toolbar
The Zoom toolbar provides additional zoom options. On the Standard 
toolbar (View > Toolbars > Standard), click on the downwards arrow 
of the Zoom button . You can also permanently display the toolbar 
by clicking on View > Toolbars > Zoom.

Figure 170: Zoom Toolbar

Zoom in. Enlarges the monitor picture. First click on the 
button, then on the object. Alternatively drag to create a 
zoom “window”.

Zoom out. Makes the monitor picture smaller. Just click on 
the button.

Reverts objects to their original size.

Changes display to the previous and next zoom factors. If 
these buttons are not visible, turn them on by clicking on the 
small black arrow on the title bar of the Zoom toolbar, then 
on Visible Buttons and fnally on either of these two buttons.

Shows the entire page.

Zooms to page width.
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Resizes the display to include all objects on the slide.

Zooms the selected object to Optimal.

Enables moving the drawing inside the Draw window, using 
the mouse.

Positioning objects with snap functions
In Draw, objects can be accurately and consistently positioned using 
grid points, special snap points and lines, object frames, individual 
points on objects, or page edges. This function is known as Snap.

To use the snap function easily, work with the highest practical zoom 
value. You can use two diferent snap functions at the same time, for 
example snapping to a guide line and to the page edge. It is best, 
however, to activate only those functions that you really need.

Examples for setting up the snap functions are found in Chapter 10 
(Advanced Draw Techniques).

Snap to grid
Use this function to move an object exactly to a grid point. This 
function can be switched on and of with View > Grid > Snap to Grid 

and on the Options toolbar with the icon .

Figure 171: Exact positioning 
with the snap to grid function

Showing the grid
To make the grid visible, choose View > Grid > Display Grid. 

Alternatively turn the grid on (or of) with the icon  on the Options 
toolbar.
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Changing the color of the grid points
By default the grid points are bright gray and not always easy to see. 
Go to Tools > Options > OpenOfce.org > Appearance. In the 
Drawing / Presentation section, you can change the color of the grid 
points. On the Color Settings pulldown menu select a more 
suitable/visible color, for example black.

Figure 172: Changing the color of the grid points

Confguring the grid
Under Tools > Options > OpenOfce.org Draw > Grid you can 
change the settings of the grid (Figure 173).

No adjustment is necessary in the Grid feld, as these settings can be 
changed directly from the icons on the Options toolbar.

Figure 173: Confguring the grid
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Resolution: sets the horizontal and vertical distance between two grid 
points.

Figure 174: Grids with diferent resolutions

Subdivisions: determines how many steps there are between adjacent 
grid points. Intermediate steps make it possible to have a larger 
separation between two grid points, so the drawing remains clearer. 
Objects can snap to intermediate points in exactly the same way as to 
grid points.

Figure 175: Grid with intermediate steps (subdivisions)

The snap feld settings are largely self-explanatory. One important 
setting is the Snap range. Grid points and snap lines are both visual 
help elements that are managed separately by Draw. If you have 
activated a snap function and then move an object, Draw looks in the 
vicinity of the position of the object for those special help elements to 
determine the fnal position of the object; with the snap range setting, 
you can determine the extent of this search area. Exactly how large the 
snap area is depends on the current environment: which particular 
snap functions are in use, how the grid is confgured, and whether or 
not there may be collisions with other objects. It is usually necessary to 
do a little experimenting to fnd what best suits your needs.

Snap to Snap objects (snap lines and snap points)
Unlike grid points, Snap lines and Snap points are created by the user. 
Snap lines run horizontally or vertically and appear as dashed lines. 
Snap points appear as small crosses, again with dashed lines.
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Note

In OOo the names of the buttons in the Options toolbar are 
Display Guides and Snap to Guides when what is actually 
meant is Display Snap line and Snap to Snap line. These will 
hopefully be corrected in a subsequent version.

If you have activated this function, you can position objects exactly. 
Horizontal and vertical snap lines can be used together. Snap lines are 
not active immediately after inserting them but are turned on (or of) 

using the  icon or with the View menu. If the snap line is no longer 
needed you can hide it (or subsequently display it again) with the 

Display Guides icon  or using the View menu.

Figure 176: Objects ‘connected’ to snap lines (left) or to 
a snap point (right). Note that the snap point functions 
as if it were the intersection of two snap lines.

Inserting a snap line with the mouse
To insert a snap line in a drawing:

1) Hover the mouse cursor over either ruler (the vertical ruler to 
create a horizontal snap line and vice versa).

2) Click and hold the right mouse button.
3) Drag the mouse into the drawing area to produce a snap line.

The snap line can be moved at any time by dragging it with the mouse. 
Moving a snap line will not, however, move any objects that have 
already been snapped to that line.
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Inserting snap points and snap lines using coordinates
The command Insert > Snap point / line opens a dialog where you 
can specify X and Y coordinates and choose the type of snap object: 
point, vertical line, or horizontal line.

Figure 177: Setting a) snap object type and 
b) snap object position using X,Y coordinates

Editing snap points and snap lines
All snap objects can be edited after setting them. If you right-click on a 
snap object, an appropriate menu opens allowing you to edit or delete 
the snap object.

Snap to page edge
With this function you can snap objects to the page edge. A 
combination with snap lines and snap to grid is also possible.

Figure 178: Objects positioned 
on the page margins
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Snap to object border
With this function you can position one drawing object on the border of 
another. The connection point can lie anywhere on the object border. 
To use this function, frst deactivate Snap to grid. Figure 179 shows 
some examples. Note that a typical object border will touch the border 
of a round object at only one of its four points.

Figure 179: Objects positioned on the 
border of another object

Snap to object points
This function operates in a similar manner to the one just described. 
The diference is that the connection point can lie only at one of the 
four corner points of both the object being moved and the target 
object. This leads to the situation where two round objects have a 
connection point that does not lie on either object but at one of the red 
circled points.

Figure 180: Objects connected to the 
object point of another object
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Help to position objects with guiding lines
To simplify the positioning of objects it is possible to make visible 
guiding lines—extensions of the edges of the object—while it is being 
moved. These guiding lines have no snap function.

The guiding lines can be (de-)activated under Tools > Options > 
OpenOfce.org Draw > View > Guides when moving, or by 

clicking the  icon on the Options toolbar.

Figure 181: Working with guiding lines

Drawing to scale
In Draw a drawing is made on a predefned drawing area or canvas. 
This will usually be in the Letter or A4 format depending on your locale 
settings, and will be output to some “standard” printer that you have 
set up on your computer (usually referred to as the default printer). 
Depending on the actual size of the drawn objects, it is often necessary 
or convenient to reduce or enlarge the drawing by some scaling value. 
You can specify the scale that you wish to use under Tools > Options 
> OpenOfce.org Draw > General.

The scale and selected unit of measurement are automatically refected 
in the rulers, the window position and the window size. Scale settings 
can be stored permanently in a template that you can then use for new 
drawings.

The scale you use has no efect on the basic drawing operations. Draw 
will automatically calculate the necessary values (for example, 
dimension lines). The grid spacing is independent of drawing scale as 
the grid is not a drawing element but only an optical drawing aid.
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Note

If you want to insert elements in a drawing from the Gallery or 
Clipboard, you should draw these to the same scale as you are 
using for the drawing to ensure the proper size ratio is 
maintained.

Splitting drawings on multiple layers
Layers are like transparencies that lie one on top of another on an 
overhead projector. You can insert and extract single layers as desired. 
For example in architecture the foor plan, heating, and electrical 
wiring can all be on separate layers. With complex drawings this layer 
technique ofers many advantages. You can make layers visible or 
invisible as needed or you can protect a layer from further changes 
while you work.

In Draw three layers are always present by default: Layout, Controls, 
and Dimension Lines. Layout  is the default layer when you create a 
new drawing.

To change to a layer, click on its tab. Everything that is drawn will be 
placed on the currently selected layer. The Controls layer is for control 
elements such as icons and pulldowns and is not usually used for 
ordinary drawing elements. The Dimension Lines layer is used 
whenever you insert a dimension line on a drawing (unless the layer is 
made invisible). Use Insert > Layer to insert a new layer in a drawing 
(Figure 182 left).

  
Figure 182: Insert and modify layers
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On the Insert Layer dialog you can specify the following properties:

• Visible: If this property is not activated, the layer will not be 
shown (the layer is removed from the stack).

• Printable: If this property is not activated, the layer will not be 
printed. This is useful if you use a ‘draft’ layer for guides or 
annotations that you use in making the drawing but should not 
appear in the fnal output.

• Locked: All objects on this layer are protected from deletion, 
editing, or moving. No additional objects can be added to a 
protected layer. This property is useful when a base plan is to be 
protected while adding a new layer with other details.

Right-click on a layer tab to bring up a menu where you can insert or 
delete a layer, rename an existing layer, or modify a layer. You can 
change the names of the user-defned layers; the default layer names 
cannot be changed.

If you choose Modify you will see the dialog in Figure 182 right. On 
the Modify Layer dialog you cannot edit the Name but you can edit 
the Title and Description and change the properties of the layer 
(Visible, Printable, Locked).

Tip

Somewhat confusing is the fact that you can move objects on 
one layer although you are working on another layer. To avoid 
accidentally deleting or moving objects on another layer, you 
should lock  that layer.

An example drawing: house plan and furniture
A popular application for programs like Draw is the “moving the 
furniture” scenario. You can easily draw the foor plan of a room or a 
house using Draw. The simplest way is to draw walls as thick lines. You 
can also draw single rectangles or polygons, place them together, 
select them and then from the right-click menu use Shapes > Merge 
to make a single fgure, then add a hatching pattern. Before you do 
this, you should read the section “Drawing to scale” on page 156.

For this example a suitable measurement unit is centimeter. The 
drawing scale and grid settings depend on the size of the foor plan.

Use the Position and Size dialog (right-click and choose Position and 
Size) to easily position and dimension the individual wall sections. 
Make sure that the rectangles completely overlap (see Figure 183) 
otherwise the merging will give uneven edges.
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Figure 183: Wall corner from two rectangles. From upper to 
lower: before merging, after merging and after hatching

Figure 184 shows the fnished foor plan. In addition, a chest of 
drawers has been added.

The body of the chest is drawn on the Layout layer; the pulled-out 
drawer and the open doors are drawn as a group and put on a separate 
user-defned layer (Layer4 in our example). Figure 185 shows how this 
is done. Making the layer with the drawers and doors visible or hidden 
will show them open and closed (see Figure 186). Hidden layers are 
shown with a colored tab.

Figure 184: Floorplan with chest of drawers
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Figure 185: Using layers for diferent parts of a 
drawing. (Left) Draw the body of the chest on the 
Layout layer. (Right) Create a new layer and draw the 
open drawers and doors, keeping the Layout layer 
visible to help you position the additional objects.

   

Figure 186: Making layers visible or hidden. (Left) 
Hide the Layout layer to see what is on Layer4. 
(Right) Show the Layout layer and hide Layer4 to 
show chest with drawers closed.

Caution

If you copy a drawing object to the Clipboard or into the 
Gallery, all layers other than the three standard layers (Layout, 
Controls and Dimension Lines) are lost and all objects will be 
pasted into the Layout layer. The reconstruction of layers is 
much easier if you assemble objects on a layer into a group 
before copying.
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Changing the layer of a drawing object
Draw has no direct command to change layers. To move an object to 
another layer, change to the new layer, select the desired object or 
group, and then cut and paste it into position. Watch the status bar 
(the selected object’s layer name is shown in the information feld) to 
follow and check the change.

You can also click on the object, hold the mouse button pressed for 
about two seconds until the mouse cursor changes from a hand to a 
pointer with an open rectangle, and then drag and drop it on the 
appropriate layer.

Creating a multi-page document
Draw documents, like presentation (Impress) documents, can consist 
of multiple pages. As in Impress, tools to manage pages and 
backgrounds are available.

Pages are automatically named as Slide 1, Slide 2, and so on. This 
description is relative; if you move pages around, they are 
automatically renumbered. If you want to have fxed slide (page) 
names, you must name them yourself. Page names are useful for 
working with the Navigator and when you want to insert single slides 
using Insert > File into another document.

Using the Pages area
By default the Pages area is docked on 
the left of the Draw window. It shows 
every page in the document as a small 
picture. Select a picture from the Pages 
area and the corresponding page is 
loaded in the main workspace. Click on 
the page to activate it for editing.

The Pages area behaves similar to the 
Styles and Formatting area. Drag on the 
gray separator line to change the width 
of the Pages pane. Click on the middle of 
this line to show or hide the pane. 
Double-click with the Control key pressed 
in the upper gray area to dock or undock 
the area, which can be turned into a 
foating window.
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In the Pages area you can drag and drop 
a picture to change the order of pages in 
the document; a black horizontal line 
shows the position where the page will be 
inserted.

Using the context menu you can insert or 
delete pages or duplicate pages with copy 
and paste (alternatively create duplicate 
pages using Insert > Duplicate Slide 
on the menu).

Using page backgrounds
With background pages you set common page settings for multiple 
pages of the Draw document. These include setting the color or 
graphics of the background, background objects, and felds such as 
page numbering and author.

Note

The terms used in this area may not be completely consistent, 
so that the terms Slide/Page and Master/Background/Page 
Template are used more or less interchangeably in places. 
When looking for information in Help, it may be necessary to 
use alternative search terms.

Creating a page background
Change with View > Master to the Master view and note that a 
related Master View toolbar opens. If this toolbar does not appear, 
activate it with View > Toolbars. In this toolbar are switches for a 
new background page and for renaming the master page. These 
functions are also available by right-clicking on a page picture in the 
Pages area of the Master view. The button for deleting a master page is 
only available when you select a background page in the Pages area 
which has not yet been assigned to any page.
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Figure 187: Master View toolbar

To return to normal mode, click the Close Master View button or 
View > Normal.

You can edit background pages just like normal pages. With Format > 
Page > Background you can set the color, pattern, or background 
picture. These settings are specifc to each background page. In the 
Master view, you can set the size and orientation of the page; such 
settings apply to all pages.

If you insert drawing objects on a background page, they are visible on 
all pages that use this background. This a convenient way, for example, 
to place a logo on every page.

Master pages are organized in layers just like normal pages. The layers 
of normal pages are associated with the layer of the same name on the 
Master page. Accordingly the layers Layout/Control/Dimension Lines 
are considered to be a unit and the Master page layer Background 
objects is associated with them.

With Insert > Fields you can insert the date, time, page number, 
author and flename. No other felds are available. With page number 
you cannot insert a fxed page number but only a variable; the actual 
number appears on the page itself and is determined by the position of 
the page. The number is automatically adjusted if the page is 
subsequently moved.

Assigning and managing page backgrounds
You can open the Slide Design dialog (Figure 188) in two ways:

• Right-click on the page and choose Page > Slide design, or
• Look in the bottom right of the status bar to see which 

background page is the current one. Double-click in this feld.

The Slide Design dialog (Figure 188) shows the available background 
pages for that page.
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Figure 188: Slide design dialog

If the Exchange background page option is selected, the selected 
background page will be used on all pages of the document, not just on 
the currently active page.

The Delete unused backgrounds option deletes any backgrounds (as 
shown in the Slide Design dialog) that have not been assigned to a 
page.

Click the Load button to open the Load Slide Design dialog. From here 
you can load previously prepared background pages. All Draw and 
Impress templates can be used for this purpose. Note, however, that 
using Impress templates will bring in only the background and not the 
other elements prepared in Impress.

Figure 189: Load Slide Design dialog

There is no special option to store background pages as templates. 
Instead you can load a document with the desired background page 
and store this document as a document template with File > 
Template > Store.
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Color palette: adding or changing single 
colors

Draw (like all OpenOfce.org components) uses color palettes for the 
representation of colors. In addition you can customize the color 
palette to suit your own needs and wishes. You can modify colors in a 
palette, add other colors, or create new color palettes.

Reach these options with Tools > Options > OpenOfce.org > 
Colors or with Format > Area > Colors (tab) (see Figure 190). The 
latter method allows color palettes to be loaded or to be stored for 
future use. Any modifcations made to colors apply only to the 
currently active palette.

OpenOfce.org always uses the RGB color model internally. Other 
methods are also available for the defnition of a color value.

The color values can be input directly as numbers. Choose between the 
RGB color model (base colors Red, Green and Blue) and CMYK (base 
colors Cyan, Magenta, Yellow and Black, K= Key). The conversion to 
RGB values is made automatically.

Tip
Information about color models can be found under:

http://en.wikipedia.org/wiki/Color_model 

Individual color tones are produced by using diferent values of the 
base colors. The color value can be any integer value between 0 and 
255. As an example, Red 3 has  a red value of 184, a green value of 71 
and a blue value of 0 in the RGB model. The CMYK color model uses 
percentages (in this case 0%, 44%, 72%, and 28% respectively).

Change these values to manipulate the color tone. Either enter a 
number directly or use the spinners on the right side of each feld. The 
change in color will be shown in the lower color feld (see Figure 190). 
Click the Modify button to apply and store the new setting.

To add a new color to the current palette, enter a new name in the 
Name feld and set the desired color values. Click Add. The new color 
will be added to the end of the palette and stored in the currently 
active palette.

You can also delete colors from a palette. Select the color from the 
Color pulldown menu and click on the Delete button, then on OK to 
confrm the change.
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Figure 190: The Colors tab in the Area dialog

Click on the Edit button to open a dialog where you can set individual 
colors (see Figure 191). Many more input possibilities are available in 
this dialog.

In the lower area you can enter values in the RGB and CMYK models 
as well as the HSB (Hue, Saturation and Brightness) model.

The two color samples at the lower right show the current color (left) 
and the new color specifed by the color value felds (right).

Figure 191: Color dialog

The color windows in the upper area permit a direct selection of color 
without any knowledge of color values. The right upper color window is 
linked directly with the various color model input felds; if you click on 
a color in this window the numbers change accordingly and a preview 
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of the color appears in the right of the two color felds (lower right in 
Figure 190; see also Method 2 below).

If you click OK, the color window is closed and the input feld is again 
active. You can at this stage select the color you have just defned, 
give it a new name, and store it by clicking the Add button. The old 
color will then (without any further warning) be overwritten.

Changing colors using the Color dialog

Method 1
You can change the current color by modifying the individual color 
values explicitly. It is possible to change from one color model to 
another during this process but the settings are always calculated and 
stored according to the RGB model. This may result in some slight 
adjustment to your input values in the other models.

The color wheel to the left illustrates the HSB color 
model. This model defnes the color tone in terms of 
three parameters: Hue (possible values from 0 to 
359), Saturation (possible values from 0 to 100) and 
Brightness (possible values from 0 to 100) is 
defned. The number for the hue represents the 
angle in the color wheel, the other two are both 
percentage values.

Method 2
You can select a new color by clicking on a point in the color window at 
the upper right of the dialog. The chosen color is shown in a black 
frame which can be dragged with the mouse. If this color is not quite 
right, you can fne tune it as described above in Method 1 by changing 
the color values.

As you drag the small square you will see the 
value change in the number felds. The CMYK 
and RGB are more or less self explanatory. To 
make the HSB model a little clearer, some 
additional comments are necessary.

To better understand the working of the HSB 
model, move the frame from left to right and top 
to bottom. You will see that the Hue and 
Saturation values swing between their maximum 

and minimum (hue by horizontal movement and saturation by vertical 
movement), but the brightness remains the same (see fgure at left). 
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This latter can only be adjusted by entering a value into the number 
feld.

Method 3
The left color window is divided like a chess board into 8 x 8 individual 
felds, each with a diferent color. Most important are the colors in 
each of the corner felds. The color red changes stepwise to green in 
the frst row, and stepwise to yellow in the frst column. The color 
green in the last column changes stepwise to blue.

This window thus contains a stepwise change between each of the four 
main colors in the corner points. If you hover the mouse over a square 
the RGB value is shown as a tooltip. For example, the yellow corner 
feld (lower left) has RGB values of 255, 255 and 0 (full red, full green 
and no blue).

Click on this yellow feld. A frame appears. If you click the -> arrow 
under the color windows the selected color is assigned.

You can change the color spread in this window to a more specifc 
range by changing one or more of the corner felds. Click on the corner 
you want to change, then select the preferred color from the right 
color window with the mouse and/or set it using the number felds. 
Now click on the <- arrow; the new color will be assigned to the corner 
square you selected  and the overall appearance of the window 
changes accordingly.

Figure 192: Changing the color of a corner square
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Creating cool efects

Duplication
Duplication makes copies of an object while applying a set of changes 
(such as color or rotation) to the duplicates.

Figure 193: Duplication example

To start duplication, click on an object or group and choose Edit > 
Duplicate. The Duplicate dialog (Figure 194) appears.

Figure 194: Duplicate dialog

Choose the number of copies, their separation (placement), rotation, 
and so on. The choices above applied to a blue rectangle produce the 
result shown in Figure 193.
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Cross-fading
Cross-fading transforms one shape into another. The result is a new 
group of objects including the two end points and the intermediate 
steps.

Figure 195: Cross-fading example

To do a cross-fade, frst select two objects.

Figure 196: The two objects 
selected for cross fading

Then choose Edit > Cross-fading.

Figure 197: Cross-fading dialog

On the dialog choose the number of increments (transition steps). You 
probably want to have Cross-fade attributes and Same orientation both 
checked. The end result is shown in Figure 195.

Which object goes in front?

How do I tell Draw that I want  and not ?

Select  (the object we want in front), right-click and choose Arrange 
> Bring to Front (or press Ctrl+Shift+plus). Or select  (the object 
we want behind), right-click and choose Arrange > Send to Back or 
press Ctrl+Shift+minus.
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Drawing an organization chart
Even though Draw does not have an organization chart toolbar, you 
can draw these charts by drawing rectangles and connector lines  (see 
Figure 198). You can indicate hierarchies by using a color progression 
from dark to light tones. Be sure your color choices maintain a good 
contrast between text color and background so that you can easily read 
the printed diagram.

Figure 198: Example of an Organization Chart

Before you begin, prepare a setup page or draft, with snap lines, to 
assist in drawing the various hierarchies, responsibility paths, and 
typical boxes that you will use in drawing the chart.

Figure 199: Draft with snap lines

Place and dimension the individual boxes according to the size of the 
overall chart. The exact size (particularly width), position, and color 
will be fxed later. It is sometimes easier to draw only one box per 
level; later you can copy and paste this box and then move the copies 
to the desired positions. Using styles can also be helpful; see the 
relevant section in Chapter 4 (Changing Object Attributes).
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You can also select one or more boxes and use Edit > Duplicate to 
make copies (see Figure 200). The spacing of the duplicated objects 
relative to the original can be controlled using the placement felds for 
the X and Y axes. Note that positive values for X and Y are to the right 
and downwards from the original object.

Figure 200: Duplicating an object

Which replication technique you use is up to you. The draft for the 
example in this chapter should look similar to that in Figure 201.

Figure 201: The fnished draft

The next step is to add text to the boxes. It is easiest to insert it as a 
text element within the box as described in Chapter 2 (Drawing Basic 

Shapes). Activate the  icon on the Options toolbar and then double-
click the box to enter text into it. Alternatively, select the box and press 
F2. You should then see a blinking cursor in the box and the Text 
Formatting toolbar should be visible.
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Set the text formatting and type the text. Depending on the length and 
format of the text, you may need to adjust the size of the box and the 
spacing to neighboring boxes or else change the formatting of the text 
to ft the box. Adjustments can be made initially with the mouse and 
then fne-tuned with the Position and Size dialog.

Now set up the fll colors and save the drawing. The connections 
between the boxes are not drawn with ordinary lines but with Draw’s 
connectors. How to draw these connectors and add text to them is 
described in “Glue points and connectors” starting on page 176.

You can use dynamic text frames instead of boxes. These have the 
advantage of automatic line breaks. Figure 202 shows the sequence of 
text input into a frame, adding borders, and setting the background 
color.

Figure 202: Working with text frames
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Drawing a fow diagram
For drawing fow diagrams (also known as fowcharts), Draw ofers a 

separate toolbar; click the fowchart icon  on the main Drawing 
toolbar.

Figure 203: The Flowchart toolbar

The easiest way to draw a fowchart is to follow the same setup 
procedure as for organization charts. Select the symbols from the 
toolbar and drag them into position as described in Chapter 2 
(Drawing Basic Shapes). See Figure 204 for an example of a typical 
fowchart.

The individual symbols must be exactly positioned if the connectors 
joining them are to form a vertical line. The midpoints of all the 
symbols that lie in a vertical straight line should have the same X 
coordinate and those on the same level on a horizontal line should have 
the same Y coordinate.

Select the shapes that are to lie in a vertical straight line and center 
them with Modify > Alignment > Centered. For those on a 
horizontal line, select the shapes and center them with Modify > 
Alignment > Center. You can also set snap lines if you need several 
vertical lines.

After adding text and setting the fll color, you can join individual 
symbols together and add text to the connectors. This technique is 
described in the next section.
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Figure 204: Example of a fow diagram

Glue points and connectors
These elements were briefy introduced in Chapter 2 (Drawing Basic 
Shapes). This section describes how to use them.

Connectors are lines or arrows whose ends automatically dock to a 
connection or glue point on an object. Connectors are particularly 
useful when drawing organization charts, fow diagrams, and 
mindmaps. The connecting lines between the symbols remain intact 
even when the latter are moved or rearranged.
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The Connector toolbar

Click the  button on the Draw toolbar to open the Connectors 
toolbar (Figure 205).

If the type of connector you want is not shown, click on the  in the 
Connectors toolbar. In the list that appears, click on Visible buttons 
(Figure 206) to open a menu from which you can activate additional 
types of connector.

Figure 205: The Connectors toolbar

Figure 206: Activating additional connectors
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Connector types fall into four groups:
• Standard connectors – the line segments run vertically and 
horizontally. All angles are right angles. The connector does not bend 
around the objects it binds.

• Line connectors – consist of a line segment and two smaller 
horizontal or vertical segments at the ends.

• Straight connectors – consist of a single line.

• Curved connectors – are based on Bézier curves, as described in 
Chapter 10 (Advanced Draw Techniques).

You can modify all the connector types from the context menu. Select 
Connector to change from one connector type to another (as well as 
some other properties). With the Line dialog you can change the 
appearance of the line (color, arrow style, and line style) but not the 
connector type.

Drawing connectors—basics
When you choose a connector from the toolbar, the mouse pointer 
changes to  . As you move the cursor over an object, the available 
connection points (also referred to as glue points) become visible. To 
connect two shapes, move the mouse cursor over a glue point, click 
and hold down the left mouse button to establish the frst point, and 
then drag the mouse cursor (left button still pressed) to the other glue 
point and release the mouse button. The ends of the line are now 
docked and the connection is established (see Figure 207).

Figure 207: Gluing a 
connector to a shape

You can also attach the beginning or the end of a connector to the 
middle of an object. This is useful when the fnal position of the object 
is not yet determined. When you move the object, Draw automatically 
selects the optimal location for the connector ends (see Figure 208).
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Figure 208: Connector attached to the middle of an object

As with all other objects, connectors have one or more control points to 
simplify the construction of the drawing. You can use these points to 
change the shape, length, and proportions of the connector line (see 
Figure 209).

Figure 209: Control points 
of a connector

To remove a connector from an object, either move the end of the 
connector away from the glue point of the object or simply delete the 
connector entirely.

Editing glue points
Glue points can be edited using a separate toolbar (see Figure 210). 
This toolbar appears when you click on the Glue Points icon  or 
select Edit > Glue Points from the main menu.

Figure 210: The Glue points toolbar

The following briefy describes the function of each button on this 
toolbar.
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Use this button to insert a new glue point. Draw a new object. 
If the object is flled, you can place a glue point anywhere 
inside the object or on its frame. With unflled objects you can 
place a glue point only on the outside frame but, after inserting 
it, you can then drag it inside the object. Activate the Glue 
Points icon on the Drawing toolbar.

The glue points that you add remain visible as 
long as the Glue Points icon is active. They 
appear as small blue crosses. A selected glue 
point has a gray square behind the cross. You 
can move a selected glue point with the mouse 
or delete it with the Del key.

Use these four buttons to choose one or more directions 
permitted for a connector to join to a particular glue point.

Activate Glue Points and then choose the direction. If, for 
example, you activate only the  button, every connector will 
be forced to come to that glue point from the left side.

In the left-hand drawing below is a glue point in the circle with 
a left entry and one in the square with a right entry. The efect 
of this when adding a connector between the two glue points is 
shown in the right-hand drawing..

If you are in glue point editing mode and you add another 
direction to a glue point (for example by activating the  
button), Draw tries to optimize the length of the connector. For 
the example above, the connection inside the circle would 
change as shown below.
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If the Glue Point Relative button is active (as it is by default) 
the glue point will move when you change the size of the 
object, as shown below.

If the Glue Point Relative button is deactivated, the remaining 
buttons on the toolbar, previously grayed out, become active. 
With these buttons you can decide how a glue point will be 
placed when the size of the object is changed.

These buttons determine how the horizontal position of a glue 
point changes when you resize the object containing the glue 
point. You can choose whether the distance of the glue point to 
the left edge of the object, to a vertical line through the middle, 
or to the right edge of the object remains fxed when you 
change the size of the object. If the width of the object 
becomes less than that distance, the glue point is attached to 
the object frame.

The following example shows what happens when an object’s 
width is changed and the glue point is set to be a fxed distance 
to the left frame.

These buttons determine in a similar manner the vertical 
position of a glue point when the size of the object is changed.

Adding text to connectors
To add text to a connector, double-click the connector. The end and 
control points become active and the familiar fashing text cursor 
appears (the cursor position is determined by the last used setting). 
The Text Formatting toolbar also appears (under the menu bar). Use 
this toolbar to set the text properties; you can directly input the text.
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If you draw a connector and then click on it, only the end points and 
control points become active. In spite of this, a connector has its own 
object frame—in this case an invisible one. You can picture it easily by 
imagining a rectangle enclosing the start and end points of the 
connector (Figure 211).

When you add text to a connector, the location of the text is referenced 
to this rectangle. The exact position of the text can be set in the Text 
dialog (Figure 212). This dialog appears when you double-click on text 
and then choose Text from the pop-up menu or when you single-click 
on the connector and select Format > Text from the menu bar.

Figure 211: Object frame of a connector

Figure 212: The Text dialog
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Take particular note of the Spacing to borders and Text anchor 
sections in the Text dialog. In the Text anchor section you can see the 
possible locations for the text. In the above example the text is 
anchored at the top left. In the Spacing to borders section at the lower 
left, negative values of spacing will position the text outside the frame.

Adjusting text to suit the connecting line
If you want the text to follow the slope or curve of a line, you need to 
activate and use the Fontwork tool.

1) To add it to the Draw toolbar, choose Tools > Customize from 
the menu bar. 

2) On the Toolbars tab, in the Toolbars pull-down list select Drawing. 
In the Toolbar content section, click Add. 

3) On the Add Commands dialog, select Format from the left-hand 
list and the command Fontwork. Click Add, then Close to return 
to the Customize dialog. 

4) In the list of commands under Toolbar Content, move the 
Fontwork icon  to the location you want by using the up/down 
arrows, and then click OK.

To write slanting text, follow these steps:

1) Add the text to the connector as described earlier. The anchor 
location of the text is not important at this stage.

2) Select the object with the text (in this case the connector) and 

click on the Fontwork icon  to open the Fontwork dialog.
3) To make the text lie along the inclined line, click the Rotate icon 

and set the distance to the line you wish.

Figure 213: Adding text to an inclined line, Step 1
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Figure 214: Adding text to an inclined line, Step 2

The Fontwork dialog opens up many other possibilities to manipulate 
the text. You can, for example, turn the text around 180 degrees with 
the Orientation  icon (which was done in the example above) or 
place the text under the line by assigning a negative value to the 
spacing between text and line.

In addition, you can use the Fontwork dialog to generate curved text 
that follows the shape of a curved line. Experiment a little to 
investigate some of the possibilities.
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Drawing to scale
Draw is not a CAD (computer-aided design) program but a graphics 
program with which you can produce drawings to a scale. The example 
used for this chapter is a drawing of a Logic Circuit Diagram. The 
exact meaning of the individual symbols is not described here as we 
are only interested in the drawing techniques used to produce the 
diagram.

The logic symbols in Figure 215 form the building block library for our 
scale drawing.

Figure 215: Logic Symbol library

Working with the Position and Size dialog
So that the edges of the building block symbols do not coincide with 
the wiring, they should be 8 mm wide and 8 mm high. The connections 
to the symbols should have a length and separation of at least 5 mm. 
These values are all random values and you would normally substitute 
values that suit your own needs.

For the drawing we used a measurement unit of millimeters, a grid 
spacing of 5 mm, and a grid subdivision of 4 points. In addition you 
should probably activate Display grid and Guides when moving as well 
as Snap to grid (see Chapter 8). This drawing will serve later as a 
collection of available symbols and you should not only draw the 
symbols but fully detail them as well.

The frst step is to draw a base element, an AND gate block. You can 
then dimension and detail this element (use the Position and Size 
dialog, as shown in Figure 216; double-click on the status bar or 
context menu to help with dimensioning). For this example, the left 
upper corner of the block is at x=10 mm and y=5 mm.
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Figure 216: Positioning and dimensioning a Draw 
object

Draw the frst connection lead by eye and dimension and position it 
using the Position and Size dialog.

Figure 217: Setting the position and dimension of the upper 
input

Use the same method to draw the remaining two leads. For positioning 
the input leads, fx the right end points; for the output lead, fx the left 
one. The frst wire lies 1.5 mm below the upper edge of the block. The 
leads have a 5 mm spacing between them. The following table shows 
the relevant coordinates of the upper corner points and the leads.

left (X/Y) [mm] right (X/Y) [mm] Input 1 (X/Y) [mm] Output (X/Y) [mm]

10 / 5 18 / 5 10 / 6.5  (right EP.) 18 / 6.5  (left EP.)

For the lower input lead, increase the Y coordinate of Input 1 by 5 mm 
to 11.5.
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The AND gate block is almost fnished. We can use it as the basis for all 
the other gates. So that the drawing gives a good visual impression, 
use Edit > Duplicate to ensure uniformity of shape and size.

Because we want to copy the block vertically downwards, use a 
Placement on the X Axis of 0 mm and on the Y Axis 15 mm.

Figure 218: Duplicating an object

With the same method, copy both blocks twice more to the right. 
Select both blocks, call up the Duplicate dialog, and use placement 
values of 30 mm (X) and 0 mm (Y). Your drawing should look similar to 
Figure 219.

Figure 219: The blocks after duplication

For the INVERTER or NOT gate the connection leads must be 
amended. Move one input and one output lead to the middle of the 
block and delete the superfuous input lead.

Draw the missing circle for negation with a diameter of 2 mm, place it 
by eye in the center and then position it and dimension the connections 
from the Position and Size dialog as described above.

You can copy the circle to the Clipboard and then paste it as many 
times as you need, positioning it and adjusting the lead lengths as 
above.

A wiring diagram also needs a symbol to show a connection point. 
Draw a flled circle for this.
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Next add text to the symbols (&, =1 etc.). Activate the icon  on the 
Options Toolbar. Double-clicking a symbol will now put you in a special 
text input mode. This integrates the text as an element in the object 
(see also Chapter 2 of this guide). You will fnd the OR symbol (≤) in 
the list of special characters (Insert > Special Characters).

It is probably a good idea to create a group for each type of gate. This 
will make it easier to use them in a diagram. Your diagram should now 
resemble Figure 215; save it to disk.

If you want you can add a name to each of the gate symbols (AND, 
OR ..), use a separate layer to add this text so that you can switch it of 
when necessary.

You can place glue points at the end of each connection lead. This will 
simplify the actual “wiring up” later when you add in the connectors.

Setting glue points
This instruction assumes a basic knowledge of connectors and glue 
points. For additional information refer to Chapters 2, 8, and 9 of this 
guide.

Note
If objects are included in a group it is not possible to add glue 
points to them. Glue points must be set before any grouping is 
done.

The glue points on the connection leads must be placed exactly at the 
ends of the lines (otherwise the wires will not be properly 
aligned).Unfortunately you cannot set the position of glue points using 
numerical values. It is necessary to do it by hand.

The best solution is to use the Zoom toolbar to enlarge the diagrams. 
You can fnd this as a tearof toolbar on the standard Drawing toolbar. 
It contains (among others) tools for zooming in and for zooming out 
(enlarging the view/making the view smaller) of the current view. If 
you click on the Zoom In tool and then click on the page, the scale is 
doubled and the view is centered on the place where you clicked.

As the ends of the connection leads in this example do not lie on grid 
points, you must switch of Snap to Grid and activate Snap to Object 
Points.

When you have done this, you can open the Glue Points toolbar with 
the Insert Glue Point icon  on the Drawing toolbar or using View > 
Toolbars from the menu bar.
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Figure 220: The Glue Points toolbar

Select the block on which you want to insert a glue point. Click the 

Insert Glue Point icon . It is now activated and appears with a 
diferent background. The mouse cursor changes to a small cross and 
you can set the frst glue point. Click the mouse at the desired location. 
If the point is not exactly where you want it, move it by dragging with 
the mouse.

When you are satisfed with the location, click on the Glue Points 
toolbar the icon with the exit direction you want (left, right, top or 
bottom). The selected icon now has a diferent (lighter or darker) 
background. Set the exit direction of the input connection leads to the 
left and the output leads to the right.

When you have set a glue point at the end of each gate’s connection 
lead, you can copy it into the Gallery.

Copying individual pictures to the Gallery
The Gallery is a very convenient way of controlling building blocks for 
drawings. It also functions as a symbol library.

First open the Gallery using Tools > Gallery or by clicking on the  
icon if it is present in one of the toolbars.

The Gallery appears above the drawing page. The left pane shows the 
folders available for use and the right pane shows the images 
contained in the current folder. Choose an image by clicking on it; 
additional information about the image appears in the header bar.

In the left pane, click the New Theme button to create a new folder. A 
new window opens. Click on the General tab and give the new theme a 
meaningful name (for example Logic) to replace the default of New 
Theme. You can rename a theme by right-clicking it in the folders pane 
on the left.

To import existing images into the Gallery, click on the Files tab and 
then on the Find Files... button. It is possible to bring in complete 
folders or individual fles; the procedure is self-evident from the dialog 
windows that open, or see Chapter 14 (Working with the Gallery) in the 
Getting Started guide.

You can drag and drop Draw objects straight into the Gallery. (The 
Properties window can be closed after typing in the name.) First select 
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the destination folder, then click on the frst symbol that you wish to 
add to the Gallery. Position the mouse cursor inside the selection frame 
of the symbol. When the crossed arrows are visible, click on the symbol 
and keep the mouse button pressed. After about 1 or 2 seconds the 
cursor will briefy blink and change to the drag symbol. Drag the object 
into the Gallery and release the mouse button. When you move the 
mouse into the Gallery feld, the cursor shape changes once more (see 
Figure 221).

Figure 221: Crossed arrows > Drag symbol > 
Gallery symbol

Tip
Zoom in on very small graphics before you try to move them so 
that the crossed arrow symbol can be clearly seen.

When you have placed all the symbols in the Gallery they can be titled. 
Right-click on a symbol, choose Title from the menu and type the 
symbol name (AND, OR).

The symbol library is available to all OOo modules, at least for users 
who have the permission/rights to access it. Making available the 
drawing collection as a Draw fle is the simplest way to distribute a 
symbol library to other users. After opening the drawing, other users 
can easily transfer the drawing objects into their own Gallery, as 
described above.

Drawing a logic circuit diagram using the Gallery
The use of the symbol library which you have created and placed in the 
Gallery can be illustrated by using the blocks to draw a half adder (see 
http://en.wikipedia.org/wiki/Half_adder#Half_adder). You can precisely 
place all the drawing objects with the help of Draw’s snap functions. 
The following instructions are only one way to achieve this objective.
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Figure 222: Half adder drawn using logic symbol building blocks

Begin with a new drawing. Set the unit of measurement to centimeter, 
a grid point spacing of 0.5 cm and subdivision of 4 points. Activate the 
grid, guiding lines, and associated snap functions.

In the frst part of the exercise you should draw only the two signal 
leads a and b, the two INVERTER gates and the two AND gates.

Begin by drawing the two signal leads. To make it a bit easier, you can 
use the values in the following table.

Start point Length

Signal wire a X = 2 cm / Y = 3.0 cm 5.5 cm

Signal wire b X = 3 cm / Y = 3.0 cm 5.5 cm

After drawing the two signal leads, you begin the hardest part. With 
grouped objects the snap function works only on points on the outside 
contours. The only way to work with these blocks as a unit, however, is 
as a grouped object. The input and output leads must lie right on grid 
points if the connecting lines are to be exactly horizontal or vertical.

Position two horizontal guiding lines (A, B) on the grid with Y=4.0 cm 
and Y=6.0 cm. With Snap to Grid active, this should be no problem. 
With an INVERTER gate the input and output leads lie in the middle of 
the block, 4 mm below the upper edge. In order that the input and 
output are docked to the guiding line, the upper edges of the 
INVERTER gate must be positioned (for a 5 mm grid spacing) at Y=4.1 
cm and Y=6.1 cm. Right-click on the guiding line, select Edit guiding 
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line from the context menu and set the guiding lines to 4.1 cm and 6.1 
cm.

In order that the blocks lie exactly underneath each other, insert 
vertical guiding lines at X=5.0 cm (INVERTER gate) and X=8.0 cm 
(AND gate).

Now open the Gallery and drag the Inverter gate into approximately 
0.64, the position desired. If the function Snap to guiding line is still 
active, you will be able to accurately position both blocks in the correct 
location. Your diagram should now look like Figure 223 and you can 
save it.

Figure 223: Drawing a half adder – Step 
1

The input and output leads of the INVERTER lie at Y=4.5 cm and 
Y=6.5 cm. Move the mouse over a guiding line. When the mouse cursor 
changes to a double arrow, drag the guiding line (with the left mouse 
button pressed) onto the input and output leads of the block. If the grid 
snap is still active, this should be exactly positioned without much 
efort.

The leads of the AND gate lie 1.5 mm below the upper edges of the two 
horizontal guiding lines. They must be moved up for the next step. The 
Y coordinates are reduced to 4.35 cm and 6.35 cm (the top edges of 
the AND gates). When you have moved the lines, you can drag both 
AND gates from the Gallery and position them. Your drawing should 
now resemble that in Figure 224.

Next drag the horizontal guiding lines again over the input and output 
of the gates (Y=4.5/6.5 cm), so that when you position the connection 
point of the leads (a small black circle) it will sit exactly on top of the 
leads from the gates.
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Figure 224: Drawing a half adder – Step 2

To position the two last gates, you need to set the following additional 
guiding lines: a vertical line with X=11 cm and two horizontal lines 
(C,D) at Y=5.5 cm and Y=7.5 cm respectively. Shift the horizontal lines 
C and D each 1.5mm upwards (so that Y=5.35 cm and Y=7.35 cm).

Drag the OR and the last AND gate from the gallery and position them 
as in Figure 225.

Figure 225: Drawing a half adder – Step 3

Since the OR gate will be connected to the two previously positioned 
AND gates, you can delete the guiding line of the OR gate. Drag 
the0.64 horizontal guiding line C and D over the inputs of the AND 
gates (Y=7.0 and 7.5 cm) and put two other lines (E,F) on the 
remaining connections (Y=5.0 and 8.0 cm) as shown in Figure 226.

Deactivate all snap functions except snap to grid. It is a good idea to 
zoom in so that you can place the lead connections exactly over the 
intersection points. Drag the connections singly from the Gallery to 
where you want to position them. You will need to adjust their position 
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with the mouse. The easiest way is to move the connection diagonally 
to the desired location (see Figure 227).

The guiding lines are no longer needed and can be hidden (it is better 
to wait until you have fnished the drawing before you delete them). 
Your drawing should now start to look like Figure 226 and can be again 
saved.

Figure 226: Drawing a half adder – Step 4

The individual blocks must now be joined up so that the gates function 
as a half adder system. To do this, you use connectors. Open the 

Connector toolbar. Use the standard connector  to join the OR to the 
two AND gates. All the other leads run horizontally and you can use 
the direct connector .

When all six lead connections have been positioned, both signal wires 
should have a small black circle added to their connection points. You 
can use the symbol for NOT from the Gallery as the basis for this.

Figure 227: Setting the connections
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If you have correctly positioned the symbols in the drawing, all the 
connection leads will be straight lines. At this time you can delete all 
the guiding lines, add text to the drawing and your fnished drawing 
should resemble Figure 226 above.

Dimensioning a drawing

Confguring the dimensioning style
As is usual with OOo, you confgure dimensioning using its own style.

After opening a drawing, press F11 to access the Styles and 
Formatting window. In the Graphic Styles list, right-click on the style 
Dimension Line and select Modify. The dialog that opens contains the 
current settings. Click the Dimensioning tab (Figure 228).

You can confgure all the properties you see in this window to suit your 
own needs. The left section includes the basic settings for dimension 
lines and dimension guide lines (these indicate where on the object the 
dimension is referenced):

• Line distance: the distance of the dimension arrow from the 
object edge

• Guide overhang: the distance the guide line extends past the 
arrow

• Guide distance: the distance of the guide line from the object 
edge

You can individually set the line lengths of the right and left guide lines 
and use positive or negative values to have the line above or below the 
reference point. The direction of the line with positive or negative 
distances depends on the setting of the Measure below object option 
(box checked or not), but this is easy to check by referring to the 
example dimension line in the bottom window of the dialog. For this 
current exercise click the box and activate this option.

In the right section you can change the settings for the Legend, the 
text of the dimension line. You can use the Text position choices to 
change the location of the text – but only if one or both of the 
AutoVertical and AutoHorizontal checkboxes are unchecked. Use the 
various options on the Text and Alignment tabs to further change the 
text format.
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Figure 228: Confguring dimension lines

Calculation of dimensions always takes into account the scale and 0.64 
dimension units contained in Tools > Options > Draw > General. If 
you set a scale of 1:10 and a unit of centimeter, then a 6 cm long object 
in the drawing will be shown with a dimension of 60 cm when the 
option Show meas. unit is activated and the selection window is set to 
Automatic. Deselecting this option turns of the display of units. You 
can change the units displayed from Centimeters to (for example) 
Millimeters by choosing Millimeter instead of Automatic in the 
selection window.

Adjust the font type and size for the text of a dimension line by means 
of the Text tab.

The Standard button at the bottom of the dialog sets all the properties 
of the dimension line to the (inherited) standard properties of the style.

Note

The dimensioning style Dimension Line is always linked and 
stored with the current work page. All the changes that you 
make apply only to this page. New drawings are started with 
the standard properties of Draw. If you want to use the 
amended style for future drawings, save the page as an 
additional template.
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Dimensioning objects
In this exercise you will dimension some logic blocks (see Figure 229). 
They are used here to demonstrate the technique; you can use your 
own drawing or fetch a picture from the Gallery.

Figure 229: Dimensioned logic blocks

So that Draw can clearly recognize the edges to be measured, you 
should set a number of guide lines delineating the edges. The previous 
sections explain how to do this. To place the guide lines exactly and 
easily, change the resolution of the Grid. Suitable values for this work 
are a resolution of 5 mm and a subdivision of 4 points. With this setting 
you should have a snap to grid function with 1 mm point separation.

We will begin by dimensioning the NOT gate. For this block we want 
the total width (18 mm) and the width of the block itself (8 mm) to 
have dimension lines. The frst step is to add guide lines to delimit the 
dimension lines. With Snap to grid activated, you can position these 
quite accurately (see Figure 230a). Watch that the function Snap to 
guide lines is active and zoom in to the part of the block to be 
dimensioned. The block should not be selected.
Start the dimensioning command by clicking the Dimension Line icon 

 on the Lines and Arrows dialog. The dimension line is placed 
automatically on the Dimension Lines layer so you can hide the 
dimension lines if you wish.

Figure 230: a) Delimiting the edges with guide lines
b) Dragging the dimension line (anticlockwise)
c) Finished dimension line
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After clicking the Dimension Line icon, the mouse cursor changes into 
a small cross. As we activated the option Dimension Line – Measure 
below Object, the dimensioning should be made in a counterclockwise 
direction. Place the mouse cursor at the left dimensioning point. Press 
the left mouse button and drag the mouse to the right dimensioning 
point. Release the mouse button. If you press the Shift key while 
dragging the mouse, you will restrain the dimensioning line in a 
horizontal (or vertical) direction (see Figure 230b).

In the same way you can draw a vertical dimension line on the AND 
gate. The dimensioning of the NEGATION symbol should also be simple 
to accomplish, but it is important that for such small components you 
zoom in enough to accurately position the lines.

Editing dimension lines
Dimension lines can be subsequently edited. You can select single 
dimension lines which are displayed with four handles, located at the 
end of the dimension lines (Figure 231).

Figure 231: Editing dimension lines

With the upper handles you can (only) change the length of the guide 
lines. With the lower handles you can move the points that are being 
dimensioned. If you select the dimension text, you can edit the font 
type and size as well as changing the dimension units of the text.

If you only want to edit the text of the dimension, double-click on an 
unselected dimension line to enter text edit mode.

All the changes that you make relate only to the selected dimension 
line. They are stored and persistent, but do not afect the settings of 
the Dimension Line style. If you insert other dimension lines, they will 
have the settings contained in the style.

If you want to make general setting changes to the Dimension Lines 
style, change the appropriate style. As soon as you confrm the 
changes with OK, the new settings will be applied to all dimension 
lines.
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Working with text in Draw
You can use text in Draw in various ways:

• as a text element

• as text associated with a picture

• as an element out of the Fontwork gallery

• as a Writer OLE object

Confguring text elements with styles
Text, like all drawing objects, can be associated with styles. The text 
settings in styles always afect the whole text element. You can format 
individual parts of a text element, but only by using manual formatting, 
which does not relate at all to styles and templates. Styles for 
characters and paragraphs do not exist in Draw.

Open the Styles and Formatting dialog by pressing F11. Access the 
formatting dialogs using the toolbar icons, the context menu, or the 
Format menu.

The Indents and Spacing, Text, Text efects, Tabs and Alignment tabs of 
the style dialog function the same as in text documents, although some 
options are not available in Draw. Specifc to drawing objects are the 
tabs Text and Text Animation.

Text animation
On the Text Animation tab, you can set how the text moves within the 
object frame. Such efects are interesting mainly for documents that 
are to be shown on the screen. They are therefore more commonly 
used in the Impress module. For printed text they do not make any real 
sense and are not dealt with further in this guide.

Text
On the Text tab, you can determine the behavior of the text block in 
relation to the border of the drawing object. The same settings can be 
altered—as manual formatting—under the Text... command in the 
Format menu or in the context menu.

The type of drawing object determines which settings are active and 
what efect they have on the text. Shapes behave diferently to other 
drawing objects. To experiment with the settings, use objects with 
rounded edges so that diferences in spacing and alignment show up 
better.
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Figure 232: Text tab of Graphic Styles dialog

Anchoring text
To try out the diferent settings possible for text anchors, start by 

drawing an ellipse from the Basic Shapes toolbar  , change into Text 
edit mode by double-clicking on the ellipse and write several, not too 
long lines of text. Repeat with an ellipse from the Circles and Ovals 
toolbar (a classical drawing object).

In the Text tab of the Edit Style dialog, 
set the values of the Spacing to Borders 
to 0 cm for all four directions.

Set Options as Left in the tab Alignment.
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Now we can try out some of the diferent possibilities of text 
anchoring.

Shapes Classical drawing 
objects

Text anchored to 
left middle – the 
text block is 
placed on the left 
side and centered 
vertically.

“Left edge” here means 
the edge of the text 
frame whose left side 
fts totally within the 
fgure.

“Left edge” here means 
the left side of the object 
frame – the frame with 
the green handles which 
is visible when you click 
on the object.

Text anchor to 
lower right.

The lower right corner 
of the text block sits 
against the edge of the 
fgure. 

The lower right corner of 
the text block lies in the 
lower right corner of the 
(invisible) object frame.

The text anchoring 
always relates to 
the entire block, 
even when single 
lines are set 
diferently to the 
other text through 
manual formatting.

If you checked the option Full width, the text block is always centered 
horizontally. The area of the text block is as great as possible; here it 
extends either to the edge of the fgure or object frame or (when not 
that wide) the width that is necessary to ft the length of the longest 
line. The diference becomes clear if you position the text on the left, 
but you set single lines through hand formatting to be aligned on the 
right.
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In the examples below, the frst line of text was shortened to “First line 
with”, spacings were set to 0 and text anchor to middle left.

Shapes Classical drawing objects

Without option 
“Full width”

With option “Full 
width”

Fitting text in frames
Here you fnd that shapes and classic Draw objects behave completely 
diferently.

For shapes the options on the right are active.

Figure 233: Options active for shapes

These have the following efects.

Word wrap text in shape: No automatic hyphenation is 
available and you cannot insert 
a fxed hyphen.

If the text does not ft in the 
shape it hangs over or under the 
outside of the shape.
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Resize shape to ft text: Watch out! If you turn on this 
option it is not possible to undo 
the size changes – neither using 
the Undo function on the menu 
nor by switching of the option 
in the dialog.

For the classic drawing objects, both lower left options in the dialog 
are active.

These options have the following efects.

Fit to frame: The text is widened and 
compressed so that it flls out to 
the object frames.

Adjust to contour:

 

All the text is contained within 
the fgure. It is split over several 
lines if necessary. Any text 
which does not ft in the fgure 
is not shown, but is still 
retained.

Note that even if you have 
activated hyphenation, words 
will be split without regard to 
the hyphenation rules.

Distance from frame
Spacing settings are added to the text. In this way the text block is 
invisibly reduced or (with negative values) made bigger.

In the examples below, the text (M) is centered horizontally and the 
text block is anchored in the upper middle part of the frame.
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Value for 
spacing “Above”

-2 cm -1 cm 0 cm 1 cm 2 cm 3 cm

The behavior is 
the same for 
classic drawing 
objects and 
shapes.

If you anchor the text above, below, right or left, a positive spacing 
value positions the text in such a way that it sits close to the outside of 
the object frame at the anchoring point. Anchoring in the middle does 
not result in this movement.

It is easier to add text to a straight line if the line is created as a very 
thin rectangle. Choose an anchor point in the middle of the rectangle 
and then determine the exact position of the text by setting the spacing 
accordingly.

Text added to open line types such as Bézier curves (curves and 
freehand lines), Polylines (polygon and polygon 45°), and Arcs is also 
positioned in relation to the enclosing object frame. If you want to see 
the extent of this frame, just click on the object. To add text along one 
of these lines, you can use the Fontwork tool described on page 209.

Text added as described above is rotated when the object is rotated. 
The property settings, particularly those dealing with spacing relative 
to the frame, relate only to situations where the object is not rotated.

Text frames and callouts
To test the range of setting possibilities, use a text frame or a callout 
with rounded corners. For text frames, as for rectangles, you can set 
the rounding in the Position and Size dialog (Slant & Corner radius) or 
in Points mode. The latter makes sense only if you have a visible 
outline. With callouts (as with text frames in Points mode), drag the 
larger marker in the left upper corner with the mouse to give the 
desired amount of rounding. An example of this is shown in Figure
234.
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Figure 234: Legend with rounded corners

Unlike drawing objects, text frames and callouts support automatic 
line breaks and you can switch on automatic hyphenation under Tools 
> Language > Hyphenation.

Non-breaking dashes and protected separators are however not 
available. For a manual line break use, as elsewhere, the key 
combination Shift+Enter.

With the text and callout icons (  and  ) you can create text 
frames and callouts with vertical text. You need to activate Enhanced 
language support > Enabled for Asian languages in Tools > Options 
> Language Settings > Languages. Text frames can be rotated like 
drawing objects, but it is not possible to rotate callouts.

Text frames and callouts do not have a separate text element, but you 
still use the Text dialog to set formatting properties. As soon as you 
have input text, the upper three settings on the left side become active 
(Figure 235). The settings for Spacing to Borders and Text anchors in 
the lower window area function in a similar manner to normal drawing 
objects and are not dealt with further here.

Figure 235: Text options active for text frames and 
callouts

206 OpenOfce.org 3.x Draw Guide



All options of The text is broken at the object frame. 
You do not see text that does not ft 
within the object frame. It is still 
available and if you enlarge the object 
it will be visible.

As with normal drawing objects the 
text positioning relates not to the 
fgure itself but to the object frame. 
Observe that the text frame in the 
example at left extends outside the 
ellipse.

Fit width to text
The width of the text frame or callout 
is enlarged so that the longest line 
fts, without a line break, inside the 
object frame.

A previously inserted manual line 
break (here after the word “longer”) 
remains in efect.

Fit height to text
The height of the text frame or callout 
is enlarged so that all lines ft within 
the height of the object frame.

Fit to frame
The text is widened or compressed so 
it fts within the entire object frame. 
This efect is the same as with normal 
drawing objects.

With the symbols  and  you can 
produce a text frame that has this 
property already set.
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Pictures and text
Pictures also possess a text element. You can use this text element to 
place lettering over the picture or to give the picture a caption. To 
format this text, proceed in the same way as for a normal rectangle. 
Usually you produce text as a separate object and then group it with 
the picture, because this gives you more fexibility.

Here are two examples showing what is technically possible with text 
elements.

tab: Font, Comic Sans MS, Bold, 40pt

tab: Font Efect, color white, with 
shadows 

tab: Alignment, Options Right

tab: Text, Text anchor “upper right” 
and 
Spacing to borders right 0.5 cm, top 
0.5 cm, others 0.0 cm

tab: Font, Bitstream Vera Serif, 14pt

tab: Alignment, Options Left

tab: Text, Text anchor “lower left” and 
Spacing to borders bottom -1.3 cm

Note: the line break after the word 
“sea,” was inserted manually.

The construction of each example was carried out using a graphics 
style. Right-click on the picture and choose Edit Style to open the 
Graphics Styles dialog (Figure 232). You may frst wish to choose a 
diferent style to edit for the picture, or create a new style for a special 
purpose. For more about styles, see Chapter 4 (Changing Object 
Attributes).

If you store the picture using File > Export, the text is exported along 
with the graphic. If you use the context menu option Save as graphic, 
then the text is not exported.
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Fontwork Gallery

Click the icon  to open the Fontwork Gallery (Figure 236) which you 
can use to insert an eye-catching caption to an image. Fontwork 
drawing objects belong to the shape category. The Gallery contains a 
selection of popular text forms.

Figure 236: The Fontwork Gallery

You are not limited to these samples; you can subsequently edit and 
customize the chosen caption type. Proceed as follows.

Choose a caption type from the Gallery 
and click OK. The caption is then 
inserted into the middle of your 
document.

Use the green handles to drag and resize 
the caption.
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Double-click to enter text editing mode 
and replace the placeholder text 
“Fontwork” with your own text.

Click outside the object or press the Esc 
key to leave editing mode.

With the Area dialog from the Format 
menu or the context menu, you can set 
fll and shadow properties. Use the Line 
dialog to set a frame around the lettering.

For further adjustments use the 
Fontwork toolbar. If this does not open 
automatically turn it on with View > 
Toolbars > Fontwork.

The left symbol is already familiar. It 
opens the Fontwork Gallery.

Use the small triangle on the symbol  
to open the tearof Fontwork Shape 
toolbar and choose the shape of the 
frame of your caption.

Use the yellow handle to modify the form 
of the caption.

With the other icons you can further 
customize the text direction and 
spacings.
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To change the font type of the caption, 
use (as for other text) the dialog from the 
Format > Character menu or the 
context menu.

If you want to give the text a 3D appearance, refer to the relevant 
section in Chapter 7 (Working with 3D Objects).

Writer OLE object
In some cases, text frames are not fexible enough to meet your needs 
and ofer too few possibilities for adjustment. For example, you may 
want to show a fgure in Draw in exactly the form it was created in 
Writer. The best solution might be to insert an OLE object. This means 
that the object is linked or connected to the application that created it. 
Draw makes available to other applications (only) one viewing window. 
The object itself is not edited in Draw but in the other application.

Insert
Use Insert > Object > OLE Object to open the dialog as shown in 
Figure 237. Use the Create new option to embed the OLE object in 
the Draw document. With the Create from fle option, you can choose 
whether the object should be embedded or linked. With a linked fle 
any change in the stored fle will be shown in Draw and vice versa: any 
change you make in Draw will be stored in the fle on disk.

If you have decided to embed the object you can still create an 
independent text document from the OLE object. For this use the Save 
Copy as command from the context menu.

Figure 237: Inserting an OLE Object
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Editing mode
As soon as you click on OK, the object is created and opens in editing 
mode. You can recognize this mode by the gray frame around the 
object and the small black handles.

Take special note of the toolbars. These are no longer those of the 
Draw module but of the Writer module. You input your text and format 
it almost the same as if you were in Writer itself. In particular you now 
have available all the format styles from Writer.

Figure 238: Writer OLE 
object in editing mode

With the handles of the gray frame you can determine which section of 
the entire text document is visible. You should switch of the ruler view.

Figure 239: Editing in Writer as an OLE object

Click outside the object to leave editing mode. Double-click on the 
object or use Edit > Object > Edit to change again into editing mode.

In an embedded Writer OLE object, you can connect to further “sub” 
OLE objects. You cannot edit a linked Writer “sub” OLE object directly 
in Draw; you must open it as a text document in Writer. This limitation 
can be illustrated by the use of formulas. Such formulas are technically 
OLE objects that belong to the Math module. To use mathematical 
formulas inside fowing text, save the text in a separate text document 
and insert it as a linked OLE object in Draw.
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Object mode
Click on an object to enter object mode, recognizable by the presence 
of the green handles. In object mode you remain in the Draw module.

Possibly you noticed that in edit mode there is no Zoom. Set the size of 
the OLE object on the Draw page in Object mode from the Position and 
Size dialog. In the left image of Figure 240 the object was inserted at 
the original size, at right the size was reduced. If you change the size, 
take care that the option Keep ratio is checked or else the object will 
become distorted. Line and Area properties are not available for OLE 
objects, nor is it possible to rotate objects as with text frames.

Figure 240: Zoom vs resizing of an OLE Writer object

OLE objects can be overlaid just like other drawing objects. In Figure
241 a drawing object from the basic shapes menu has been placed 
behind the OLE object.

Figure 241: Draw object behind 
an OLE object

The page with the text document has the background property set to 
transparent. If you change the background color of the OLE object in 
Edit mode, it will also show in the Draw document.

The Format menu has the entries Area and Line grayed out because 
they are not usable, but the menu entries Paragraph, Character, Text, 
and Bullets and Numbering are all available. These relate not to the 
text object which you are currently editing but rather to a text element 
within the object, which you can open by pressing F2. (This is similar 
to the way that pictures are linked with an OLE object.) The double-
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click, which opens the text element in images, does not work here 
because it puts you into the OLE object’s edit mode. Whether it makes 
sense to use a text element within text like this is questionable!

Guide to Bézier curves

Bézier curves—what are they?
OpenOfce.org uses cubic Bézier curves. A curve 
is defned by means of a start point P0, an end 
point P3, and two control points P1 und P2 (see the 
fgure at left). For points on the curve the terms 
nodes or anchors are often used.

For the mathematical background of Bézier curves, 
see  http://en.wikipedia.org/wiki/Bezier_curve.

Bézier curves are very useful for experimenting with the shape and 
form of curves. In point mode you can change the curve alignment by 
dragging the points with the mouse. The curve leaves the start point P0 

in the direction of the control point P1 and arrives at the end point P3 

from the direction of the control point P2. These directions are shown 
in Draw by blue lines. The more distant a control is from its start or 
end point the smaller the curvature at that point. If a control point lies 
directly on one of these points, it has no infuence on the curve.

Direct drawing of a Bézier curve

Open the Curve toolbar by clicking on 

the small black triangle of the  
symbol on the Drawing toolbar. Click on 

the Curve icon . The mouse cursor 

changes to .

Click on the start point of the curve and 
keep the mouse button pressed (start 
and end points are shown here in the 
fgures as snap points).
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Drag the mouse to approximately the 
position of your frst control point. It 
does not matter if this is not exactly 
right as you can move the control point 
location later. If you hold the Shift key 
down while dragging, the control point 
will lie on a 45 degree grid.

Release the mouse button and move the 
mouse to the position of the end point of 
the curve. You can see that the line of 
the curve follows the movement of the 
mouse. Double-click at the end position.

Turn on point mode with the  icon 
from the Draw toolbar.

At the end of the curve you will see not 
only the end point but also an associated 
control point, the round handle. Hover 
the mouse cursor over this point; the 
cursor shape changes to show that you 
are in edit mode of a control point.

Now you can drag the control point to 
its correct position, if necessary.

Point mode of the Bézier curve
After drawing a curve using the  icon from the Draw toolbar or with 
the Edit points command from the context menu, you can bring the 
curve into a point mode from which you edit individual points on the 
curve. Points on the curve are shown with a square handle ; the 
control points with a round handle . The starting point of a curve 
appears somewhat larger than the other points. When you hover the 
mouse over a curve point the mouse cursor changes to  - over a 
control point it changes to . In point mode the toolbar Edit Points 
should appear. If not, turn it on from View > Toolbars > Edit Points.
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You can switch on the option All control points in Bézier editor under 
Tools > Options > OpenOfce.orgDraw > View. The default is to 
see the control points and guide lines only when a point is marked by 
clicking the point. By holding the Shift key down as you mark, you can 
select and mark several points at the same time. A marked point is 
shown a little darker .

Drawing a succession of Bézier curves
Several lines or Bézier curves can be linked together. The single parts 
are referred to as segments. Technically such a succession of Bézier 
curves and lines is known as a path.

Begin the drawing as with a simple Bézier curve. At the end position of 
the frst segment, end not with a double-click but with one of the 
following:

• Click on the end point of the frst segment but do not keep the 
mouse button pressed. In this way you produce a curve point 
which is both a control point for the frst segment and a control 
point for the second segment. This control point lies, however, on 
the actual curve point and so does not infuence the direction of 
the following curve segment. Move the mouse to the end position 
of the second segment. This segment appears to be a straight line 
but is in fact a Bézier curve. Either double-click to fnish the curve 
or repeat the above procedure to add successive segments.

or

• Go back and click once on the end point of the frst segment and 
keep the mouse button pressed. Now you can drag the initial 
control point for the second segment into place, as described 
above. Release the mouse button at the desired position of the 
control point and move the mouse to the end position of the 
second segment. The curve follows the line of movement of the 
mouse.

You can either end the drawing here with a double-click or continue 
and link in further segments.

To generate a closed curve, select the curve and click on the Close 

Bézier icon  on the Edit Points toolbar, or right-click and select 
Close object from the context menu.
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Transition points
For the transition from one segment to the next, there are three 
diferent types of points, each with its own properties.

Corner points
This is the only common point between two segments which are 
otherwise independent of each other. It is likely that the curve has a 
kink at this point (depending on the angle of the tangents, the lines 
from the corner point to each control point; see Figure 242).

Figure 242: Corner point

Smooth transition points
The tangent lines to the common point have the same angle and form a 
straight line. If you change the position of one of the control points the 
other also moves, so that the tangents remain in a straight line. This 
also applies to the case where a Bézier curve meets a straight line: the 
tangent line lies on the straight line and cannot be moved sideways.

Figure 243: Smooth transition point

Symmetric transition points
In this case the tangents not only lie on a straight line but the distance 
of the control points from the curve point is the same. The segments 
have the same direction and the same curvature at the transition point.

Figure 244: Symmetric transition point
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Changing point types
When a point is selected, the Edit Points toolbar activates the three 
corner point icons.

The circled icons are, from left to right, Corner point, Smooth 
transition, and Symmetric transition. The latter two icons appear the 
same but you can identify them by looking at the tooltip. At any time 
only one of the three icons will be active. To change the type of point, 
click on one of the other two icons.

Closing the curve
To close an open curve, use Close object from the context menu or the 
Close Bézier icon  from the Edit Points toolbar. A straight line is 
drawn between the start and end points if these points are Corner 
points.

If the start and end points are Smooth points or Symmetric points and 
the control point does not lie directly on the curve point, it changes 
position so it is in a straight line with the line segment and the closing 
line will be a curve (see Figure 245 for a comparison).

To prevent this happening, change the curve point type before closing 
to a corner point.

Figure 245: Close curve – start and end points are corner 
points (left), smooth or symmetric points (right)
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Transformation between straight line and Bézier 
curve

Transform a straight segment into a Bézier curve
Select the larger of the two handles at the ends of the straight line; 
this will be the starting point of the curve. After a short time the 

Convert to curve icon  on the Edit Points toolbar becomes active. It 
starts in the “out” position. Click the icon to turn on the function. The 
straight line is transformed into a Bézier curve. The type of the 
segment end point remains as it was. Using this function you can 
convert one side of a polygon or a part of a polyline into a Bézier curve.

Transform a Bézier curve into a straight segment
Select the larger of the two handles at the ends of the curve;  this will 
be the starting point of the straight segment. After a short time the 

Convert to curve icon  on the Edit Points toolbar becomes active. It 
starts in the “in” position. Click the icon to turn of the function. The 
Bézier curve segment is transformed into a straight line. The type of 
the segment end point remains as it was. If all segments are straight 
lines, Draw converts the object to a polygon or a polyline.

Transform complete curves, polylines and polygons

Transform a polygon or a polyline into a curve
Select the whole polygon or polyline. The object does not need to be in 
point mode. Choose Convert to curve from the context menu or the 
Modify menu. The points in the resulting curve are all of the type 
Corner point and the control points lie on the curve segments. All the 
segments thus appear as straight lines.

Transform a curve into a polygon or a polyline
Select the whole curve. Choose Convert to polygon from the context 
menu or the Modify menu. The curve does not need to be in point 
mode to do this. The individual segments are not replaced by straight 
lines. Instead additional points are generated on the curve so that the 
line of the polygon/polyline matches that of the curve as closely as 
possible. These points are placed closer together as the curvature 
increases.
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Freehand lines
You can also produce a curved line from a Bézier curve using the 
freehand line tool . This tool automatically inserts anchor points and 
control points to render the curve as close as possible to the original 
Bézier curve.

Place the mouse cursor at the beginning point and keep the mouse 
button pressed until you reach the end of the curve. As soon as you 
release the mouse button, the curve is complete.

Normal view Point mode 

Combining closed curves
If you draw a Bézier curve segment and, at the end point of the 
segment, click and hold the mouse button, followed by a single press of 
the Alt key, the curve is closed with a straight line and you are placed 
in Combining mode. You can now begin a second curve at an arbitrary 
point. Ending the drawing with a double-click also closes this curve. If 
you end it with an Alt-click as described above, you can draw further 
curves. The curves that you have just drawn form a common object, a 
so-called Combination. You can use this (for example) to place holes in 
flled curves.

If you want to bind two curves together into a Combination at some 
stage, select both curves and use Modify > Combine.

Even if you use a Combination, the individual curves are still available 
as objects. You can use Modify > Split to convert the Combination 
back to single objects.

You can create Combinations only from closed curves. Other objects, 
such as rectangles or polygons, will be automatically transformed into 
curves, and curves that are not closed will be closed with a straight 
line.
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Connecting curves
To join curves together, select them and use Modify > Connect. A 
connection is only possible with open curves. If you use this tool on 
closed curves, they are frst opened and an additional end point 
inserted at the starting point. A straight line is used to connect the 
curves.

The behavior of connected curves cannot (at present) be modifed. It is 
not obvious in advance how the transition properties of the connected 
curves are calculated, nor which end points will be connected.  It is 
therefore a good idea to work on a copy and try out the efect with 
diferent positions of the end points of the individual curves. To avoid 
changes to a shape, frst set the property of the new connection point 
to the type Corner point.

Adding comments to a drawing
Starting with OOo 3.2, Draw supports comments (formerly called 
notes) similar to those in Writer and Calc.

Choose Insert > Comment from the menu bar. A small box containing 
your initials appears in the upper left-hand corner of the Draw page, 
with a larger text box beside it. Draw has automatically added your 
name and the date at the bottom of this text box.

Type or paste your comment into the text box. You can optionally apply 
some basic formatting to parts of the text by selecting it, right-clicking, 
and choosing from the pop-up menu. From this menu, you can also 
delete the current comment, all the comments from the same author, 
or all the comments in the document.
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You can move the small comment markers to anywhere you wish on the 
page. Typically you might place it on or near an object you refer to in 
the comment.

To show or hide the comment markers, choose View > Comments.

Select Tools > Options > User Data to confgure the name you want 
to appear in the Author feld of the comment, or to change it.

If more than one person edits the document, each author is 
automatically allocated a diferent background color.

Connecting and breaking lines
It is possible in Draw to join separate line elements into one line. 
Select a number of lines and choose Modify > Connect. The lines are 
converted to curves and adjacent end points are joined together. The 
resulting shape is a polyline, not a closed shape.

To add text to the polyline, press F2 and type the text. To make a 
closed shape from the polyline, right-click the polyline and choose 
Close Object. You can add text and also change area properties and 
edit the object as with any polygon object. Note that you can only use 
the Close Object command on connected lines, freehand lines and 
unflled curves.

If you select a shape and choose Modify > Break, this does not 
reverse the Connect process but simply converts the polygon into a 
collection of individual lines. Text added to the shape will be associated 
with one of the lines (often the last one). You cannot apply a fll to a 
closed shape made up of lines resulting from the Break command.
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addition to draw objects  33
dynamic frames  32
fxed frames  33

text styles  200
textures of 3D objects  137
threshold, apply   108
tile size  111

226 OpenOfce.org 3.x Draw Guide



tolerance parameter  107
toolbars  12

basic shapes  30
block arrows  31
callouts  31
circles and ovals  26
connectors  28
curves  26
drawing  20
Edit Points  48, 49
fowcharts  31
lines and arrows   23
stars and banners  31
symbol shapes  30
text formatting  32

transition points  217
transparency  70, 76, 97, 99, 105, 146

U  
ungrouping  79

V  
vector graphics  7
vectorize  110, 113
vertical distribution of objects  88
vertical text  206

W  
wiring diagram  186
workplace  8
Writer OLE object  211

Z  
zoom  11
Zoom toolbar  149, 189
zoom value  148

Index 227


	Chapter 1
  Introducing Draw
	Introduction
	The Draw workplace
	Rulers
	Status bar
	Toolbars
	Standard toolbar
	Line and Filling toolbar
	Drawing toolbar
	Color bar
	Choosing a color palette

	Options toolbar

	Drawing grid and guides
	Floating and moving toolbars
	Customizing toolbars

	Chapter 2
  Drawing Basic Shapes
	Creating simple drawings
	Custom shapes
	Drawing basic shapes
	Drawing a straight line
	Drawing an arrow
	Drawing lines and arrows
	Drawing a rectangle or square
	Drawing ellipses (ovals) and circles
	Adding ellipse and arc tools to the Drawing toolbar
	Drawing elliptical and circular arcs
	Curves

	Gluepoints and connectors (basics)
	Gluepoints
	Connectors

	Drawing geometric shapes
	Basic shapes
	Symbol shapes
	Block arrows
	Flowcharts
	Callouts
	Stars and banners

	Adding text to objects
	Using dynamic text frames
	Using text elements in Draw objects


	Chapter 3
  Working with Objects and Object Points
	Introduction
	Selection modes
	Changing the selection mode
	Selecting objects
	Direct selection
	Selection by framing

	Selecting hidden objects
	Arranging objects


	Moving and dynamically adjusting an object’s size
	Dynamic movement of objects
	Dynamic size modification of objects
	Dynamic size modification of objects with the help of the status bar
	Modifying an arc

	Rotating and shearing an object using the mouse
	Rotating
	Changing inclination or perspective

	Setting size and position exactly
	Position and Size
	Rotating objects
	Slant and corner radius

	Editing object points
	An alternative way to change the form of basic shapes
	How curves work
	The Edit Points toolbar
	The three kinds of tangent
	Examples


	Chapter 4
   Changing Object Attributes
	Toolbars and menus
	Line and Filling toolbar
	Text Formatting toolbar
	The context menu

	Editing lines and borders
	Common line properties
	Drawing arrows
	Customizing line and arrow styles
	Customizing line styles
	Customizing arrow styles


	Editing the inside (fill) of an object
	Common fill properties
	Fill with a uniform color
	Fill with a gradient
	Fill with a line pattern
	Fill with an image

	Adding a shadow
	Advanced area fill options
	Creating your own fill color
	Creating your own gradient
	Creating your own hatching (line pattern)
	Creating your own bitmap fill

	Customizing shadows
	Adding transparency

	Using styles
	Creating a new style
	Applying a style
	Modifying a style

	Special effects
	Rotating an object
	Flip an object
	Mirror copies
	Distorting an image
	Distort an object
	Set in circle (perspective)
	Set to circle (slant)

	Dynamic gradients


	Chapter 5
  Combining Multiple Objects
	Introduction: grouping and combining objects
	Grouping objects
	Grouping by common selection
	Maintaining groups and undoing groups
	Editing individual objects in a group
	Nesting groups

	Combining objects
	Merging, subtracting, or intersecting shapes
	Merge
	Subtract
	Intersect
	Practical example

	Aids for positioning objects
	Moving an object to the front or to the back
	Aligning objects
	Distributing the distance and space between objects


	Chapter 6
  Editing Pictures (Raster Graphics)
	Introduction
	Importing raster and vector graphics
	To link or to embed?
	Scanning
	Pasting from the clipboard
	Dragging and dropping
	Inserting from a file

	Exporting graphics
	Exporting the entire file
	Exporting single objects
	Exporting as a vector graphic
	Exporting as a raster graphic

	Modifying raster object properties
	The picture (editing) toolbar
	Cropping
	The graphic filter toolbar
	Eyedropper
	Practical example: Changing wrong colors to transparency
	Effect of the tolerance parameter
	Color depth
	Reducing color depth


	Conversion
	Convert to a contoured image
	Convert to a polygon
	Number of colors
	Point reduction
	Fill holes

	Convert to bitmap

	Print options with raster graphics

	Chapter 7
 Working with 3D Objects
	Creating 3D objects
	Creating 3D bodies
	Variation 1: Extrusion
	Variation 2: Body rotation
	Variation 3: Using ready-made objects

	3D scenes
	Producing 3D shapes
	Variation 4: Extrusion of shapes
	Variation 5: Fontwork


	Editing 3D objects
	Rotating 3D objects
	Procedure for 3D bodies
	Procedure for 3D shapes

	3D settings for 3D bodies
	3D Effects dialog – general buttons
	3D Effects - Geometry
	3D Effects - Shading
	3D Effects - Illumination
	3D Effects - Textures
	3D Effects - Material

	3D settings for 3D shapes

	Combining objects in 3D scenes
	Examples for your own experiments


	Chapter 8
  Tips and Tricks
	Positioning objects with zoom
	Zoom adjustments using the status bar
	The Zoom toolbar

	Positioning objects with snap functions
	Snap to grid
	Showing the grid
	Changing the color of the grid points
	Configuring the grid

	Snap to Snap objects (snap lines and snap points)
	Inserting a snap line with the mouse
	Inserting snap points and snap lines using coordinates
	Editing snap points and snap lines

	Snap to page edge
	Snap to object border
	Snap to object points
	Help to position objects with guiding lines

	Drawing to scale
	Splitting drawings on multiple layers
	An example drawing: house plan and furniture
	Changing the layer of a drawing object

	Creating a multi-page document
	Using the Pages area
	Using page backgrounds
	Creating a page background
	Assigning and managing page backgrounds


	Color palette: adding or changing single colors
	Changing colors using the Color dialog
	Creating cool effects
	Duplication
	Cross-fading
	Which object goes in front?



	Chapter 9
  Organization Charts, Flow Diagrams, and More
	Drawing an organization chart
	Drawing a flow diagram
	Glue points and connectors
	The Connector toolbar
	Drawing connectors—basics
	Editing glue points

	Adding text to connectors
	Adjusting text to suit the connecting line


	Chapter 10
  Advanced Draw Techniques
	Drawing to scale
	Working with the Position and Size dialog
	Setting glue points
	Copying individual pictures to the Gallery
	Drawing a logic circuit diagram using the Gallery

	Dimensioning a drawing
	Configuring the dimensioning style
	Dimensioning objects
	Editing dimension lines

	Working with text in Draw
	Configuring text elements with styles
	Text animation
	Text
	Anchoring text
	Fitting text in frames
	Distance from frame

	Text frames and callouts
	Pictures and text
	Fontwork Gallery
	Writer OLE object
	Insert
	Editing mode
	Object mode


	Guide to Bézier curves
	Bézier curves—what are they?
	Direct drawing of a Bézier curve
	Point mode of the Bézier curve
	Drawing a succession of Bézier curves
	Transition points
	Corner points
	Smooth transition points
	Symmetric transition points
	Changing point types

	Closing the curve
	Transformation between straight line and Bézier curve
	Transform a straight segment into a Bézier curve
	Transform a Bézier curve into a straight segment

	Transform complete curves, polylines and polygons
	Transform a polygon or a polyline into a curve
	Transform a curve into a polygon or a polyline

	Freehand lines
	Combining closed curves
	Connecting curves

	Adding comments to a drawing
	Connecting and breaking lines

	Index

